Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

w2k8 R2 64bit. Unable to get external file version from EMM database

Created: 07 Mar 2013 • Updated: 07 May 2013 | 8 comments
This issue has been solved. See solution.

this is new fresh installed NBU 7.5.0.4 Master on w2k8 R2 64 bit SP1.

 

Problem:

 

  • Sometime the nbu event daemon stopped itself immediately after it was started. Same as manually started it, it just stop again. Meanwhile, the Windows application event logs generated alot of [EMM interface initialization failed, status = 334].

 

  • Each time after the Master server is rebooted, from Windows application event logs showed, the error of [Unable to get external file version from EMM database] .

below is the picture captured, with ODBC data source status.

 

Discussion Filed Under:

Comments 8 CommentsJump to latest comment

seanwong's picture
  • there are also "countless" of nbproxy.exe running (kept generating new) in the OS process.
  • attached installlog.

 

 

AttachmentSize
BKUPINST_HT2.7z 70.09 KB
seanwong's picture

 

  • Is the daemon " ltid " suppose to start on a new installed NBU Master? This is captured from the new master..
 
 
D:\apps\Veritas\NetBackup\bin>bpps
* SGGSINTSYSMS007                                        3/07/13 21:54:08.417
COMMAND           PID      LOAD             TIME   MEM                  START
vnetd            2168    0.000%            0.078   12M   3/07/13 21:52:12.980
bpinetd          2772    0.000%            0.109   12M   3/07/13 21:52:13.183
bpcd            10508    0.000%            0.078   15M   3/07/13 21:52:13.355
nbevtmgr        12124    0.000%            0.374   24M   3/07/13 21:52:13.604
dbsrv11         12152    0.000%            1.216   42M   3/07/13 21:52:19.003
nbemm            1980    0.000%            0.842   46M   3/07/13 21:52:19.892
nbrb             6868    0.000%            0.405   35M   3/07/13 21:52:25.274
vmd             11936    0.000%            0.234   20M   3/07/13 21:52:28.145
ltid            11232    0.000%            0.156   20M   3/07/13 21:52:30.688
nbrmms          10896    0.000%            1.092   33M   3/07/13 21:52:30.969
nbcssc           1604    0.000%            0.530   10M   3/07/13 21:52:35.088
nbaudit          1172    0.000%            1.731   33M   3/07/13 21:52:35.353
bpdbm            9628    0.000%            0.140   21M   3/07/13 21:52:40.283
bpcompatd        9808    0.000%            0.109   17M   3/07/13 21:52:40.502
bpjobd           3740    0.000%            0.202   33M   3/07/13 21:52:40.611
bprd            10876    0.000%            0.140   23M   3/07/13 21:52:40.673
nbjm            11084    0.000%            0.483   29M   3/07/13 21:52:40.970
nbpem           10176    1.538%            0.764   31M   3/07/13 21:52:45.994
nbproxy         10916    0.000%            0.156   22M   3/07/13 21:52:51.220
nbsl            10296    0.000%            0.312   33M   3/07/13 21:52:51.282
nbproxy         10924    0.000%            0.156   22M   3/07/13 21:52:53.280
nbvault         12188    0.000%            0.343   23M   3/07/13 21:52:55.183
nbstserv        11868    0.000%            0.561   35M   3/07/13 21:53:06.931
nbproxy          3836    0.000%            0.156   22M   3/07/13 21:53:07.071
nbars           11604    0.000%            0.624   35M   3/07/13 21:53:12.688
nbsvcmon        10784    0.000%            0.421   22M   3/07/13 21:53:18.133
nbproxy         10844    0.000%            0.156   22M   3/07/13 21:53:18.897
nbim             5620    0.000%            0.561   37M   3/07/13 21:53:21.378
bmrd             3612    0.000%            0.187   23M   3/07/13 21:53:26.730
nbproxy          9916    0.000%            0.140   22M   3/07/13 21:53:33.376
nbproxy          5544    0.000%            0.140   22M   3/07/13 21:53:48.166
nbproxy          4108    0.000%            0.140   22M   3/07/13 21:54:02.941
bpps            11408    0.000%            0.358   10M   3/07/13 21:54:07.044
 
D:\apps\Veritas\NetBackup\bin>
 
 
  • I've another testing machine (w2k3 R2 64 bit SP2). This server also setup as new Master 7.5.0.4 as well, without any problem at all. (I don't see any "ltid" daemons started on it.
 
 
E:\apps\Veritas\NetBackup\bin>bpps
* INGBTCPIC7MS026                                        3/07/13 19:26:37.171
COMMAND           PID      LOAD             TIME   MEM                  START
dbsrv11          5540    0.000%           15.343   46M   3/07/13 14:06:46.799
vnetd            7768    0.000%            0.031  6.7M   3/07/13 14:06:59.064
bpinetd          8040    0.000%            1.437  9.5M   3/07/13 14:06:59.158
bpcd             8440    0.000%            0.156  8.7M   3/07/13 14:06:59.736
bpdbm            1336    0.000%            0.218   15M   3/07/13 14:06:59.986
bpcompatd        1536    0.000%            0.093   12M   3/07/13 14:07:00.627
nbsvcmon         6044    0.000%            0.296   20M   3/07/13 14:07:00.705
bpjobd            924    0.000%            0.750   25M   3/07/13 14:07:00.736
vmd              6256    0.000%            0.546   15M   3/07/13 14:07:00.892
bprd             6440    0.000%            0.203   17M   3/07/13 14:07:00.970
nbvault          7984    0.000%            0.250   21M   3/07/13 14:07:01.439
nbsl             7100    0.000%            2.281   34M   3/07/13 14:07:01.689
nbevtmgr         1136    0.000%            0.656   26M   3/07/13 14:07:02.861
nbrmms           5164    0.000%            0.718   30M   3/07/13 14:07:03.549
nbaudit          7000    0.000%            0.562   27M   3/07/13 14:07:04.236
nbpem            5044    0.000%            0.640   30M   3/07/13 14:07:04.470
nbjm             7520    0.000%            1.140   28M   3/07/13 14:07:05.424
nbstserv         9104    0.000%            1.531   29M   3/07/13 14:07:06.439
nbars            7332    0.000%            0.531   28M   3/07/13 14:07:06.908
nbproxy          6468    0.000%            0.171   23M   3/07/13 14:07:07.830
nbemm            6388    0.000%            4.250   43M   3/07/13 14:07:09.189
nbrb             4716    0.000%            0.765   30M   3/07/13 14:07:09.799
nbim             7128    0.000%            0.437   30M   3/07/13 14:07:10.111
nbproxy          8572    0.000%            0.140   20M   3/07/13 14:07:11.236
nbproxy          4704    0.000%            0.171   20M   3/07/13 14:27:08.752
nbproxy          5004    0.000%            0.125   20M   3/07/13 16:48:03.702
bpps             8776    0.000%            0.031  5.7M   3/07/13 19:26:36.108
 
E:\apps\Veritas\NetBackup\bin>
 
  • On the same problematic Master server,It was installed with RHEL 5 (Linux)&  NetBackup Master 7.5.0.4, the problem was (Still has problem) during the NBU 7.5 base software installation process reached ~95% completion  (Upgrading NBDB...),this context was halt / stagnant for about 10 minutes prior to display next of error msg : " EMM interface initialization failed, status = 77 " -- eventually the installation was showed  "completed". One support ticket was lodged with Symantec, this ticket is recently closed due to the time line of tasking is limited and behind scheduled, and also the server is re-formated into Windows 2k8 now. Unfortunately, does not expect this problem (From the same machine) hit the Windows platform as well at the moment. Other chained problems are: Failed to complete the NBU 7.5.0.4 CLT patching (Baseline package patching completed successfully). And found out the " ltid " service (started) appearred on this machine, when all NBU services started.

 

 

  • The possible root cause, could be between the OS -- routing table configuration &/or the existing of other enabled NIC interfaces installed on the server, that corresponded withe NBU 7.x application (e.g. currently there are 3 active NIC; only one is designated for application network interface). Quick win is = disabling other NIC except for the one used by NBU application + killed all 'nbproxy.exe' processes.

If the NIC are diabled but without killing all nbproxy processes, the attached picture showed the error msg would occur during the attempt of opening the host properties in the GUI.

Status = (0) COMM_FAILURE (IDL:omg.org/COBRA/COMM_FAILURE:1.0)

 

  • Does anyone, know about the NBU communicating behaviour (While attempts to open the Host > Master > properties panel?) especially the server has more than one NIC enabled?

NOTE: The NBU application uses the NIC, is confirmed not a teaming.

ScreenShot2013-03-11-112948.png
RamNagalla's picture

hi 

litd should only required to run if robot or tape drives configured on that server..

I would suggest you to go with symantec support case for this issue.. 

seanwong's picture

i stumbled to this KB = [http://www.symantec.com/docs/TECH51026], deployed the KB advice and in progress of monitoring.

DOCUMENTATION: When connecting to host properties/master server, the following error are received: "unable to connect to EMM server (77)" and "EMM interface initialization failed, status = 334"

 
 
Problem
 
- Unable to connect to EMM server (77)
- EMM interface initialization failed, status = 334
- Netbackup Event Manager service won't start
- Lots of nbproxy processes are running
 
 
Cause
 
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG\ 
"CLIENT_PORT_WINDOW" has changed to 1024 1024 from 0 0
 
 
 
Administrators can correct this issue by editing the following registry setting:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG 
CLIENT_PORT_WINDOW=1024 1024 (This is wrong)
 
The modified line setting should contain a =0 0 or another desired port range.  Example using 0 0 is as follows:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG 
CLIENT_PORT_WINDOW=0 0
 
 
 
Solution
 
  • Administrators can correct this issue by editing the following registry setting:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG 
CLIENT_PORT_WINDOW=1024 1024 (This is wrong)
 
  • The modified line setting should contain a =0 0 or another desired port range.  Example using 0 0 is as follows:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG 
CLIENT_PORT_WINDOW=0 0

 

Anshu Pathak's picture

You can try that technote, it could he helpful in your case.

The error that you are getting is mostly because of name resolution and aliases problem.

Check these files and make sure all of them are using same name.

server.conf (windows: <installpath>\netbackupdb\config -- Unix: /usr/openv/var/global)

vxdbms.conf  (windows: <installpath>\netbackupdb\data -- Unix: /usr/openv/db/data)

bp.conf ( windows: registry -- Unix: /usr/openv/netbackup)

hosts file (unix: /etc/hosts)

 

Anshu Pathak

seanwong's picture

 

  • These 2 are the same names = <short host name>

server.conf (windows: <installpath>\netbackupdb\config -- Unix: /usr/openv/var/global)

vxdbms.conf  (windows: <installpath>\netbackupdb\data -- Unix: /usr/openv/db/data)

  • These 2 are the same names (But different from above 2) = <FQDN>

bp.conf ( windows: registry -- Unix: /usr/openv/netbackup)

hosts file (unix: /etc/hosts)

 

All of these <names> are detected / generated by NBU software itself during the Master base installation, except for the 'hosts' file which was added manually.

 

 

ScreenShot2013-03-12-150234.png ScreenShot2013-03-12-150443.png
Anshu Pathak's picture

As it a fresh install we have two options

Option 1: Reinstall NetBackup and this time use short name for master server during install

Option 2: Change registry "server", "client" and "emmserver" entry to use short name. Also change /etc/hosts file to have short name as alias or you udpate the host file in such a way that short name gets preference.

Example:

1.1.1.1  short

1.1.1.1  short.local.com

Anshu Pathak

seanwong's picture

this should the culprit to be rectified.

 

 

 

http://www.symantec.com/docs/TECH153520
http://search.sybase.com/kbx/changerequests?bug_id=646169
SOLUTION