Video Screencast Help

Wait on External Event

Created: 01 Feb 2009 • Updated: 21 May 2010 | 5 comments

I need some help using the Wait on External Event component. I created a workflow and it appears the start process runs fine, but the wait process never executes. I have the time between checks at 5 minutes and timeout at 10. I added a log in the wait process and it's never executing. It works fine when I run it in debug, but when I run it as a web service, it doesn't work.

Discussion Filed Under:

Comments 5 CommentsJump to latest comment

cenovio's picture

I am also having a problem with an external event. I am using a new file auto start and it works fine in debug mode but once I publish it doesn't work. I called support. If I learn anything helpful I will post it.

aphud's picture

I had the same issue, I am using Workflow Advanced and was able to resolve the issue with the help of a Workflow contact at Symantec. Go into your Task Tray application (guy with the green shirt icon)right click and go to Settings. Once inside about half way down there is a Workflow Server Configuration, click the elipse to the right. Under the Webservice Auto Invoke section, there is a Manual Setup Info: , click the elipse to the right there. (Make sure Run WebServices is checked , but mainily what I had to do was create a local account on the server, give it admin rights locally *domain account didnt work), then use that account under Use Specific Credentials:
Also just below Manual Setup Info: there is a check box for HTTP Authenication, below that for Username and Password: use your local account you created here also. Click OK and Save, then restart Server Extensions (if it doesnt automatically) . Then deploy your process and see if that works.

APHUD

cenovio's picture

Thanks for the advice. Tried this and it still doesn't work when deployed. Hopefully support guys can fix me!

lone_ranger's picture

Any update on this? I published an Auto Start workflow today that starts with an Auto Start E-mail. It works fine in debugin but not when published. I will they this suggestion above to see if it resolves my issue.

lone_ranger's picture

Thanks for the pointer aphud. I made the adjustments, but it's still not working.