Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Waiting for retry job in activty monitor

Created: 14 Jun 2012 • Updated: 09 Jul 2012 | 6 comments
mansoor.sheik's picture
This issue has been solved. See solution.

Hi,

In my activity monitor i have some job called waiting for retry. How to remove that?

Comments 6 CommentsJump to latest comment

Marianne's picture

Status 50?

This one is asked about once a week!

http://www.symantec.com/docs/TECH43177

http://www.symantec.com/docs/TECH163191

http://www.symantec.com/docs/TECH146990

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

As Marianne says it comes up all of the time this one

There is a bug with a fix listed in the Late Breaking News but more often than not it is down to something crashing somewhere.

To actaully clear them i have found the method that never fails is as follows:

1. Make a note of all of the job id's involved

2. shut down NetBackup on the Master

3. Go to \netbackup\db\jobs\ and delete the bpjobd.act.db (make sure you do not delete the bpjobd.db !!)

4. Go to NetBackup\db\jobs\ffilelogs\ and delete all the files with the number that matches your job id's

5. Go to NetBackup\db\jobs\trylogs\ and delete all the files with the number that matches your job id's

6. Start NetBackup up again - all done

Of course what you need to do then is find out why they are happening - server being rebooted, processes crashing etc. Check your logs and event logs for clues

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
captain jack sparrow's picture

Make a note of all the JOBID showing waiting for retry

Stop NBU services on master (execute bpps -a to check if process are not in hung state)

RUN CMD with administrative privileges

execute netbackup/bin/bpjobd -r <jobid>

This would confirm you for removal.acknowledge it. and remove all the JOBID showing as waiting for retry.

After done with removal. ..Start NBU service and check if they do exists or are gone :-)

 Cheers !!!

CJS

mansoor.sheik's picture

Hi all,

Will update the status once done. Thanks in Advance

captain jack sparrow's picture

is issue resolved.. If so mark the post that had helped you

 Cheers !!!

CJS