Video Screencast Help

WDE 9.7 + error Unable to commit disk

Created: 07 Apr 2014 | 13 comments

Being using PGP WDE on a Server 2008 box for the last number of years on a perpetual license.

We copy our end of month backups onto encrypted disks.

Recently the PGP software stopped allowing us to encrypt disks with the error message

Unable to commit disk.

This error occurs within 3 seconds of clicking on Encrypt disk.

The disks are external 2TB USB disks and have being working fine for the last 12 months as we have being using the same model of disk.

No events in the WDE logs, Windows Server log etc.

We have tried formating the USB drive and also confirmed that we can copy data onto the disk.

I realise the edition of software is out of support, but we cannot get an OK for a new PO for a newer release until we find the issue with the encryption software.

We can connect older disks that have ebing encrypted and read them sucessfully.

Also tried installing the software on a new PC as a test, but getting the same error.

Operating Systems:

Comments 13 CommentsJump to latest comment

R_Fernandes's picture


We have a ongoing Feature Request for 2TB + encryption :

Do let us know the version of PGP Desktop. 

The make and model of the external hard drive. 

The make and model of the external hard drive  that got encrypted before (was this 2 TB too ? )

There is an Article for this error too : TECH166276

if/when you consider your issue is resolved, please click "Mark As Solution" on a response
Wobble Wobble's picture


Info as follows;

Desktop version 9.7, 9.7.1[Build 1503]

PGP SDK 3.9.1

Hard drives are Seagate STBV2000200 -2TB disks, 1.8TB usable, have being in use since July 2013.

Previous to that we were using Seagate 1D7AP2-500 - 500GB disks.

But we cannot even encrypt a 500GB disk now!


dcats's picture

Hi  Joe,

Please have a look at this article: Unable to commit disk - TECH166276 and then this one Best Practices: Symantec Drive Encryption - TECH149543. Perhaps it was converted to dynamic.

Open a command prompt (CMD), select your disk and see the details.
DISKPART> list disk
DISKPART> select disk <disk number here>
DISKPART> detail disk

DISKPART> list partition
DISKPART> select partition <partition number here>
DISKPART> detail partition

DISKPART> list volume
DISKPART> select volume <volume number here>
DISKPART> detail volume


Wobble Wobble's picture

Checked the disk that it was not dynamic, details below.

Tried reducing the partition size to 1.5TB, 900GB, 500GB, (mulitple 500GB and a single 500GB partition) but cannot encrypt the disk, same error cannot commit disk.

Tried a 500GB disk and I can encrypt that.

Anyway to find out what the difference is in an older 2TB disk that we could encrypt and the new order that we cannot encrypt?

Also, any reason why reducing the parting as per

and encryption not working?

Detail Disk for the 2TB disk.

DISKPART> detail disk

Seagate Expansion Desk USB Device
Disk ID: 16038A23
Type   : USB
Status : Online
Path   : 0
Target : 0
LUN ID : 0
Location Path : UNAVAILABLE
Current Read-only State : No
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 5     G   Disk03  NTFS   Partition   1863 GB  Healthy


DISKPART> detail partition

Partition 1
Type  : 07
Hidden: No
Active: No
Offset in Bytes: 8388608

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
* Volume 5     G   Disk03  NTFS   Partition   1863 GB  Healthy


DISKPART> detail volume

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
* Disk 2    Online         1863 GB    15 MB

Read-only              : No
Hidden                 : No
No Default Drive Letter: No
Shadow Copy            : No
Offline                : No
BitLocker Encrypted    : No
Installable            : Yes

Volume Capacity        : 1862 GB
Volume Free Space      : 1862 GB

Wobble Wobble's picture

We took a 2TB Seagate disk, not a disk from an External USB device, but a space SATA disk, and that encrypts.

The plot thickens.

dcats's picture

Hi Joe,

What I find strange is this:
"Location Path : UNAVAILABLE"

Perhaps you will need to mount the disk in the diskmgmt.msc console.


Wobble Wobble's picture

I've being able to connect and see the different configs of the disk in Disk Management for the whole time.

Logged a case with Seagate, potentially an issue with the USB hardware as opposed to the disk...

dcats's picture

Hi Joe,

Perhaps connecting to another USB port and/or updating drivers could make a difference.


Wobble Wobble's picture

We have one server that is used for the backups and the encryption and this has not being updated recently.

we have tried it on a few other test machines al lto no avail.

As I mentioned we can encrypt a Seagate 2TB (1.8TB usable) SATA disk in a USB caddy, but not a Seagate External 2TB USB disk.

Wobble Wobble's picture

We got more curious and did some more tests.

Taking the 2TB disk out of the Seagate 2TB External Caddy, the disk had a 63GB partition, RAW format.

Encrypting a SATA Seagate Baracuda disk and then placing it into the Seagate USB External caddy, we could not read the disk at all.

Full results attached.

Opened a ticket with Seagate, but they said it was a software vendor issue.

Will attempt to re-open the ticket with Seagate or open a new ticket.

Issue encrypting Seagate Disks.docx 215.59 KB
dcats's picture

Hi Joe,

I noticed that the disk ID in the last combination is 00000001 when I expected it to be A92A2189 (as in the previous test).
Could you check if you have conflicts with existing disk IDs?
Are these disks clones?
Have you tried in other USB ports (and/or in USB 2.0 instead of 3.0)?

Could you check if you need updated drivers for that disk/system?
Not sure if this helps, but here it goes (external link):


dcats's picture

Hi Joe,

A quick update.
I tested a generic thumb drive and an external disk and both have: "Location Path : UNAVAILABLE"

It seems normal for USB-attached devices.


PGP_Ben's picture

I'm surprised nobody has suggested on here yet to try updating the client. PGP 9.7 is several years old and also not technically supported anymore. As a matter of fact, everything version 9.x has not supported since 2011.. Also PGP 9.7 was not officially supported on Server 2008. Reference cited (9.7 release notes):

Maybe this was a problem with the version of server and PGP 9.7 and an update might help you? We have done some very recent fixes related to certain 3TB and 2TB disk drives not encrypting correctly in the UI on 10.3.2 release.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.