Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Weird LiveUpdate Behavior

Created: 17 Apr 2013 • Updated: 17 Apr 2013 | 11 comments
D@ry1's picture

Hey Guys,

We have this weird LiveUpdate behavior here, when we try to use the liveupdate on the right upper part of the SEPM console on the home page it gives an error of code=4, but when we use the luall.exe as administrator on the symantec directory it do update with no problem, it also means we dont have proxy problem at all.

NOTE: We're running 12.1.2 on Windows Server 2012

Thanks,

Comments 11 CommentsJump to latest comment

.Brian's picture

What version of SEPM is this on?

See if this helps:

SEP12.1 RU1,LiveUpdate returns result as no updates available

Article:TECH158336  |  Created: 2011-04-19  |  Updated: 2012-10-05  |  Article URL http://www.symantec.com/docs/TECH158336

If this doesn't work you may need to reinstall and re-register LU with the SEPM

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

D@ry1's picture

we're running 12.1.2 on Windows Server 2012,. Also I already tried this before when we we're troubleshooting the live update problem it self,. when it was not updating at all.

Thanks,

W007's picture

hello,

"Error: LiveUpdate encountered one or more errors. Return code = 4" in LiveUpdate status in Symantec Endpoint Protection Manager

http://www.symantec.com/business/support/index?page=content&id=TECH103112

also look this discussion

https://www-secure.symantec.com/connect/forums/sepm-v-121-ru1-liveupdate-return-error-code-4-live-updating

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Ambesh_444's picture

Hello,

Please try with this article.

https://www-secure.symantec.com/connect/forums/error-liveupdate-encountered-one-or-more-errors-return-code-4-liveupdate-status-symantec-endp

"Error: LiveUpdate encountered one or more errors. Return code = 4" in LiveUpdate status in Symantec Endpoint Protection Manager

http://www.symantec.com/business/support/index?page=content&id=TECH103112

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

Rafeeq's picture

use the liveupdate on the right upper part of the SEPM console on the home page it gives an error of code=4,

===> this will use System account. Check if that has access to internet

running Lu uses currently logged in account. I think thats why first one is failing.

check this once.

Symantec Endpoint Protection Manager fails to update its definitions, error message "PrepareLUDownloads was not run. Skipping PostSession work"

 

http://www.symantec.com/business/support/index?page=content&id=TECH131478

D@ry1's picture

Hey,

I think you're the close one yet, I'll check the SEPM  later this day and post an update.

Thanks,

Mithun Sanghavi's picture

Hello,

LiveUpdate encountered one or more errors Return code = 4 is a Generic Error.

Could you please upload the log.liveupdate?

That would help us understand the root cause of the issue.

Again, are you using any proxy?

Did you try disabling the Windows Firewall on the machine and checked ?

Also, When uninstalling and reinstalling LiveUpdate, are you using the correct client for SEP 12.1?  

http://www.symantec.com/business/support/index?page=content&id=TECH171060

Make sure you are using Liveupdate version 3.3.1.23- nothing earlier!

Windows LiveUpdate Client for Use with Symantec Endpoint Protection Manager 12.1
Article: TECH181305   |  Created: 2012-02-13   |  Updated: 2012-03-21   | 
Article URL http://www.symantec.com/docs/TECH181305

Also, check the Proxy settings in SEPM 12.1 if they are correct?

How to Update the Proxy settings in the Symantec Endpoint Protection Manager (SEPM) 12.1

https://www-secure.symantec.com/connect/articles/how-configure-proxy-settings-symantec-endpoint-protection-manager-sepm-121

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SebastianZ's picture

What are the proxy settings for liveupdate connections in the SEPM? The fact that running luall.exe is successful but update from SEPM console level fails would indicate there is some misconfiguration on the SEPM side regarding this - check in

  1. SEPM -> Admin -> Servers
  2. select the name of the manager server under local site
  3. After selecting your server, in the tasks pane, click on Edit the Server Properties, a dialog box will open up
  4. Click on Proxy Server -> check the properties here
D@ry1's picture

we're using domain account but we dont have any active directory linked on the SEPM yet, is it possible the reason for that?

Mithun Sanghavi's picture

Hello,

Using the Domain Account for SEPM authentication and Syncing the AD groups with SEPM are not related.

You may choose either or both of them.

Secondly, it is not inreference to your Liveupdate issue.

Are you using any Proxy? If yes, check the Proxy configuration and authentication set correctly.

How to Update the Proxy settings in the Symantec Endpoint Protection Manager (SEPM) 12.1

https://www-secure.symantec.com/connect/articles/how-configure-proxy-settings-symantec-endpoint-protection-manager-sepm-121

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.