Video Screencast Help

What is the default NDMP tape reservation method utilized by BE2012?

Created: 26 Apr 2013 • Updated: 26 Apr 2013 | 2 comments

Hi all,

 

I hope this is an easy question, but I've yet to find the right documentation on the matter so I thought I would turn here. Right now my environment looks like this:

Brocade SAN 4gb Fiber Channel Switch

2x Netapp Filers running OnTap 8.1

2x IBM LTO4 Tape drives in a Quantum i6k tape library

1x Dell server running Windows Server 2008 R2 w/ Backup Exec 2012 (fully patched)

 

Between Netapp1 and Netapp2 I have 8 backup jobs on each filer. These backup jobs are seperated by data type, and there are 4 different media sets utilized between the 2 filers. The issue I'm seeing has to do with reservations. I'm having an issue with tape drives consistantly going offline during my weekly full backups as when 1 job finishes from 1 filer and another job begins that belongs to the other filer, it encounters a reservation conflict and takes the drive offline. The only way I've gotten around this is by assigning all jobs from Netapp1 to Drive1, and all jobs from Netapp2 to Drive2. Even further, I've had to create seperate Media Sets for backup jobs from each.

This segregation is hurting my backup performance, as the backup jobs cannot share the tape drive cluster. Right now, the Netapp is set to *no* tape drive reservation system - I am willing to change it to SCSI or persistant reservations but I need to know which Backup Exec 2012 uses by default. I have a hunch that correcting this should resolve my issues. 

Operating Systems:

Comments 2 CommentsJump to latest comment

teiva-boy's picture

Most backup software will support persistent reservations. I always use that when talking FC tape.

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."

Colin Weaver's picture

We had a condition a while ago (much older version of Backup Exec) where we had an issue with 2x NetApps sharing one library where the job on NetApp 1 would run, the job on NetApp2 that used the same media set as the original NetApp1 job then starts and because it is an append to the same media set and the last place the specific piece of media was mounted was NetApp1, the NetApp2 job then does a 3-way backlup (data from NetApp2 is passed via NetApp1 to the tape instead of directly.)

The solution to this was always use different media sets for the two filers and start the first job each day on each filer as an overwrite. (EDIT: and do not put Netapp 1 and Netapp 2 into 1 backup job - pre BE 2012 comment)

My guess is you are running into a related issue with the newer version of Backup Exec that has the same background cause just slightly different symptoms.

 

EDIT2: I found the original public article http://www.symantec.com/docs/TECH69446