Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

What makes a WSE/WSI start automatically when Windows restarts

Created: 23 Jan 2013 | 3 comments

I have an install written in Wise Installation Studio 7.  We recently added a check to the WSE that checks for the .Net Framework 4.0.  If it's not there I give a message and do an exit installation.  So I run my install and get the message about no framework.  Then I run the Microsoft standalone install for .Net 4.0.  It doesn't ask to reboot in XP, but I do anyway.  Once I restart and log back in, it kicks off my install again and evntually brings up the Windows Installer  command line parameter screen for some reason.  Does exit install not really exit or is something else hanging around.  Where do I look or what can I clear so this doesn't happen.

Thanks.

Phil

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

EdT's picture

There is insufficient information in your posting to determine a cause. Did you run the install manually or via a deployment system?

When you say "Then I run the Microsoft standalone install for .Net 4.0" are you saying that you ran it manually or that the installer actually ran it?

Exit install does exit the install, but since we cannot see the logic in your Wisescript wrapper, it is impossible to determine what is restarting your install when you log back in again.

All I can say is that there is some sort of error in your install and you need to add some logging information into the Wisescript code so that you can record exactly what is going on.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

pbishop's picture

I ran the install manually by double clicking the EXE. When I said running the .net 4.0 standalone I meant I double clicked the following file.

dotNetFx40_Full_x86_x64.exe

I attached my wse and wsi zipped up as one file. I tried adding the logging, but am not seeing what is causing this. Under Vista and 7 it doesn't do this. Only under XP. Again, its only after I run my install first and get the error about not having .net. Then running the dotnet file above. Then rebooting and then that's when it starts to kick off my install again.

Thanks for the help Ed

AttachmentSize
install wse and wsi.zip 173.2 KB
EdT's picture

I don't have enough spare time right now to trawl through the logic in your Wisescript, but the restart appears to be due to this line:

item: Edit Registry
  Total Keys=1
  Key=Software\Microsoft\Windows\CurrentVersion\Run
  New Value=%MODULEFILENAME% %INIFILEPATH%
  New Value=
  Value Name=%_PACKAGECODE_%
  Root=2
end
 
Although there is another line where the RUN key is cleared, my guess is that the path through the script leaves the RUN key populated which then runs the entire install again.
 
My personal approach to these sorts of packages is to write my own Wisescript wrapper entirely from scratch so that I have total control over the logic. However, what you may want to try is to single step through the wisescript and monitor variable values at different points. Or at least make sure that the RUN key is cleared immediately after you display a message for the user to install .NET 4

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.