Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

When adding host: Error V-383-50513-5753 Could not push credential to managed host

Created: 27 Feb 2014 • Updated: 27 Feb 2014 | 2 comments
xhawk's picture
This issue has been solved. See solution.

I'm trying to add a SLES10.1 host, but failed.

The port 5634 is opened bi-directional between VOM server and the host.

VRTSmh package is installed on both sides. The logs are bellow:

=====================================================================

Add Host Log
------------
Started [02/27/2014 17:23:42]

[02/27/2014 17:23:42] type  rh MV-DB2 cms 
[02/27/2014 17:23:42] Check if MH is pingable from MS and get vital information from MH
[02/27/2014 17:23:42] Output: {
"XPRTLD_VERSION" :  "1.0.180.0",
"DOMAIN_NAME" : "UNKNOWN",
"DOMAIN_TYPE" : "localhost",
"BROKER_HOST" : "UNKNOWN",
"AGENT_ACCOUNT" : "UNKNOWN",
"VS_HOSTNAME" : "UNKNOWN",
"VS_IP" : "UNKNOWN",
"XCS_NAME" : "MV-DB2",
"XCS_ADDR" : "10.25.104.13",
"XMH_NAME" : "vommgr",
"XMH_ADDR" : "10.25.128.108",
"XCS_TIME" : "1393493045",
"XCS_LOCALE" : "POSIX",
"OSNAME" : "Linux",
"OSRELEASE" : "2.6.16.46-0.12-smp",
"CPUTYPE" : "x86_64",
"OSUUID" : "{e3531f0a-1dd1-11b2-ae93-3f6bc6511b0b}"
}

[02/27/2014 17:23:42] Return code: 0
[02/27/2014 17:23:42] creating task for Add host
[02/27/2014 17:23:44] ADD_HOST_PRECONFIG_CHK
[02/27/2014 17:23:44] {"JOB":{"RETURNCODE":0,"ERROR":"Success","NAME":"add_host","OUTPUT":"ADD_HOST_PRECONFIG_CHK","STATE":"SUCCESS","PROGRESS":1}}
[02/27/2014 17:23:44] retriving Agent password
[02/27/2014 17:23:44] ADD_HOST_INPUT_PARAM_CHK
[02/27/2014 17:23:44] {"JOB":{"RETURNCODE":0,"ERROR":"Success","NAME":"add_host","OUTPUT":"ADD_HOST_INPUT_PARAM_CHK","STATE":"SUCCESS","PROGRESS":6}}
[02/27/2014 17:23:44] user name is "root"
[02/27/2014 17:23:44] ADD_HOST_CONTACTING_MH
[02/27/2014 17:23:44] {"JOB":{"RETURNCODE":0,"ERROR":"Success","NAME":"add_host","OUTPUT":"ADD_HOST_CONTACTING_MH","STATE":"SUCCESS","PROGRESS":20}}
[02/27/2014 17:23:44] Output: HTTP/1.1 403 Directory Listing Denied

403 Directory Listing Denied
[02/27/2014 17:23:44] Return code: 1024
[02/27/2014 17:23:44] Checking to see if CS is reachable from MH
[02/27/2014 17:23:47] Output: {
"XPRTLD_VERSION" :  "6.0.0.0",
"LOCAL_NAME" : "vommgr",
"LOCAL_ADDR" : "10.25.128.108",
"PEER_NAME" : "MV-DB2",
"PEER_ADDR" : "10.25.104.13",
"LOCAL_TIME" : "1393493027",
"LOCALE" : "en_US.UTF-8",
"DOMAIN_MODE" : "TRUE",
"QUIESCE_MODE" : "RUNNING",
"OSNAME" : "Linux",
"OSRELEASE" : "2.6.32-358.el6.x86_64",
"CPUTYPE" : "x86_64",
"OSUUID" : "{00010025-9eaf-b11e-0000-000000000000}",
"DOMAINS" : {
    "sfm://vommgr:5634/" : {
        "admin_url" : "vxss://vommgr:14545/sfm_admin/sfm_domain/vx",
        "primary_broker" : "vxss://vommgr:14545/sfm_agent/sfm_domain/vx"
        }
    }
}

[02/27/2014 17:23:47] Return code: 0
[02/27/2014 17:23:47] CS host (vommgr) is resolvable
[02/27/2014 17:23:47] Trying to figure out if host is already part of the domain
[02/27/2014 17:23:47] Executing: /opt/VRTSsfmh/bin/xprtlc -u nobody -l https://localhost:5634/agent/domain/enum
[02/27/2014 17:23:48] ADD_HOST_SEND_CRED_MH
[02/27/2014 17:23:48] {"JOB":{"RETURNCODE":0,"ERROR":"Success","NAME":"add_host","OUTPUT":"ADD_HOST_SEND_CRED_MH","STATE":"SUCCESS","PROGRESS":30}}
[02/27/2014 17:23:48] Output: HTTP/1.1 404 Not Found

404 Not Found
[02/27/2014 17:23:48] Return code: 1024
[02/27/2014 17:23:48] fancy_die
[02/27/2014 17:23:48] ADD_HOST_CRED_PUSH_FAILED
[02/27/2014 17:23:48] fancy_dead
===================================================================================

Any hint? Thanks!

Operating Systems:

Comments 2 CommentsJump to latest comment

Michael Auria's picture

Here is one of the possibilities documented in the knowledge base.

 

"Could not contact managed host error" encountered when adding server to a Veritas Operations Manager (VOM) domain

http://www.symantec.com/docs/TECH204900

 

Otherwise, this will require a troubleshooting session.  Please open a support case and I will be glad to work with you ro resolve it.  You can open the case by calling our office or opening it online at:

 

http://mysymantec.symantec.com

 

Let me know of the case # and I will take ownership.

SOLUTION
xhawk's picture

hi,Michael

 

Thanks!

This was a careless mistake: I noted Package VRTSmh is installed, but actually package VRTSsfmh is not installed on clients.

After installing VRTSsfmh, the clients are added successfully to VOM.