Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

When "Locally on the Deployment Server" is selected, PowerShell tasks are opened with notepad.exe instead of powershell.exe

Created: 23 Oct 2012 | 3 comments

Deployment Server 6.9.517 (SP5 MP2) on Server 2008R2.

When I select "Locally on the Deployment Server" for my PowerShell tasks, the DS opens the script in notepad (as system, so I can't see it in the console) instead of powershell.exe. I have to kill notepad in task manager to get the task to complete. Of course it returns an error 1. What is going on? It used to work fine. I now have to do all kinds of bone-headed scripting gymnastics to run powershell locally.

Yes, I opened a support ticket with Symantec, but they said that running powershell scripts locally on the deployment server isn't supported. I know that it can work, because it used to, even if it isn't technically supported.

 

Comments 3 CommentsJump to latest comment

carlsson's picture

could it be file association on your Ds?
Has someone been editing a powershell script and ticked "always open this type of file.... "

try right clicking a powershell file in explorer and reset the association to the powershell app

C

Hojiblanca

symdon's picture

Using the steps mentioned in the KB article below, we are able to execute the Powershell script using "Locally on the Deployment Server " option. http://www.symantec.com/business/support/index?pag...