Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Where did all my Hyper-V VMs go?

Created: 11 Nov 2008 • Updated: 22 May 2010 | 16 comments
LMHansen's picture

So, on Friday, I edited our backup selection, and all the Hyper-V VMs showed up. Today, it lists none.

 

Hyper-V is installed on a remote computer. The remote agent is installed on the machine with Hyper-V, and the Hyper-V agent option was installed as a part of the Backup Exec server install. When I go to browse Windows Systems\MachineName\Microsoft Hyper-V\Virtual Machines, it simply says "none".

 

I do have the remote agent also installed on the virtual machine, and I can back up the virtual servers this way. However, I have a couple of Virtual servers that exists on a different subnet, so I cannot access these directly through the agent, hence the need for the Hyper-V option.

 

I'm running BE 12.5, Rev. 2213. Hotfix 309248 and 313346 is installed.

Comments 16 CommentsJump to latest comment

MAgee's picture

I'm having a similar issue. I have a mix of Virtual Server 2005 R2 SP1 and Hyper-V running on Server Core machines. The BE lists the VS 2005 vms and all of their data. The Hyper-V machines, however, only list some of the vms and none of the data (such as vhds or vmcs). The biggest difference between the Hyper-V and VS2005 hosts is that the Hyper-V hosts are connected to a SAN and VS2005 is using local disks. 

ZakkieBoy's picture

I too have a similar problem, BackupExec 12.5 SP1 on W2k8 not listing some virtual machines (Hyper V) in the resource selections. 

 

These seem random, (as in there seems to be no consistency with where the VM's are stored SAN,local,etc)

 

This is no filling me with confidence as im due to purchase my license tomorrow!

Emil Muzz's picture

Same problem here:

Server 2008, BE 12.5, VMs stored on a local Raid-50

 

After installation I was able to select all 3 VMs for backup. After the job had failed, I checked the selection and found only one VM. This one disappeared after the next reboot of the Hyper-V server. No VMs visible now.

penniwise10's picture

I am seeing the same thing. 12.5 on W2k3 R2 x64 with the MS Agent option bought and installed. I'm up to date on BEWS according to live update and so is the client.

 

In the selection list for the host server I only see 1 of my 5 Hyper-V Guest servers. I can backup the contents of each Hyper-V guest server just fine but I'd like to be able to backup the whole server. After all I did pay for it

ZakkieBoy's picture

penniwise10 wrote:

 

the whole server. After all I did pay for it

 

My sentiments exactly.. I/We paid large amounts of money for an Agent - which simply doesn't work!

ZakkieBoy's picture

Hi through talking to symantec support if you uninstall SP1 this seems to fix the problem so is ok for a temporary workaround

 

http://seer.entsupport.symantec.com/docs/317800.htm

 

apparently they know about the problem, and are working on a permanant fix

Message Edited by ZakkieBoy on 01-26-2009 07:08 AM
LMHansen's picture

I reviewed my hotfix installs, and didn't have any of the ones mentioned in doc 317800.

 

But, nevertheless, I uninstalled the hotfixes that I did have, and now Hyper-V seems to be working again. I am able to view and select Virtual machines for backup. I'll know tomorrow if it actually worked.

 

I am currently running 12.5 with only hotfix 313346 installed. That should be 12.5.2213

 

Emil Muzz's picture

Thanks for your feedback guys. Although I'm only evaluatin at the moment, it's good to know that there is a temporary fix. I'm going to install BE 12.5 again and will give feedback soon.

LMHansen's picture

All my Hyper-V machines are now missing again. None are showing as selectable. They were there yesterday and the day before when I reconfigured the backup jobs, but when the backup job finally started, there was nothing there.

 

The Virtual machines are hosted on a remote computer. When I select the computer, I get the "Microsoft Hyper-V" option. Expanding that gives me a "Virtual Machines" folder, but this one is empty...

 

This is not good. We've just moved the majority of our web servers and services to virtual machines, and now find ourselves unable to back them up...

Chris Auer's picture

I just went through this issue with Support. I had to restart HyperV (saved state on all servers, then restarted the three HyperV services). Then restart the backup exec server service. They all showed again.

Emil Muzz's picture

Are you then able to perform a backup? I restartet the server several times but wasn't able to run a single backup. The job fails and after that some or all VMs have disappeared in the backup selection.

ETH0's picture

I installed the hotfix below after installing SP1 and all hotfixes from liveupdate and all myHyper-V VMs reappeared in the Backup Console.

 

317966: Backup Exec 12.5 for Windows Servers revision 2213 Hotfix 317966
 http://support.veritas.com/docs/317966s revision 2213 Hotfix 317966 http://support.veritas.com/docs/317966

 

I was also able to run backups of all my VMs.

Emil Muzz's picture

I installed BE including all updates and tried ru run a backup. After 40GB the server crashed without warning. After reboot, no VM was shown in the backup selection. I'll try again in a few days but that doesn't look good. I'd better search for another backup solution.

Chris Auer 2's picture

I have the same issue. The patch didnt do anything. I am working on a scrpt to save the servers and then let the backups run. It is the fact that VSS fails that causes BE to fail.

Zakkieboy2's picture

A few weeks later and things are still unacceptable. - Why didn't I just go with DPM 2007????

 

Now I have The Microsoft Volume Shadow Copy Service (VSS) snapshot provider selected returned: "Unexpected provider error". & numerous problems getting the exchange box to backup and the jobs running at a snails pace....

 

I know symantec are going to blame the MS shadow copy, and the support that I paid for is just as poor as the Agent - Is it time to start asking for a refund????

Chris Auer 2's picture

What Symantec needs to give us in an option to save the server right before the backup starts and start it when the data begins to transfer. That should give us an outage of about 1 1/2 minutes. I can live with that.