Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Windows 2012 STD x64 - Master server cannot connect to client

Created: 12 Feb 2014 • Updated: 22 May 2014 | 6 comments
This issue has been solved. See solution.

We are running Netbackup 7.6.0.1 on Windows 2008 R2 X64 server. I upgraded the Active Directory from 2008 R2 to Windows 2012 STD x64 and installed the Netbackup Client 7.6.0.1 on it. Adde the AD cleint server to the Master Backup server. When I select the host properties of the AD client server, it fails to connect.

When I do a PING or NSLOOKUP, everthing works and resolves.

Apart from installing the cleint software, is there anything else to do?

Operating Systems:

Comments 6 CommentsJump to latest comment

Marianne's picture

Hopefully you have done reverse lookup as well with nslookup? And performed lookup in both directions?

Have you disabled Windows firewall on the AD server?

NBU needs port 1556 to be open in both directions.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Qatar Exchange's picture

Thank you for your reply. The first thing was the NSLOOKUP/REVERSE LOOKUP done on both sides and it is OK.

Even the "bptestnetconn - hostname" on command prompt of master server resolves

The error coming from the Master Server when connecting is - invalid error number

The Client OS properties is set to Windows 2008 R2. The "detect Operating System" only picks up Windows.

Maybe something needs to be done on the NFS Side?

Marianne's picture

NBU does not need NFS for connectivity.

Please test as follows:

Create bpcd log folder on client under netbackup\logs folder.

On master server, run from cmd:

bptestbpcd -client <client-name> -verbose -debug

Please post output of command as well as Client's bpcd log file.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Nicolai's picture

what does the command say: bptestbpcd -client {client_name} -verbose 

On the client enable these debug logs with verbose =5 set : bpcd bpinted and attach them to a post as a file

Try to disable reverse name lookup by running  "bpclntcmd: -reverse_name_lookup prohibited" on both master,media and client.

you can reverse back to normal using : bpclntcmd: -reverse_name_lookup allowed

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Qatar Exchange's picture

The revers name lookup failed from the Client. Port 13782 was blocked on the Firewall for INCOMING.

Thanks to all for your feedback..

Marianne's picture

Glad we could help!

Please remember to close off this discussion by marking Solution for the post that pointed you in the right direction. Or 'Request Split Solution' if more than one post helped you.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links