Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Windows 7 boot error, using Ghost 11.5!

Created: 03 Jun 2010 • Updated: 29 Sep 2010 | 31 comments

Hi guys, new guy here...I work for IT at a university and we're imaging lots of incoming desktops for staff and faculty. We installed 1 main copy of Win 7 with our software and updates, then uploaded it to our ghosting machin via GhostCast Server. Then, we pull that image down using GhostCast Server to our other machines that need the image (for now imaging older Dell Optiplex 320's, but models will change as new machines roll in). The problem is, we get this error when we boot the newly imaged computers up for the first time:

Windows failed to start. A Recent hardware or software change might be the cause. To fix the problem: 

1. Insert your windows installation disc and restart your computer.
2. Choose your langugae settings, and then click next
3. Click "repair your computer."

Status: 0xc000000e
Info: The boot selection failed because a required device is inaccessible.

This did not happen when I imaged a new Dell E4200 laptop...only with the older 320 Desktops. With the laptops everything works find and dandy after downloading and uploading a new image.

My question is: Is this a known issue, and is there a fix within Ghost, where a new image can be obtained that will not require a diskpartitioning software to change anything in the machine themselves AFTER they've already been imaged?

Thanks!
 

Comments 31 CommentsJump to latest comment

EdT's picture

Windows 7 creates a small system partition as well as the main partition and both are required for Windows 7 to boot correctly. So the first question is to ask whether the target machines are getting both partitions. If only one is being imaged. then the absence of the other partition could be causing the message about a device not being available.

If that is not the cause, then do your machines have compatible hard disk architectures? Trying to boot an image created on a machine with a SATA hard disk running in IDE compatibility mode, on a machine configured for AHCI on its hard disk, is again going to cause problems if the appropriate SATA driver is missing.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Shane Lu's picture

Thank you EdT. I am imaging the entire hard drive. Therefore if there were two partitions that Win7 needed, it will be in there. However, when I installed Win7 on the host machine first, I had a 8MB partition/free space left over that I could not get rid of. I suppose this is the second partition you're talking about...but since I imaged the entire drive, that should have been included.

Every machine we image has exact specifications down to BIOS version. I will try changing some BIOS settings, but I doubt that will do any good. The hard drives are all identical along with anything else. I'm still stumped. Any more help would be appreciated.

Thanks.

EdT's picture

The 8Mb free space at the end of the drive is nothing more than a "rounding" error based on partition boundaries needing to start in specific locations where Cylinder and Head count are both zero. The only time I think you will avoid a bit left over at the end is if you only have one partition.
The Windows 7 "hidden" partition is at the start of the drive.

Having covered that aspect, are you running Sysprep before you create the image, and then going through mini setup once the image is deployed, or are you ghosting a fully operational image?  If the latter, then it is likely that you are running into issues with licensing as there are various copy protection mechanisms on Windows 7 and although you think the hardware is identical, it is most likely that bios and motherboard serial numbers are different and so the machine is regarded as being a different platform.

To test if this is the issue, try re-imaging the original machine on which the image was developed. If it works on there and not on supposedly identical hardware, then it's down to the copy protection. The error message you are getting does, after all, refer to a change of hardware as a possible cause.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Shane Lu's picture

That is not the problem- the machine I built the image on still does not work with the image reloaded on to it. I can throw the Win7 DVD in there and it will fix the partition in just a couple of seconds but neither my boss nor I want to take that route unless absolutely necessary. Any more clues?

EdT's picture

What Ghost switches are you using?
It may be worth searching for past postings on DELL imaging as I'm sure there have been previous discussions regarding the most appropriate switch settings to use.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Shane Lu's picture

Hmm, I'm not sure what a Ghost "Switch" is. Can you elaborate?

I'm simply using GhostCast server to create an image then restoring it onto another computer using the GhostBoot Wizard.

dh1530's picture

There are advanced, command line switches you can use in your implementations for different things like using more or less than the default 3 compression types, stating -sure so you don't get prompted to state that you're sure, -rb will reboot the machine after ghosting, etc., etc., etc.

http://www.symantec.com/business/support/index?page=content&id=TECH130961&locale=en_US

DMH

kerryrey's picture

Has there been a good solution found to this? I am running into the same exact error. I have gone through Wiping the drive completely put just a C partition on the drive installing windows 7 fresh so I only have then one C: partition and not the little boot locker security partition in the front of the drive. Then I take an image of the machine and try to then deploy that image to both another machine (and even back to that same machine the image is from) and I am still getting that dumb 0xc000000e error. I am in the same boat as Shane Lu where there are going to be hundreds of machines used from this one image.

EdT's picture

Windows 7 requires a small "system" partition at the start of the drive and will create it on a drive with a single partition, if it does not exist, when you install Windows 7 for the first time.
So I would suggest that you have a look at the existing partition structure - eg using Diskpart in WinPE or any suitable bootable disk utility, and you should see the small partition in there. It is a hidden partition so is not visible under windows.
Thus you need to image the disk and not the partition, or you need to image both partitions, otherwise you are not going to get anywhere.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

BlakeGo's picture

Having the same issue ghosting a windows 7 pc using ghost.exe from drive mapping network boot disk. The ghost switches I'm using during image creation and restore are -fnx -ffi

When the computer boots up after imaging, I get this:

"Info: The boot selection failed because a required device is inaccessible."

ChestnutHill's picture

I need help with creating a Windows 7 64 bits image. Ghost is imaging the entire drive which is making them large. I have looked all over the forum and there are no answers.

EdT's picture

Your posting is a series of statements. Is there a question you are asking, and if so, can you be a lot more detailed in your description, by providing information on your Ghost environment and what your problems are.

Windows 7 consists of two or more partitions depending on how it is installed. You could of course capture each partition separately and then try partitioning your target machines to match your source machine and then restoring each partition individually.

Apart from the forums, Connect also includes a huge database of articles - have you had a look in there, as I'm sure there is enough Windows 7 stuff in there to choke a camel.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

DonK's picture

Boot your OS media, choose "repair disk" on the bottom left. Do NOT let it repair your disk when it says it found errors. Choose the "command prompt" option at the very end.

Do the following to set the boot partition active:

 diskpart

list disk

select disk X

list partition

select partition Y

active

exit 

Where "X" above is your BIOS drive number (usually zero "0"); "Y" is one you need to make a decision to set. If you are using an OEM build, your first partition will be labeled OEM. Don't select that one. You want the first partition labeled "primary" (usually either 1 or 2).

Next, you have to set your boot loader with bcdedit for each boot option:

 bcdedit

bcdedit /set {your ID} device partition=Z

bcdedit /set {your ID} osdevice partition=Z 

Where "Z" above is the letter corresponding to the boot partition above, not the assigned drive letter when you installed the OS. You can find this letter by typing "notepad" at the command line, then choose save as, then click on "computer" to list the various partitions. Cancel your save, and exit without saving once you know the right drive letter. It should be obvious which letter you need to use (usually a "C" or "D").

Reboot the system with the OS install disk, then choose repair, and let the repair tool do the repairs.

Reboot, and the OS will now work. If you are in an environment where you image 100s of computers, this won't work for distribution when you have to touch each system for 15 minutes to get them working. So far, I have only seen this with 64-bit Win7 systems.

DonK's picture

Forgot one detail  with bcdedit portion of the fix - the "boot ID" is the identifier of the boot entry. The default entry is "{default}" but you will want to make sure you change all of the ones listed for each entry. If you fail to do this, you will not have a safe mode, or you will have a system that doesn't return when it goes into hibernation or any other mode listed with bcdedit. 

willod's picture

EdT,  Let me clarify the situation.  I think we are all running into the same problem.  The 100 to 200MB system partition that Windows 7 creates is not necessary in any way.  It is a structural choice (a bad one) that Microsoft made.  It can be removed before install by repartitioning the drive or after by moving the boot files to the main system, rebuilding the boot and marking it active.  The error comes up sometimes either way.  It is a problem with Windows 7 addressing the boot files incorrectly or Winload.exe.  The problem is that all the files are in their correct spots in the OS, but for some reason the bit-addressing has changed.  Before cutting the image, Windows 7 is booting fine.  A full image-from-disk with no switches creates a non-booting image.  Sames true for a partion-to-image.

DonK, Thanks, that solution works, but so does OS Disk startup repair.  Unfortunately, for my purposes I can run repairs on every machine I image.

Sysprep, didn't solve the problem and caused windows to deactivate...maybe I am using it wrong.

The question is this:   How does one fix the OS so that upon re-image the machine can correcting address the boot information?

EdT's picture

@willod

I'm not clear what you mean when you say you can remove the system partition before install by repartitioning the drive. Do you mean prior to ghosting or prior to installing Win 7 from DVD ?  My experience is that even with a blank unformatted disk, the Win 7 install still creates two partitions.

Also, have you tried moving the boot files and getting the image working as a single partition, then tried imaging via Ghost?  Do you still get the same level of failures?

My untested speculation is that differences in hard disk capacity or geometry might be the underlying cause. When partitions are created, the partition boundary has to be on a cylinder boundary, so imaging to a hard disk with a different geometry to the original could result in partition boundaries appearing in slightly different places, and this could affect the way Windows 7 starts up if there is some sort of block count maintained internally. 

The larger hard disk capacities, eg 2Tb are also coming with 4K sector sizes and some translation has to go on since Windows still works with 512K sector sizes. Whether this could also be a factor is something I have not been able to determine so far.

Windows 7 will deactivate when sysprepped - I am assuming you are using a MAK key which is not the intended solution for corporate volume licensing, where a KMS server is the preferred solution.  It's all about preventing piracy, and it would not surprise me to find that the problems experienced during imaging are also caused by some aspect of the anti piracy measures.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

willod's picture

with the geometry.   I think when Windows 7 install creates the 2nd partition it sets some of it's boot function to bit addresses instead of actual values or variables.  And moving the image back to that drive or to a new (but identical one) might move the required values.  Currently I am working with a an image that has the system reserved partition removed after Windows install but before cutting the image.  

To arrive at this scenario I did the following:

1. Move the required folders and files to the the main partition, recovering the boot system, and deleting all files from the system reserved and deleting it.  

2. Reboot to make sure the OS boots properly (which it does).

3. Cut an image from the partition, now the only partition.

4. Re-image the same machine with that image (to get rid of the 100MB unallocated space)

5. Now is when the problem occurs first, but this would make sense as an addressing issue since I have moved the files on the disk.

6. Run windows startup recovery.  Everything is peachy and booting fine, normal drive lettering, boot file locations, etc. (and no system reserved).

7. Cut image from disk (now only 1 partition).  Re-image same computer and boot device missing error occurs again.  Weird, right.

 

Initially I thought it had to do with the System Reserved partition, especially because it appears that upon re-imaging, the 2-partition system assigns c: to the system reserved and d: to the main partition.  But it shouldn't have that problem with only 1 partition.

 

I have a working Win7 image from another model (no system partition).  I think I blocked Windows 7 Install from creating the system reserved upon install.  I don't remember how, but if you are interested I will post a link.  Maybe, that's why the other model works (it's newer and a bigger HDD; neither have over 200GB).

 

As for sysprep.  You're right, it really didn't have a practical application for my needs.

 

It may an anti-piracy thing.  But it seems a bit drastic to block simple re-imaging, that's more Adobe's cup of tea rather than Microsoft's.  Also, running startup recovery doesn't require any key reentry.  And for your peace of mind, so you know I am not trying to swindle MS.  We have a large volume of identical machines, all with valid Win7 licenses, that we send out in the field on temporary assignments.  When they are returned, we must wipe them for security reasons.  So ghost has provided an easy solution.

EdT's picture

Is the remaining partition set Active ?

Is your bios set to compatibility mode for creating the image and for restoring it? (Or not set as long as this is consistent)  I'm not convinced that the LBA to CHS translation is the same between AHCI/SATA and Compatibility mode.

Are you taking a Disk image or a Partition Image?

Are you repartitioning the hard disk before each image write?

One thing you could try is to boot the working machine into WinPE and run BCDEDIT to check the partition setup in some detail, then after re-imaging, boot into WinPE again, and run BCDEDIT once more and compare the result with before.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

willod's picture

Yes, once the system reserved is gone the remaining partition must be set to active for boot.

The current computer I am working with does not have an AHCI mode in the BIOS, or at least I can't find it.  On other laptops, I have found that going from Compatibility to AHCI will cause a blue screen.

To get rid of the unallocated space, I took a partition image.  For the final distributable image I used Disk.

I am not repartitioning the disk before each write.  The "final" image is cut from a booting machine with a single partition.

bcdedit /enum displays the same on all 3 except the following:

Scenario (1):  Working image (on a freshly imaged machine with usable image)

Scenario (2):  Non-working image (on working source machine)

Secnario (3):  Non-working image (on freshly imaged machine, boot issues)

 Windows Boot Manager

Device: (1) boot , (2) partition=C: , (3) unknown

Windows Boot Loader

Device: (1) boot , (2) partition=C: , (3) unknown

osdevice: (1) boot , (2) partition=C: , (3) unknown 

 

So, I know I can fix the non-booting machine (3) by running startup repair or bootrec.  But, the real goal would be create the Disk Image from (2) and not have it result in (3).  Not sure how (1) ended up as such and don't which (1 or 2) is the proper configuration.

By the way, thanks for all your help.

EdT's picture

On a non-booting machine, can you get it to boot by using BCDEDIT to set the Windows Boot  Manager and Windows Boot Loader settings to (1) from the non-working "unknown" setting?

If this works then at least you have a solution that could be implemented in code as part of the imaging process, while we all try and figure out why the imaging process is bollixing these things up.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

willod's picture

I use the software via network boot into MS-DOS.  bcdedit.exe doesn't work in dos mode apparently.  Any alternative? 

By the way.  I tried a new image with the system reserved removed before  Win7 install and the same thing occurs.    In case you're curious about installing win7 w/o the sys reserved:

 

 

  1. Once Windows 7 Setup is loaded, press Shift + F10 keys at the first setup screen (which allows selection of language, keyboard and locale). A Command Prompt window will be opened.
  2. Run Diskpart, the built-in disk partitioning tool of Windows 7 with the following command:

    diskpart

  3. Type in the following command one by one, follow by Enter key to create a partition (text in brackets are comments only):

    list disk (to show the ID number of the hard disk to partition, normally is Disk 0)
    select disk 0 (change 0 to another number if applicable)
    clean
    create partition primary size=80000 (create a partition with 80 GB space; to use entire disk as one partition, omit the “size=value” parameter switch; use similar command to create more partition if needed or create in Windows 7 after installation)
    select partition 1
    active
    format fs=ntfs quick
    exit

  4. Type exit at command prompt to close Command Prompt window.
  5. Continue Windows 7 installation as usual. Remember to just highlight and select the partition just created when come to partition screen.
EdT's picture

Have you tried booting to WinPE ?  You can run BCDEDIT from the WinPE command prompt.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

willod's picture

Yes, I guess I need to figure out how to make a network bootable version of Windows 7's WinPE.  The DVD works but we image up to 30 machines at a time and having to insert DVD's into all of them.

willod's picture

Looks like the solution is to replace my DOS Netboot(Win98) with a new PE 2.0 or 3.0 netboot.  Then I can just add the following to my batch file:

 x:\windows\system32\bcdedit /set {default} device partition=c:
x:\windows\system32\bcdedit /set {default} osdevice partition=c:
x:\windows\system32\bcdedit /set {bootmgr} device partition=c: 

I'd still like to know how the working image for the other model works.  Can't figure out how to set device and osdevice partition=boot.  Or configure Boot Manager and Boot Loader in that same way.

Maifriend's picture

I have the same issue. I have a Thinkpad T410 and for my tests I use two identical 60GB HD. I use the recovery DVD that came with my T410 to reload Windows 7. Then using GSS I create an image that I store on my GSS server then load it on the second 60GB.

Result: Windows 7 crashes when the laptop boots.

On the second attempt, I use the "-id" switch, same results. Not that "-id" is supposed to copy everything and you can't resize while copying.

On the third attempt, I use -fdsz. The laptop then boot with the message "... inaccessible" and if you use the DVD to repair then it works. But with hundreds of laptops to clone, it's not an acceptable solution.

On the fourth attempt, I clone from disk to disk instead of saving an image to the GSS server. On reboot the system crashes and same results as in 3rd attempt if I use -fdsz.

Anyone who has a valid license of GSS can call Symantec support which I plan on doing tomorrow.

It's simply sucks that Symantec didn't have a switch to clone W7 or W2K8R2, unless it's there but I read the documentation and didn't see anything.

EdT's picture

Have you tried any of the solutions proposed earlier in this thread?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Maifriend's picture

I haven't tried any of the solutions proposed in this thread because I've been using ghost for around 10 years and I've never had to modify Windows or the boot disk in anyway, just ghost the image to the server then ghost it back to the PC.

Back to our pb, I boot a ghost laptop with W7 DVD (from Technet) and did a repair. The System Recovery Options displayed this:

-----------------------------------------------------------------------------------------------------
The Following startup options will be repaired:
Name: Windows
Identifier: {9DEA862C-5CDD-4E70-ACC1-F32B344D4795}

The Following startup options will be deleted:
Name: Windows
Identifier: {91578897-033D-11E0-A330-F0DEF11CF591)
Windows Device: Partition=Not Found

The following startup options will be added:
Name: Windows 7 Professional (recovered)
Path: Windows
Windows Device: Partition=D: (46031MB)

Name: Windows Recovery Environment (recovered)
Path: Recovery\WindowsRE\Winre.wim
Windows Device: Partition=C: (1199 MB)

A copy of the current boot configuration data will be saved as C:\Boot
------------------------------------------------------------------------------------------------------

Apparently there is an issue with a partition.

EdT's picture

Just noted you have a Thinkpad - is this set up with System Recovery?  From the listing in your posting it looks like the 1199Mb partition is part of the System Recovery setup and the larger partition is the main system partition. I see no sign of the Windows 7 small system partition (usually around 100Mb)

The other "problem area" that I have encountered with native Lenovo builds is that they use a Linux boot manager for the System Recovery function, and this gives all sorts of problems with imaging utilities. The Vista machine I first encountered this on appeared to use different sector sizing for the boot manager and this proved very difficult to clone.

So if you are basically trying to image a Lenovo OEM operating system install, I would suggest that you may have better results if you avoid System Recovery completely, and just go for a disk wipe and a standard Win7 install, then try imaging that.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Maifriend's picture

Problem resolved, at least for me. I'm cloning the Thinkpad T410 and boot from a 1GB flash drive.

Spent nearly 3 hours with Symantec tech support and here's what we did.

On my T410, I installed all the software I needed. Then ran sysprep.exe from c:\windows\system32\sysprep.

Select Out of the Box Experience and Shutdown. Do not click Generalize.

Plug a USB flash drive to your Ghost Suite Server.
 

On the Ghostcast server

1) I use Ghost Solution suite 2.5 with all the updates. On the Ghost Suite Server, install MSXML 6 from Microsoft (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=993C0BCF-3BCF-4009-BE21-27E85E1857B1&displaylang=en). It is needed to install additional driver.

2) On the server, launch the Ghost Boot Wizard

3) Select Windows PE and click Edit

4) Select WinPE (not WinPE-512), click Edit if you want to add the driver for your network adapter. Deselect the driver you don't need. You have to use the 32 bits driver for Vista (NDIS 6.1 I believe). Give it a name/description. No need of network driver if you Ghost from disk to disk, the T410 DVD drive can be removed and replaced by a second HDD.

5) Click the Storage tab and add the driver for your computer hard disk drive controller. This will increase read/write speed. For my Lenovo T410, I use the Intel 82801 Sata Raid (included with GSS 2.5). If your computer use an Intel chipset it should be fairly easy. Remember to use a Vista 32 bits driver.

6) Click OK when you're done with the drivers

7) Back to the Windows PE Editor, click OK

8) Back to the Ghost Boot Wizard screen, click Next

9) Select Standard Ghost Boot Disk and click Next

10) On the Symantec Ghost Boot Wizard - Client type screen, I had to add -ib (specific to Lenovo) and -fdsp (all machine) in Parameters. If you use a PC DOS boot disk, you can manually add the switch when you launch Ghost but PC DOS will be extremely slow when you have to ghost 500GB hard drive

11) Click Next. Leave all settings empty and click Next

12) Select DHCP will assign the IP settings

13) On the Destination drive screen, you should see your USB flash drive. You might want to burn a CD/DVD if your laptop/desktop can't boot from a flash drive. If you don't see it then click the Refresh button. I use FAT on a 1GB flash drive. Click Next, skip the Additional Files screen by clicking Next and click Next on the Review screen.

14) It's going to take a few minutes to create the bootable flash drive. Click Finish when it's done.

15) Boot your laptop/desktop from the USB flash drive, assuming that the Bios will support it. Connect to your GSS and clone.
 

Maifriend's picture

I use the recovery disk from Lenovo and didn't have any issue ghosting the T410. I have the recovery DVDs and plan on removing the Rescue and Recovery partition.