Video Screencast Help

Windows 7 Copy Profile issues

Created: 16 Jan 2013 • Updated: 16 Jan 2013 | 2 comments
This issue has been solved. See solution.

Hi All,

I've recently been reworking our Windows 7 Build image and automating the process.
I'm finding a weird issue with the CopyProfile section of this.

During the process i run a set of registry deletes to clear all the quick launch items from the start bar.

like so:

REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Npprffbevrf\Pnyphyngbe.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Npprffbevrf\Fgvpxl Abgrf.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Npprffbevrf\Favccvat Gbby.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Npprffbevrf\Cnvag.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\KCF Ivrjre.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Jvaqbjf Snk naq Fpna.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{0139Q44R-6NSR-49S2-8690-3QNSPNR6SSO8}\Npprffbevrf\Erzbgr Qrfxgbc Pbaarpgvba.yax" /f
REG DELETE "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{F4E57C4B-2036-45F0-A9AB-443BCFE33D9F}\Count" /v "{N77S5Q77-2R2O-44P3-N6N2-NON601054N51}\Npprffbevrf\Npprffvovyvgl\Zntavsl.yax" /f

This then works fine during that but once i have sysprepped, imaged and redeployed it doesnt always consistantly seem to keep these settings, though some of the profile settings are still in place.

Anyone got any ideas?

Thanks Jim

Comments 2 CommentsJump to latest comment

Zac H's picture

Instead of making the changes to HKCU (which is just the current logged on user), maybe you need to make changes to the default user hive.  In the past, I've done this with a batch file and a reg file.  Something like this:

DefaultUser.cmd:

 

:: Import reg hive
REG LOAD HKU\Default_User "C:\Documents and Settings\Default User\ntuser.dat"
 
:: Add changes
REG IMPORT "%~dp0DefaultUser.reg"
 
:: Unload hive
REG UNLOAD HKU\Default_User
 
DefaultUser.reg
 
; ***********************************************************
; HKEY_USERS\Default_User KEYS
; ***********************************************************
;
; This is what sets up the settings for Default User, which
; are the keys used when a new person logs on to the machine
; ***********************************************************
 
; Set IE to not reuse the same window for shortcuts
[HKEY_USERS\Default_User\Software\Microsoft\Internet Explorer\Main]
"AllowWindowReuse"=dword:00000000

 

SOLUTION
JimChud's picture

Thanks Zac,

This is exactly what i'm currently doing. I posted this and went... oh you plumb! why not load the default user hive itself!

Thanks for the quick response.

Regards Jim.
Connect Etiquette: "Mark as Solution" those posts which resolve your problem and give a thumbs up to useful comments, articles and downloads.