Video Screencast Help

Windows 7 Imaging & HP 8200 Elite

Created: 26 Jun 2012 | 7 comments

Hello,

    I was curious to know if anyone else is seeing these two issues with the HP 8200 Elite Small Form Factor.  My first issue is that when set to network boot in the BIOS, it waits, seemingly for an indefinite period.  This is the only model of computer that exhibits this behavior.  I believe these are the first of this model in our district so I am just getting to work with it in the last day.  My second issue is a driver issue in regards to the Intel(R) CPT Family SMBus Controller - 1C22, as I can not find a driver that will install during Win7 Mini-Setup.  I have tried at least 2 HP downloads.  I can get it to install by pointing to the driver folder I populate with model specific drivers but that's it.  In my limited testing I have tried 32 & 64 bit Windows installs and drivers.  So, I am reaching out to see what experience others may have. 

   Currently, we are using Altiris 6.9 SP4 Deployment Solution.  If you need any additional information just ask.  We would like to start deploying this model shortly so I am in a bit of a crunch.  Thanks in advance for any help you can suggest and provide.

 

Scott

Comments 7 CommentsJump to latest comment

BBC's picture

Hi Scott,

We actually move on to the next generation at the moment and have been using the 8200 series (USDT and SFF Elites) for quite some time. Since I don't use Sysprep builds, there are a few differences, but what you could try is something like this:

In the XML specify a FirstLogonCommands event something like this example below. During yoru deployment, copy over the driver set in whatever way you want (just make sure the driver packages are extracted) and the drivers should be installed after Mini Setup has finished.

XML section:

<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>%SYSTEMDRIVE%\<PATH>\DriverInstall.CMD</CommandLine>
<Description>Driver installation</Description>
<Order>1</Order>
<RequiresUserInput>false</RequiresUserInput>
</SynchronousCommand>
</FirstLogonCommands>

DriverInstall.CMD:

START /W %~d0%~P0%DPInst.exe /c /el /lm /q /sa /se /sh /sw

The DPInst.exe is provided with each driver package you download from HP / Lenovo or other vendors. Hope this helps a bit further,

-BBC

b3tts32's picture

We had/have the same issue with our 8200's coming from HP. It's a known issue related to the bios, more specifically the PXE agent not picking up an IP address. We had to downgrade the BIOS to version 2.06 to get around the issue.

 

As for the driver issue, we edited a registry entry before creating the image to point our drivers folder. Which essentially is about the equivalent of the OEMPnPDriversPath so drivers get installed during the mini setup process.

 

HKLM>Software>Microsoft>Windows>CurrentVersion>DevicePath

%SystemRoot%\inf;%SystemDrive%\drivers

BBC's picture

Not sure if this is much relevant to this, but we just recently found an issue with that hardware plaform being caused by a built-in card reader. That caused several DS tasks to fail and as it seems, there is no way to disable the device from within the BIOS. Only unplugging it from the main board works out here...

njsmith's picture

Boy are we having fun with the 8200 SFF.

I have updated all our BIOS to v2.21 this is the latest that I can find on the HP website.

Our experience to date.

BIOS Configuration changes

Storage : IDE Mode. (AHCI is not working for us, we don't have time to fix it now, we will address this another time)
Disable EFI Boot options - although something seems to keep turning them back on and altering the boot order.

Boot order: Network first.

We find that on starting up the PC often ignores the PXE boot and goes straight into loading and configuring Windows. To date the only way around that has been to run diskpart and clean the hard disk. So we suspect that the PC straight out of the box has some smarts built into it to force the installation of the provided OS. Something in that initial loader process is also resetting the BIOS configuration.

It is not ideal as we simply want to put our image onto the PC straight out of the box. But it looks like we have to boot the PC up update the BIOS and clean the HD first. Not ideal as we really do want unattended setups.

 

rdeploy is also proving difficult, so we are ghosting at the moment, not our preferred option.

BBC's picture

We have the 8200 series (SFF and USDT) for quite some time now and only faced an issue once where a card reader was built-in. I mentioned earlier that we had to physically unplug it from the mainboard to avoid conflicts with the mapped network drives for imaging.

Do you also set the remote wakeup source to Remote Server? We configure both parts by default in the BIOS. The EFI optons hould only be relevant if you run a WinPE supporting that, so tht should not matter.

Aside from that, we do rdeploy an IMG image, which wipes the disk and that works consistently so far (expecting the first 8300s' now) and we also do unattended setups for both, WinXP and Win7. Maybe the question is which boot environment you use at the moment? We use DOS and lay down an IMG containing a WinPE environment and so catch partitioning the HDD and also laying down a mini OS, which we can re-use at any time after the machine has finished its silent install of OS, drivers, apss, etc.

Just a comment about AHCI or IDE modes - if you run unattended installs for the OS, you should not have to worry about changing the setting. Again, one of the reasons why I do NOT do sysprep and also do NOPT rely on DeployAnywhere, which - from reading posts in these forums - shows up as causing more issues than helping.

-BBC

PS: I guess, at some point i will have to post the entire process we use for building clients so that whoever wants can consume...

njsmith's picture

Thanks BBC

We are not running a scripted install of Windows. Our process is to manually build a master PC, then image it and deploy the image.

We find with AHCI that windows does it's primary install, then when it reboots it cannot find the files to continue setup. Most likely we need to put a disk driver in, but have not had time to investigate this. We are under pressure to deploy a number of machines quickly. After that we will be able to go back and do it properly.

I/We are also not familiar with GPT partitioning. As above no time to do it properly (but there will be time to re-do it. sigh)

Our environment is Deployment Solution 6.9 SP5 on a 32 bit 2003 server. Installing Windows Enterprise 64bit.

In that scenario Rdeploy does not seem to handle multiple partitions. So we must install windows on a single partition.

On the other hand Ghost does handle multiple partitions and I have a working solution for that. But there is an entrenched view that rdeploy should be used "cos that's the way we always do it.

Compounding all that my experience is with MDT not Altirus. Sigh.

Jason_Wilson's picture

What I see with out 8200's is when PXE booting to WinPE via DS 6.9 SP4, if the box has 4GB of memory (2 sticks) it will 'freeze' at the WinPE Loading bar screen, never to complete.

Pop 1 of the two sticks out, process works fine, pop memory back in - all is good.

This wouldnt be a big deal, except many of my field sites use remote imaging - so no hands on the box to remove the memory.

 

We are testing SMP 7.1 WinPE PXE - and it doesnt have this issue... it will image the same box as above with 4GB no issue.

Boot disks on the 6.9 PXE have been regen'ed, etc... HP has offered no help.

Anyone else ever see such behavior?