Video Screencast Help

Windows Explorer in a layer

Created: 17 Dec 2012 | 5 comments

Is it possible to have an instance of Windows Explorer running in a layer? I can get a command prompt working and create folders etc, I can even do it in notepad, but when I try 'Run Application From Layer...' and use explorer.exe, it seems too ignore the layer.

Any suggestions? Is it because the process is already open? Is there a way around it?

Comments 5 CommentsJump to latest comment

AngelD's picture

You may get away with the explorer.exe /separate argument

JohnSmith1's picture

Unfortunatly it doesn't look like /seperate is valid switch. I have tried explorer /n and explorer c:, but when I deactivate the layer, the explorer process stays open

I have also tried a VBScript which kills the explorer process and opens it up again with the same result.

AngelD's picture

As the explorer process is heavily base integrated (managing the user desktop) I would try to skip using the process to make changes when trying to create/modify a layer.

What is it you hope to achieve through the explorer process?

JohnSmith1's picture

Whenever I try to install a program with ties to Windows Explorer (Dropbox, Classic Shell) It seems to call Explorer to write files which then do not get captured by the layer.

I have noticed however, that If a Global capture is used, Windows Explorer actions are captured.

AngelD's picture

Yeah, I think a global capture is your "only" alternative to capture the changes missing or if you know what to put in then just add those resources (files,registry) into the layer after a "regular" capture.

Doing a global capture will capture more then just the wanted resources but may be easier to just see what's missing and then add those to the "clean" layer.