Video Screencast Help

Windows Failed To Start After Deploying Image

Created: 14 Nov 2012 | 14 comments

I am getting an error after an image is pushed to my computer. It shows the "Windows Boot Manager", and then it states that "Windows Failed To Start, etc."

Here's what I am doing.

1. Insert my "automation folders.iso" into new computer.

2. Boot computer to CD

3. System loads network drivers just fine.

4. Push task to deploy Windows XP.gho image to new "minint..." computer.

5. PC gets task and image starts to push.

6. Image seems to push fine.

7. Image goes through sysprep.

8. This is when I get the error.

Any suggestions? I am trying to recommend this software for a company, and I keep running into all these issues.  They may not want this software if I can't get it running smoothly without all these issues.

Comments 14 CommentsJump to latest comment

etk1131's picture

When the machine reboots after the image lays down, push F8 and select "Disable Automatic Restart on System Failure" so that you can see what the error code is.  The most likely one I'd expect is a STOP 0x7b, which is an inaccessible boot disk.

Are you using DS 7.1 with DeployAnywhere?  If so, you may not have the mass storage driver added to your DA database.  It's likely in your Automation Folders iso, so that when you boot, the HDD is accessible, but I've run into issues where I've forgotten to update my DA database with the relevant storage drivers.

You can add them from the SMP console (Settings/Deployment/Driver Management).

Hope this helps.

Cyclones92's picture

Thank you!! I will most definitely try that.  I hope that works for me.  I will update this once I try it.  I won't be able to until Monday, November 19th.

Cyclones92's picture

Well, it ended up failing again. :(  Here is what I did and it still failed.  Did I miss something? I am thinking of creating a video to show what is happening or if I am just missing something.

  • I downloaded the 960 drivers and used the DeployAnywhere to add them.
  • I saw that the drivers were added.  
  • I then launched "bootwiz.exe" to create another automation iso image
  • I then burnt that ISO to disc and started the image process over
  • I then got the following errow below/attached. 

etk1131's picture

Windows Boot Manager is Windows 7, which I assume is what came stock on the machine you're trying to image.

Since you've mentioned Windows XP as the target OS, it looks like maybe the image isn't actually laying down.  Did you use bootwiz to add the pre-boot device drivers as well?  Do do this, go into bootwiz and from the Tools menu choose Add Pre-Boot device driver.  For this to work, you'll need Vista drivers (32-bit) if you're running WinPE as your automation environment.  You will need to add mass storage and NIC drivers there.

Unfortunately, the drivers need to be in place in both the DA database and in the pre-boot environment.

Hope this both makes sense, and helps!

Thomas Baird's picture

There are two sets of drivers that "may" be needed here.  Be sure NOT to confuse them.

1) Windows PE drivers.  These are VISTA, no matter what image you're placing.  They're applicable to BootWiz and a recomplie of the automation envirionment.

2) Your target OS drivers.  These are for DeployAnywhere, and MUST match the OS version you use exactly or they will not work.

When you're adding drivers in the console, there are two tabs - one for each of these.  If you add to the wrong one, well, you gain little or nothing.

When you get a boot failure like above, unfortunately, we don't know WHERE that failure happened.  Right now, the failure appears to be when attempting to boot to WinPE, which if that is the case, then affects your image in now way at all.  You may want to remove the drivers you added IF that is the case, especially if this happened only after adding them.  Remember that Automation is WinPE 2.1 and that is VISTA, not XP, not Win7/8.  Not until the next release...

However, if this failure is happening when you boot the main OS that you just deployed, then the drivers are missing to access the Hard Drive most likely (Mass Storage).  This is a hard-stop for the OS.  If those are missing, you MUST add the drivers to DeployAnywhere, NOT to bootwiz, and a recompile of the automation environment makes no difference at all.  The drivers added MUST be in the right format, and MUST match exactly the OS you are deploying (e.g. Windows 7 x86) or they will not work.

So, determine where the error is, add the right drivers, and you should be well on your way.

Thomas Baird
Enthusiast for making things better!

Cyclones92's picture

Thank you all for replying.  I do have a question and not sure if it is the cause or not.  I am capturing and deploying Windows XP btw, but the image I captured using AF had two partitions on it.  We used to use the older version of Ghost to capture and deploy images and of course it had two partitions on it.  When I captured the didn't capture both the ghost partition and the OS partition would it since I used AF.  AF should have just captured the partition I was on?

I did download the Windows XP .cab file from Dell for the Optiplex 960.  DeployAnywhere added all the drivers without giving me an error.  This was for the "network" and "storage" drivers for x86 and x64.  I just added them all.  I then had created the iso again to make sure after using the bootwiz to create it.

So should I add the Windows Vista drivers for network/storage as well for the preboot DA database? I haven't done anything nor added any Vista drivers yet for either. 

Your explanation, both of them, are very helpful.  I will definitely give that a shot as well.

Thomas Baird's picture

Remember there are 2 tabs you have to load drivers into - and depending on which tab, you get different "fixes".  If you need the drivers for when you reboot to production, you do it in DA.  If you need the drivers for Automation (that is, WinPE will not run or connect to the internet) you load them into BootWiz.

We don't like recovery partitions if you're using Automation folders - gives us headaches.  Not sure specifically in this case without more information.

Keep us posted.  :D

Thomas Baird
Enthusiast for making things better!

etk1131's picture

Here's how I captured and deployed XP using DS 7.1:

1) Build and configure the OS on a reference system, including whatever software you wish to have on the image.  I only install the NIC driver if Windows doesn't pick it up.  Be sure to install the Altiris (Symantec Management) Agent and allow all the subagents you wish to install as well.

2) Upload Sysprep CAB files to the SMP (Settings/Deployment/Sysprep Imaging Configuration)

3) Upload network/storage device drivers (for XP) to the DeployAnywhere database (Settings/Deployment/Driver Management - DeployAnywhere tab)

4) Upload network/storage device drivers (for VISTA) to the Pre-Boot (WinPE) environment (Settings/Deployment/Driver Management - Preboot tab)

5) Recreate automation environment to incorporate the VISTA drivers you just added; burn to a disc if that's how you've been getting to Automation

6) Create an image capture job that includes the following tasks (in order):

  1. Prepare for Image Capture (this will run Sysprep using the CAB that you uploaded, then reboot - specify if you're going to boot to PXE or Automation)
  2. Create Image (this is where you'll set the name of the image and what imaging tool you're going to use - we use Ghost in my environment)
  3. Reboot to Production

7) Run the above capture job on the reference machine.  You'll see the Sysprep running, and then the system will reboot.  Boot to the disc that you created to get to Automation.  The image creation will run once the system gets into Automation, and at the end you'll have an image on the server.

8) Create a task to deploy the newly captured image, and you should be able to push it down to the system while it's in Automation.  Be sure to include DeployAnywhere so that the drivers that you uploaded to the DA database (the XP ones) get injected when the image process is complete.

Hope this helps.

joegman's picture

You might have the same problem I have and I have not been able to resolve it yet.  However, I have not been able to devote much time.  My workaround is to delete the Dell utility partition before pulling.  When I push that image, I have no problems. I can pull/push Win 7 images with multiple partitions, but XP breaks.

I will eventually figure this all out but right now it bothers me that my retail Ghost will pull and push all day no matter how many partitions I have with no problems, but Ghost bundled with Altiris is so finicky.  

Cyclones92's picture

Thank you all again! I will try all these options and see how they work.  I hate not being able to work on this daily and only have a couple days a week to do this, but hopefully I can fix this issue.  

Cyclones92's picture

Okay...what I am doing wrong here???  Nothing is working.  I built a brand new Windows XP computer with no additional software on it besides updating it.  I then installed the plug-ins and pushed the Automation Folder to it.  I then captured it, worked great.  I then pushed it to another PC...worked great...only until it finished doing the sysprep afterwords and I got another error...except it ends with an "e" instead of an "f" as shown above.  I downloaded the pre-boot and the deployanywhere files from Dells website.  I extracted the .cab folder and uploaded them all.  I rebuilt the AF by using the bootwiz.  At the rate I am going...they are going to scrap this project and move on.  

Cyclones92's picture

Sooo...I tried that RapiDeploy instead of Ghost to capture and deploy the image...and it actually worked! Not sure why it would over the other, but I am going to try and capture my BIGGER image and see if it works or not now.  I won't know until later though.

joegman's picture

Ah, I might give RapiDeploy a shot then. I do not want to spread mis-information, but I remember reading that RD will be phased out soon so that is why I have been focusing on Ghost. 

Nelo's picture

that is a bcdedit error. do a search for bcdedit here on connect I created two posts how to solve that problem.