Video Screencast Help

Windows host process (Rundll32) has stopped working

Created: 07 Mar 2008 • Updated: 29 Jul 2010 | 25 comments

Running SVS 2.1 SP1 (2.1.2088), fresh install on Vista Ultimate. SVS itself works.



Whenever I try and run the Altiris SVS control panel applet I see a command window open briefly and close and then get "Windows host process (Rundll32) has stopped working".



If I acept the offer to check online I get nothing back.



The details shown are:



"Problem signature:

Problem Event Name: BEX

Application Name: rundll32.exe

Application Version: 6.0.6000.16386

Application Timestamp: 4549b0e1

Fault Module Name: StackHash_8252

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: 00127a10

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.0.6001.2.1.0.256.1

Locale ID: 2057

Additional Information 1: 8252

Additional Information 2: b8f3ee3bfbe1d8693afe559ca9393149

Additional Information 3: e2d5

Additional Information 4: caa1a55a423f6f49a21ac74e395dfc51"



This happens on two different computers, one with Vista SP1, one without.



How can I troubleshoot this further?

Comments 25 CommentsJump to latest comment

Andy Knowles's picture

One is an AMD Sempron 3100+, the other is an Intel Core 2 Duo 6320

philbenson's picture

I have the same problem running on Vista Ultimate SP1 various VM images. Perhaps it has something to do with DEP. Does anyone know offhand which dll's would need to be included in the DEP exclusion list?



I'm running SVS .95



Phil

Curtis Brown's picture

Same problem pre and post SP1. Post SP1 was a clean install. Desktop and laptop.

Tried adding SVS and Rundll32 to DEP exceptions. Tried turning off DEP and turning off UAC. Same result with immediate shut down.



Intel Qx6800 (hardware DEP support). Abit motherboard Running etrust for antivirus. Ati vid card. Vista Ultimate.

Laptop is Intel pentium M (hardward DEP support), etrust and Nvidia video card. Vista Enterprise.



Is this application even under development anymore? Amazingly sparse here and Juice barely has any posts in the past few months (and I couldn't find anything on this app elswhere) and no updates for almost a year to the app.

Dissapointed if that is the case as I very much like the idea of the app (and when it worked for me on XP) to deal with trouble things like Power DVD and beta apps.

Jordan's picture

Sorry on the lack of info everyone. The control panel app isn't developed by the SVS team so the people who watch this forum, like myself, have little or no knowledge on how it works or what might be causing the problem.



All I personally know is if you're running a 32-bit OS in a VM who's base machine is 64-bit you're almost guaranteed to have this issue.

If a forum post solves your problem please flag is as the solution

Curtis Brown's picture

Thanks for the reply Spriggan.



Sorry, in my case should have corrected that I don't have the exact same problem as Andy, with lauching the control app. Rather what I get is the exact same error, but it is in trying to launch the SVS application after install. This is on a 32bit OSs, not 64.

I simply can't (and haven't ever been able to) use SVS 2.0 or 2.1 on Vista Ultimate or Enterprise. Pre and post sp1. Rundll32 shut down.

Jordan's picture

Vista support didn't come until SVS 2.1 but it's interesting you can't get that to work, I use it all the time on my Business edition at home and Ultimate here at work. How are you using it? Is it when you run SVSadmin or SVScmd that you get the crash? Because SVS itself is loaded at the time windows starts up and those two programs are just a way to interact with SVS.



SVS is still under development, we're hard at work on 3.0 and have another update coming out this year (no dates, sorry guys) for the 2.X line.

If a forum post solves your problem please flag is as the solution

Curtis Brown's picture

Ok, I apologize, I got confused as I didn't (and don't) see SVS running so I assumed that svsvista.exe was launching the program. I am indeed having the same problem listed above. Trying to launch the SVSControl Module svsvista.exe, causes the failure. I also found and tried the application named "Alternate Admin Console" and have the same result of immediate Rundll32 shutdown.



To you comment that it is already installed and running, can you point me to what I should be seeing if this is the case? I do not see anything in the running processes or services. I looked in services that weren't running as well and didn't see anything that looked like it might be related to svs.



I was able to install 'trinket' however all the options (except 'about' and 'exit'). Not sure if this is an indication that it isn't running or simply that they are grayed out until you create a layer.



Also, I tried going to Uninstall programs and 'modify' the SVS install to 'run all from my computer' and I it stopped towards the end with a 'fatal error'. The same thing happened when I select 'repair'. It goes through the uninstall process fine.



Not sure that it is relevant, but I've never tried running it on something less than Enterprise or Ultimate versions of Vista. These two versions do have core differences to the rest though I have no idea if that is causing any of what I'm seeing. I'd like to assume that some of the Vista users who have had success with SVS are running these editions.



I'm confused as to how the admin console is not part of the application as you mention given that you download and install it together. Regardless, even if SVS is running somewhere, I'm not a command line capable guy so if I can't get a gui it isn't usable to me.

Jordan's picture

did you restart after installing? Because it's sounding like SVS may not be loaded or you never entered a license key because that would cause you only having access to about and exit.



Easy way to check is to launch SVSadmin (C:\Program Files\Altiris\Software Virtualization Agent\SVSAdmin.exe) and then goto help->About and see if there's a registration key and a driver version listed.



Since SVS is a driver you won't actually see a process for it in Task Manager until you have an app running that uses the driver.

If a forum post solves your problem please flag is as the solution

Curtis Brown's picture

Restarted many times. Always installed under an administrator account and launched the install 'run as administrator' as well as simply using the UAC prompt. I've also installed with UAC disabled (disable, reboot - install, reboot). Key was entered each time, using a different key (via the 'get key now' option on install).



I was able to validate that SVS is installed and does at least create and activate layers. Using SVScmd.exe I followed the command list to create two test layers, activate them, and report they are running. I also used the command to validate that it had a key that it reported valid.







Note that there is no file called SVSAdmin.exe in that folder. All the files installed in Vista are

AltirisVSProvider.ddll

AltirisVSProvider.mof

SVSapplet.chm

SVSCmd.exe

SVSvista.exe (this is the control module that crashes with the rundll32 DEP message)

SVSVistaTask.xml

SvsWmi.dll

SvsWmi.mof

UIUtils.dll



So the primary problem appears to be using a GUI to control the files, which again, for me, is the only way I could use it with reasonable amounts of effort.



Any suggestions on other graphical control tools to try would be appreciated. As noted i tried "Alternate Admin Console" with the same result as svsvista.exe.



I'd be glad to provide any files that your devs would be interested in seeing to try to figure out why it is that the GUI is crashing for us on Vista.



Thanks again for your help.





Additional notes:

Rundll32 problem detail:



Problem signature

Problem Event Name: BEX

Application Name: rundll32.exe

Application Version: 6.0.6000.16386

Application Timestamp: 4549b0e1

Fault Module Name: StackHash_5b8a

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: 0034b528

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.0.6001.2.1.0.256.4

Locale ID: 1033

Additional Information 1: 5b8a

Additional Information 2: ee07390d92b0059782965f5f4b1d8d73

Additional Information 3: 260e

Additional Information 4: 9a171b23eadca812a2aa0d55478b0d80



Extra information about the problem

Bucket ID: 213701049



SVScmd screenshot of layer creation, activation, and key validation:

Jordan's picture

No SVS admin? Someone must have given you a modified MSI because it's included with SVS and there should be an icon for it on the desktop, I recommend getting the latest version of SVS from https://kb.altiris.com/article...?article=29519&p=1 and installing it. You can also just goto add/remove programs and click repair for SVS and you should have the option for adding it, though if you don't have the most recent version (2095) I would just download it. You're also missing files, here's my list:



AltirisVSProvider.DLL

FSLUI.DLL

SVSAdmin.exe

SVSapplet.chm

SVSCMD.exe

SVSVista.exe

SVSVistaTask.xml

SVSWmi.DLL

UIUtils.DD



The files missing are all UI related but that's not causing the SVSVista crash since I get it too on my system.

If a forum post solves your problem please flag is as the solution

Curtis Brown's picture

As I couldn't modify the install, as it fails, I went ahead and used your link and installed the latest version from there (after uninstalling, reboot, install, reboot). The other version was from svsdowloads as the Juice site gave a dowload for SVS that took you to altiris site and another one for SVS Personal Use Download which took you to svsdowloads.



So, I figured out that the Admin app was the radio button I hadn't checked on install as it seem ot infer it was more for corporate application packaging use and it had previously caused the application to fail to install (which I figured out was simply that during those tries I hadn't tried to launch the install by selection 'run as administrator').



The good (and forehead smacking) news is that the Admin app was the core of what I was looking for and I thought it was SVSvista.exe.. So with that little, but critical issue resolved I can now use SVS! Of course making applications work is a whole other issue.. (first try, Quicktime isn’t working after app captured install and re-try..) Thank you very much for ending my confusion there!



The remaining issue of course the original subject of the post about the control module (before I detoured the thread). So is this not Altiris’ application, just bundled from a third party? Or it simply that you mean it is a different group in Altiris that you don’t’ work with?

Jordan's picture

Ah yes the little radio button, it's been a while since I manually installed SVS. Just a reminder that there are capture issues with Vista and it's recommended that you capture on XP and import to Vista, transactions cause problems for us and while I'm not sure if this is your quick time culprit it could be.



The Control Panel App is developed by a different group with in Symantec that the SVS team doesn't work with.

If a forum post solves your problem please flag is as the solution

aarontan's picture

Was this ever resolved? I'm now getting the same error as the original post.



Windows host process (Rundll32) has stopped working. And in the notification error, windows pops up a dialog saying that DEP has prevented it from running.



If I add C:\Windows\System32\rundll32.exe to the exceptions list, I still get the same error.



I'm running 2.1.2084 (HF2 personal edition)

Jordan's picture

Not for SVS 2.1 SP2 (that's in beta), as has been stated this isn't something the SVS group makes and so all I can do is pass along the information to another team.

If a forum post solves your problem please flag is as the solution

aarontan's picture

ok. Should be noted that I did a clean install of Vista and installed SP1.



I think Vista SP1 might have something to do with this.

Jordan's picture

Nope, it's never really worked on Vista.

If a forum post solves your problem please flag is as the solution

William Foster's picture

If anybody out there experiencing the issue described above is still reading this thread, will you check something for me. In your BIOS settings, do you have an option for Data Execution Prevention (DEP) and is it enabled? If you do and it is, does disabling DEP allow the CPA to start working correctly?

Evan Border's picture

This definitely appears to be a Data Execution Prevention issue. On two different Vista machines (one Home Premium, the other Ultimate), I always experience the error involving Rundll32.exe being shut down by Windows.



Yet the SVS Control Panel applet works fine if I first disable DEP from within Vista, then reboot and retry.



If I turn DEP back on again, the error returns.



Like a previous poster, I also lack the BIOS option to physically disable DEP on my machines. But DEP can be disabled in Windows Vista from the command line if you type the following:



bcdedit.exe /set {current} nx AlwaysOff



Note: You must have local admin rights *and* run the Command Prompt with elevated rights (or disable User Account Control). You will also need to reboot your machine after running the bcdedit command.



The boot configuration data editor can also turn DEP back on:

bcdedit.exe /set {current} nx AlwaysOn

(reboot is required)



Anyways, whatever group within Symantec is responsible for this applet needs to be tapped on the shoulder and provided with this testing info. This type of error really puts customers off and gives the impression that SVS is not ready for prime time (or at least for Vista). Obviously the customer is not going to see a difference between the applet and the SVS driver...they just see SVS generate a nasty looking error message.

Evan Border's picture

I just realized I wasn't totally clear in my last message about this being a workaround to the problem.



For anyone experiencing the Rundll32.exe error when you attempt to launch the Altiris SVS control panel applet on Windows Vista, there is a workaround.



Read my previous post (right above this one) for the instructions on disabling DEP in Windows Vista.

Anthony De Silva's picture

Disabling DEP is not an option where i work as we utilize Bitocker file encryption and it causes a warning message at boot when DEP is disabled. You also need to enter in your 54 character encryption key.



Symantec: What is the correct solution for this? The OS we are using is Windows Vista Enterprise SP1

Andy Knowles's picture

Thanks Evan, that workaround worked on my system.



I can confirm that, for me (Vista Ultimate SP1) the underlying problem still exists on Software Virtualization Solution 2.1 Service Pack 2 Maintenance Pack 2 (2.1.3066).



Now officially known as "Symantec Endpoint Virtualization Suite"