Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Windows login prompt pops up when accessing ASP pages on the EV server

Created: 13 Jun 2006 • Updated: 09 Oct 2012 | 10 comments
Andrew Miller 3's picture
This issue has been solved. See solution.

Has anyone experienced the problem where you get a Windows authentication login prompt whenever retrieving an ASP page on the EV server. In addition, no user id is accepted and yo u end up getting the 401 HTTP error or access denied. I am getting the login prompt for any of the EV server ASP pages (i.e. http://evserver/EnterpriseVault/search.asp) on both the server itself and when accessed by remote users. Below is a list of the environment and what I have tried so far.

Environment
1) EV 6.0 SP2 running Windows 2003 Standard SP1
2) EV Server is a Domain Controller (needs to be for testing purposes)
3) EV service account is a member of Domain Administrators (for testing purposes)

Troubleshooting done so far
1) Added in EV server name and FQDN name to Trusted Sites in Internet Explorer for EV service account.
3) Confirmed DNS records are working properly.
4) Disabled the loopback check.
5) Verified that IIS virtual server on EV server is running Integrated and Basic authentication.
6) Verified permissions on the IIS Virtual Directory on the EVserver.

Discussion Filed Under:

Comments 10 CommentsJump to latest comment

Micah Wyenn 2's picture

Andrew,

On the properties for the site (in IIS mgr), make sure that integrated windows auth is checked. That should prevent the site from prompting you.

micah

Andrew Miller 3's picture

Micah,
I already verified that it was checked. Any other suggestions?

Thanks,

Andrew

TonySterling's picture

Is http://evserver in you local intranet zones? In v5 you set this in the desktopsettings.txt and in v6 it is on the adv. tab of the policy to allow EV to add this when the synch occurs. For reference you can look at the section on Add server to intranet zone in the admin guide.

Jason Szeto's picture

Add the EV server URL to the local intranet zone under your IE settings. You can push that out from under your mailbox policy Desktop settings.

Andrew Miller 3's picture

Yes,
Both the DNS name (http://evserver) & the FQDN wildcard name (http://*.domainname.com) are added into the Local Intranet Zone and the problem still occurs. It almost seems to be an IIS permissions issue but I verified the IIS permissions and didn't see any problems. Even launching the simple about.asp page causes the login prompt to occur. Both Event Viewer and DTrace show no unusual events. Is there any special IIS settings that need to be set when running Enterprise Vault on a Domain Controller?

Thanks,

Andrew

TonySterling's picture

After you added it did you do a synch of your users? Also, make sure that they are actually showing in IE security for local intranet.

Micah Wyenn 2's picture

Yeah,
And check the IIS site settings again. I've got a strange feeling that somehow you don't have the integrated windows auth option box checked in the right levels of the tree. Go from top to bottom to ensure that it's getting set correctly.

Really, it shouldn't prompt you unless you're not in a trusted domain (to Tony's post), or if the option isn't enabled. The only other thing I can think of is making sure the IIS server can contact a GC for AD. But I'm figuring you would have noticed that by now if it really was the problem.

micah

Micah Wyenn's picture

I just saw an identical problem in another client site. Turns out support told'm to run multiple directory servers and enterprisevault websites. when you click on the vault usage report, look at the bottom of the window to see which actual server you're loading the asp from. If you've got multiple EV servers, you very well may be loading the page from an unexpected server source. To fix, find the server that's loading the offending page, and disable integrated windows auth.

micah

SOLUTION