Video Screencast Help

Windows Search Issues

Created: 04 Jan 2013 • Updated: 10 Jan 2013 | 13 comments
This issue has been solved. See solution.

Hello, I have some issues with EV and Windows Search. First of all my client is 64-bit Win 7, 32-bit Office 2010 and EV client says in Outlook. I am not sure what is running on server side, corporate IT maintains that. They say my experience is a known issue with EV and they hope it would be fixed in coming service packs. I wonder if it is however some configuration or installation issue.

So, my vault is part of indexing and Windows Search as well as Outlook's own search find items from index but clearly it includes only the metadata part since I do not get hits on attachments at all or words in large emails which are past the 120 (or something like that) word limit. Furthermore, even if I find an email with this method I cannot open the mail from the search results. Hourglass displays for a brief moment and then nothing. Search hits from mailbox or pst files open just fine. If I use the special "Search Vaults" feature I can find items but that is too clumsy for everyday use because it searches only the vault.

Some items from the ev_client_log which might be relevant:

[EV WDS plugin disabled - 64 bit OS and 32 bit Outlook not supported]


The indexing operation performed by the WDS protocol handler failed: 0x80040154

Comments 13 CommentsJump to latest comment

Rob.Wilcox's picture

Using Outlook's "Instant Search" will only search the metadata... subject, date/time, author, recipient (that sort of thing) and up to 120 characters of the message body.

If you have Vault Cache as well as Virtual Vault, and you have the content policy set to store all content, or to store all viewed content thent hat means you'll have several .DB files on disk .. these contain archived data.  Windows Search can index those.

I *thought* that mixed-bitness worked nowadays, but maybe I am wrong.  Your client version doesn't quite add up..  Can you copy the environment section out of your client log and post some or all of it here?

c-3po's picture

I hope this is what you were asking for:

04/01/2013 07:10:40.005[26008]: Environment:
04/01/2013 07:10:40.005[26008]:     Enterprise Vault Client (HTTP)
04/01/2013 07:10:40.005[26008]:     Microsoft Windows 7 Enterprise Edition Service Pack 1 (build 7601), 64-bit
04/01/2013 07:10:40.005[26008]:     Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz Intel64 Family 6 Model 42 Stepping 7;
04/01/2013 07:10:40.006[26008]:     Microsoft Outlook 2010, 32-bit (
04/01/2013 07:10:40.006[26008]:         [EV WDS plugin disabled - 64 bit OS and 32 bit Outlook not supported]
04/01/2013 07:10:40.006[26008]:         [RPC over HTTP enabled (flags = 39)]
04/01/2013 07:10:40.006[26008]:     Microsoft Internet Explorer 9.0.8112.16421

c-3po's picture

Outlook Instant Search only metadata: ok I can live with that, my main concern is Windows Search.

Content policy: I am not sure what that means but I definitely have .db files in a folder called ...KVS\Enterprise Vault\8C529CA95CCD6148972775796A0F7564. For whatever reason it seems those are not getting indexed.

Rob.Wilcox's picture

It sounds like you do have local Vault Cache data - that's a good start.


For whatever reason it seems those are not getting indexed.


The reason for that is stated in the part of the trace that you posted:

04/01/2013 07:10:40.006[26008]:         [EV WDS plugin disabled - 64 bit OS and 32 bit Outlook not supported]

But, I thought that that particular hurdle had been bounded by the EV Engineering team whilst I was still at Symantec.  I'm just testing it here now.

Rob.Wilcox's picture


Enterprise Vault Client (HTTP)


This from your client trace is the EV 10.0 client, ie not one of the service packs.

I also get the same message about WDS being disabled.

I have just tried the 10.0.2 client, to see if that makes any difference.

And I no longer get the message in the client log file.

To be honest I think (vaguely recalling some months ago before I left Symantec).  This a timing-collision type of thing.  The release of EV 10 overlapped with some of the EV 9 work, meaning that the base release of EV 10 lacked some functionality that was then added to EV 9.  That missing functionality was caught-back-up-with in EV 10.0.1. I think.

So .. the fix?  Use the 10.0.2 client.  I think you'll see that Windows Search even with mixed bit-ness is going to be okay now.  Give it a try in a controlled environment -  I have run out of time on mine. 

Outlook Instant Search though will still only search the Virtual Vault 'meta data', not the full item.

[Bear in mind that sometimes a rebuild of the WDS index is needed, and/or a few Outlook restarts....]

c-3po's picture

Thank you Rob that sounds good, I will talk with the folks responsible for our EV installation. If I understood correctly they were already planning on rolling out the 10.0.2 version.

c-3po's picture

I have now client version 10.0.2 and partial success. I can now open items that I find with Windows Search but search is still indexing only metadata. Index has been rebuilt as well as the local Vault Cache.

I wonder if this is related; if I look at the EV user guide PDF, it shows a separate "Vault Cache" item in the indexing dialog but I do not have one. I have only the Vault item under the Outlook branch.

Joseph Correia's picture

Could it be that in the Desktop Policy the "WDS search auto-enable" setting is configured to "Forced Off"?

This setting controls the vault cache search filter for WDS.

This would be under the control of the IT folks managing the EV environment.

I believe the default setting is "Forced On", however they may have disabled it for some reason?

c-3po's picture

Thank you Joseph, they told me it is set to "keep user's setting" and after some googling I found that I should in that case then run installation with the ACTIVATE_WDS_PLUGIN=1 option. Once I did that I got the "Symantec Vault Cache" item in the indexing list. My index is now rebuilding so I will see after a while if this fixes all my search issues.

However, once I ran the setup with this option I encountered same problem as described here:

I can get around it by setting log level to 2 but it is odd that I had no problems until I reran the installation with this option. Uninstall / reinstall without the option did not fix it anymore.

Rob.Wilcox's picture

I am 94.7% sure you're sorted now..  Since you'll see entries like this in Windows Search:

When you click on the one which looks like an archived item -- well, you can imagine what should happen :)

c-3po's picture

Thank you Rob and Joseph for all your help, everything works now as it should and after rebuilding caches and indexes it seems I can drop also the log level back to normal. Case closed :)