Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Windows Server 2012 and Backup Exec 2012

Created: 14 Apr 2014 • Updated: 15 Apr 2014 | 5 comments
This issue has been solved. See solution.

I recently upgraded one of our Server 2008 R2 servers to Windows Server 2012 R2. This was a test machine to see how the upgrade process would go and what issues i would have. Backup Exec 2012 seems to be the only issue I'm having. We started with Service pack 3 but as part of the troubleshooting we moved up to Service pack 4. When clicking on the desktop icon to run backup exec i get the following error.

Capture.JPG

 

If i right click and run as administrator it will open up fine. Here comes the line that nobody likes to hear "It worked that way before". It works in Server 2008 without running as administrator and it even works in a fresh install of Server 2012 without running as administrator. This isn't a huge issue but we do have a few people that aren't used to doing that and if i can keep it as close to the same as its always been i know it will keep them happy (Plus they are getting used to the new UI in backup exec 2012). I have tried running a repair on backup exec and it still continues to have issues after that. We have backup exec on about 160 servers so i would like to try to keep from uninstalling and reinstalling (Mostly because we just uninstalled 2010 and installed 2012 over the course of a few weeks so i would hate to do it all over again). We login to server with domain admin accounts. The server i upgraded is a Domain controller, DHCP, File Server, Print server and does host IIS Internet printing.

 

Digging deeper i found using process monitor its failing on one registry key trying to open it.

Capture_0.JPG

I gave myself full control to that registry key and tried running it again and it failed to start up with the error "BackupExec has Stopped working". Which in event viewer shows some type of memory dump error.

Capture_1.JPG

Not really sure what I can try next as thats why I'm posting that to hopefully get some suggestions on what i may be able to try next.

Operating Systems:

Comments 5 CommentsJump to latest comment

EyeintheSky's picture

I hate to say it, but do you know that Backup Exec 2012 is not supported with Windows Server 2012 R2? Backup Exec 2012 R2, which has been renamed Backup Exec 2014 is supposed to fix that.  Symantec is insisting that it will be released in the 2nd or 3rd quarter, but I wouldn't be surprised to see it renamed Backup Exec 2015. 

lmosla's picture

Is this the media server that was upgraded to 2012?  

As EyeintheSky said,

Backup Exec does not currently support being installed on a Windows 2012 Server. This will be supported in the release of Backup Exec 2014.

Support for backing up a remote Windows 2012 server started with Backup Exec 2012 SP2

SOLUTION
pkh's picture

Note that BE 2012 does not support the backup of Server 2012 R2.  This will also come with BE 2014.

crazynick9600's picture

thats fair enough. I thought i read somewhere it works as long as you have service pack 2 or something like that. But maybe i misread. anyways thanks for your help everyone.