Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

WMI Writer fails during freeze operation

Created: 20 Aug 2013 • Updated: 05 Sep 2013 | 6 comments
This issue has been solved. See solution.

I have Backup Exec 12.5 installed on a Windows 2008 SP2 32-bit server. I have the following error happening on all of my backups: 

 

backupexecerror.PNG

 

The only writer that has an error is the WMI writer: 

Writer name: 'WMI Writer'
   Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
   Writer Instance Id: {1ae70cd1-b332-49b3-b95c-bb3b97e4c659}
   State: [9] Failed
   Last error: Retryable error
 
I set the service for volume shadow copy to automatic and to restart the service after 1 minute on failure. The backup gets about halfway done before it fails. I'm stuck at this point in time. Any help would be great, Thanks.
Operating Systems:

Comments 6 CommentsJump to latest comment

Jaydeep S's picture

Please revet back the settings for VSS to default, 'Manual'. Try to re-run the backup with AOFO unselected. Also, have you tried rebooting the server.

VJware's picture

Most commonly, this error can be resolved by stopping the WMI service, re-registering a WMI dll and/or recreating the WMI repository and then restarting the WMI service. (However, you may attempt these steps only on Windows 2003 servers and regarding Windows 2008, would recommend to contact MS to confirm the same)

lmosla's picture

Hello,

on windows 2008 servers writer errors are often cleared with a reboot.  Reboot the server and then retry the backup job.  If the error still occurs check Windows Events for errors that occur when the backup is run.

Ryan OFlaherty's picture

@Jaydeep - I set VSS to Manual in the services and unchecked AOFO on the backup. I rebooted the server. No luck.

 

@ VJware - I stopped the WMI service, renamed the repository to repository.old, started the wmi service, and tried to backup but it failed.I am going to try re-registering the .dll files and I will see how that goes.

Ryan OFlaherty's picture

The backup also gets about halfway everytime and then fails.

Ryan OFlaherty's picture

I tried  registering the dlls but that didn't help. I ran 

 

Winmgmt /salvagerepository

then 

Winmgmt /resetrepository

 

and the backup started working properly.

SOLUTION