Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

WOL not success on cross subnet

Created: 29 Oct 2013 | 9 comments

Hi,

I use WOL (wake on lan) to wake up an agented PC in a subnet. But I find the task server (located in another subnet) send a WOL boardcast (255.255.255.255) to its own subnet. It is sure that the PC cannot be wake up since WOL signal cannot cross subnet. What wrong of my NS server setting causing this?

Thanks.

Operating Systems:

Comments 9 CommentsJump to latest comment

pete_4u2002's picture



 

How does Wake on LAN proxy and Multicast proxy work?
Article:HOWTO4536  |  Created: 2006-08-04  |  Updated: 2008-06-12  |  Article URL http://www.symantec.com/docs/HOWTO4536
Daniel Chan 852's picture

Hi Pete,

Thanks so much for your reply.

Actually, in order to setup proxy, I tried before to enable the tickle in Symentec Management Console =>

SETTING> TARGET AGENT SETTINGS> ALL DESKTOP COMPUTER (excluding 'Site Servers')> Advaned> "Enable tickle on Symantec management Agents"

Reference : http://www.symantec.com/business/support/index?page=content&id=HOWTO60829

However, it still failed to wake up the clients.

So, I hope to know any other setting needed or

How can we setup clients as a proxy correctly (I am using NS server ver.7.1) ?

Thanks.

Daniel Chan 852's picture

Thanks Rajaganesh.

I try to capture the packet on site server subnet (pic1.jpg). It ONLY has a magicpacket to 255.255.255.255 from the site server (IP : xxx.xxx.zzz.37) and the MAC address is correct (i.e. the PC wanted to be wake up). There is no 2nd packet shown in the reference:

http://www.symantec.com/business/support/index?page=content&id=TECH38547

Also, I cannot capture any WOL packet in client subnet.

It seems the site server didn't send WOL packet to its gateway (xxx.xxx.zzz.255). 

I try to setup another site server, assign the client PC to be managed by it but still having the same result.

Any more idea based on these information?

Thanks.

Note: The client PC can be waken up if it is placed in same subnet with site server. So, the BIOS setting of client PC should be correct.

pic1.JPG
Rajaganesh's picture

You may need to make sure the UDP port no : 52028 and 52029 are not blocked by the network.

For more information : http://www.symantec.com/docs/DOC1892

Daniel Chan 852's picture

Thanks for your reply. I search that reference before and discussing with our network engineer and sure that 52028 and 52029 didn't blocked already.

I also try to capture the tcp 52028 and udp 52029 port on both site server subnet and client subnet but both have no packet detected (pic2.jpg).

The problem seems due to the site server didn't send WOL packet to its gateway (xxx.xxx.zzz.255) or didn't send any packet to 52029 or 52028 port. So, I feel missing some setting in Altiris NS / SiteServer.

Thanks.

pic2.JPG
Rajaganesh's picture

Could it also be  a task server issue,Is the task server registering to itself ?,Does it handle other tasks to the client on the subnet ?

Daniel Chan 852's picture

The site server can handle other task such as running script, deployment on that client. Also, I had also try to setup another site server but it gave the same result.

What should I setup to make sure WOL packet will send out from site server?

Thanks.

Rajaganesh's picture

Shouldn't the 'All site servers' be included in the tickle/power management in the targeted agent settings.

Check this article : http://www.symantec.com/docs/HOWTO60817 - this will give you more insight of what is happening in the background.

1.  Check the Maintenance windows are enabled,If so you can try the override maintenance windows option that is available in the newschedule option  within the task.

2. Check to make sure atleast one client is awake on the remote subnet.

3. Check to make sure the directed broadcast is allowed in your network across subnets.