Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Workflow Error - Adding Server to Environment

Created: 01 May 2014 • Updated: 01 May 2014 | 5 comments

Hello,

I am getting the following error when creating a new environment on our NS.  One question, does Workflow Server need to be installed on the NS as well? Currently I have all the workflow components installed on one of our Site Servers.

Error in Workflow Enterprise Management. Method EnvironmentIsValid: Object reference not set to an instance of an object.

System.ServiceModel.FaultException (mscorlib): Error in Workflow Enterprise Management. Method EnvironmentIsValid: Object reference not set to an instance of an object.

Server stack trace:

at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)

at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

at Symantec.Workflow.Web.SvcRef.EnterpriseManagement.IEnterpriseManagementService.EnvironmentIsValid(String sessionId, Guid environmentId)

at Symantec.Workflow.Web.SvcRef.EnterpriseManagement.EnterpriseManagementServiceClient.EnvironmentIsValid(String sessionId, Guid environmentId)

at Symantec.Workflow.Web.EnterpriseManagement.DataAccess.EnvironmentIsValid(Guid environmentID)

at Symantec.Workflow.Web.EnterpriseManagement.EnvironmentsTab.ValidateEnvironment(Boolean showErrorsOnly)

Exception logged from:

at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)

at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)

at Symantec.Workflow.Web.EnterpriseManagement.EnvironmentsTab.ValidateEnvironment(Boolean showErrorsOnly)

at Symantec.Workflow.Web.EnterpriseManagement.NsemButton.linkButtonText_Click(Object sender, EventArgs e)

at System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e)

at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)

at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest()

at System.Web.UI.Page.ProcessRequest(HttpContext context)

at ASP.enterprisemanagement_default_aspx.ProcessRequest(HttpContext context)

at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

at System.Web.HttpApplication.ApplicationStepManager.ResumeSteps(Exception error)

at System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)

at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

at System.Web.HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)

at System.Web.Hosting.ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

**CEDUrlStart** :http://entced.symantec.com/entt?product=SMP&version=7.5.1670.0&language=en&module=47kSSdBRe9vga8bKwLzijkhJNoEEqGfMwwmYNv02xkv2hyLXzraqXMKDrpeVjfHd2ynZQ/6jkLsoWrCrn8X9NQ==&error=440372391&build=**CEDUrlEnd**

-----------------------------------------------------------------------------------------------------

Date: 5/1/2014 10:33:26 AM, Tick Count: 262075892, Host Name: OKCVDNS01, Size: 3.81 KB

Process: w3wp (5888), Thread ID: 9, Module: w3wp.exe

Priority: 1, Source: Symantec.Workflow.Web.EnterpriseManagement.EnvironmentsTab.ValidateEnvironment

File: C:\ProgramData\Symantec\SMP\Logs\a.log

Operating Systems:

Comments 5 CommentsJump to latest comment

TGiles's picture

When the Symantec Management Platform installs it will automatically install the Symantec Workflow Server Extensions service onto the SMP server. This service must be installed & functioning for proper use of the Workflow Enterprise Management functionality.

jdeleon7010's picture

I noticed the service is installed and set to auto, but is failing to start.  Here is the event log error.  Do I need to install the workflow server on the NS?

Service cannot be started. System.MissingMethodException: Method not found: 'Void LogicBase.Framework.Loader.LoaderBaseClass.RegisterServer()'.

at LogicBase.Deployment.WindowsService.LogicBaseDeploymentService.OnStart(String[] args)

at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

TGiles's picture

Sounds like the install didn't complete properly. I would run the Workflow installer to let it lay everything back down. 

reecardo's picture

Also, make sure the versions of WF are the same across both machines... the Core versions must match

jdeleon7010's picture

When moving production, do I need workflow installed on our NS as well as an SS?