Video Screencast Help

Workflow not progressing after end of dialog workflow

Created: 07 Jun 2013 | 2 comments

Hi all,

 

I'm not really sure if this is the correct way to be doing  what I'm doing but...

I have a form start workflow project, inside that are dialog workflows which I am using to display forms to the user.  The first form is meant to be a main menu so when you click on one of the buttons it then takes you to the next dialog workflow.

 

The problem I'm having is when running or debugging the workflow the process ends at the first end in the dialog workflow.  It doesn't return to the main model to continue the process. 

 

I've looked over the forms and can't really see an explanation, I am able to in the debugger go to the statistics tab, where there is 1 process still running and by clicking on the link for "Dialog Page" it will progress the workflow.  I don't know why it doesn't do this automaticly though.

 

Any help would be very much appreciated.

 

Untitled_0.png

Operating Systems:

Comments 2 CommentsJump to latest comment

reecardo's picture

If a debugged workflow "halts" at a Dialog Workflow component, it's just waiting for the task to get worked before continuing on in the flow. You can go to Process Manager to work the task, or you can go to the Workflow Statistics tab (in the debugger window) and drill down to work the task.

Once the task is worked, the debugged workflow should kick in and progress forward.

Jammes's picture

Hi Reecardo,

 

The dialog workflow I created is only just to alow the user to select an option, that would be its task.  When the user clicks a button it goes to the end of the dialog workflow I was expecting it to then feed back that information to its parent component (which is a linked module) but it only seems to sit at the end of the dialog workflow. 

My understanding is that the only way to get a form a workflow project is to put it inside a dialog workflow.  I might be misunderstanding the way the dialog workflow component works and perhaps there is another way to do what I want but just unaware of it.  I've tryed multiple options and looked at all the symantic training videos and am no further forward.