Video Screencast Help

Workflow Server Alias

Created: 21 Feb 2013 • Updated: 21 Feb 2013 | 6 comments
This issue has been solved. See solution.

How do I configure workflow and my projects to default to the DNS alias that I have setup instead of the server name?

Operating Systems:

Comments 6 CommentsJump to latest comment

rhamner's picture
  1. In Task Tray tool go to Settings-->Workflow Server Configuration-->Deployment Info. Change the RootUrl property.
  2. Restart Workflow Service.
  3. Redeploy all your projects or go into properties.config file of each deployed project and change the BaseURL property.
  4. Restart IIS.
  5. If you already have processes started there may be be some links stored in the TaskResponse table of database. They should continue to work since you're not changing the machine name but you could run an update query.
SOLUTION
noodleNT's picture

Thanks! You are on fire this week rhamner!

noodleNT's picture

Some of my projects are just data sync workflows that have no user interation. Do I need to redeploy those too or willl they be fine?

rhamner's picture

They should be fine as long as they don't generate tasks.

noodleNT's picture

I am trying to publish a link in an email to a ProcessManager report for our Help Desk to check the progress of their deployments. I tried using the following but it jumps back to using the server name and not there alias. Is there a better variable to use? I was trying to get something that would work when I publish to both my Test and Production environments.

 

[[ProjectProperties].EnsembleURL]/Portal/Template20_80.aspx?PageID=5a790419-9ffc-4aaa-8180-599fab8d4e85

rhamner's picture

On both Workflow machines go to in Task Tray Tool -- >Settings --> Servers and edit "(local)".  Change the IP field to the DNS name.