Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Writers keep failing

Created: 09 Sep 2013 • Updated: 16 Sep 2013 | 20 comments
This issue has been solved. See solution.

On the server I have BE 2012 SP2 loaded the backup of itself keeps failing.

I keep getting VSS snapshot unexpected provider errors.

During the backup the writers mentioned below are running fine.   After a reboot they are running fine again.

And two of the writers stop and give a [7] timeout error.

The WMI and System writers.

Symantec says it is a Windows problem?

I found one guy who reinstalled the agent and it fixed it but this is the BE server itself.   I do not see the agent in the add remove programs.   So assuming it does not need to be installed on the server with the BE software on it?

Thanks

Mike

 

Operating Systems:

Comments 20 CommentsJump to latest comment

Kunal.Mudliyar's picture

You can not uninstall a remote agent from the server which is a backup exec server as the remote agent is integrated with the package.

If you are getting VSS errors try rebooting the server and check the MS documentation to fix the vss errors, as if the VSS is bad even windows backups will fail.

Technical Support

Symantec

mli7777's picture

Well other backups are working well but of course they are different servers with just the agent on them.

So do you think any of the suggestions in this article would help ?

My main thought about trying is the one that re-registers the dll files ?

http://www.tomahawkbackup.com/faq/index.php?action=artikel&cat=8&id=117&artlang=en

It is a how to troubleshoot VSS errors.

 

Mike

 

Kunal.Mudliyar's picture

Mike,

Other server`s backup could be working because their VSS is good.

This link that you have shared looks like a good source of information to fix VSS however as these are OS related fixes Symantec can`t guarantee that this will fix VSS for you.

BE will not complain at the time of backup if the VSS writers are stable after the fix.

Technical Support

Symantec

Kunal.Mudliyar's picture

Hi Mike,

That article was about reregistering DLLs related to VSS.

We have to pull that off article as registering DLLs can cause unexpected failure and reinstallation of OS.

Please see this technote

http://www.symantec.com/docs/TECH173983

which quote

"Starting with Windows Vista and with Windows Server 2008, Windows component installation is manifest-based. Trying to manually register specific components, as described in the following steps, can have unexpected results that may require you to reinstall Windows to resolve.

Don’t reregister dll’s on Windows 2008 or 2008 R2:
Beginning with Windows Vista and Windows Server 2008, Windows component installation is manifest based, and most of the registry is locked down even to Administrator. However, the VSS binaries in Windows Vista and Windows Server 2008 still contain the code to perform self-registration. The code is removed in Windows 7 and 2008 R2.  We don't suggest you to re-register VSS binaries in Windows Vista and Windows Server 2008 or later operating systems.  For more information please contact Microsoft, or refer to their documentation.
http://social.technet.microsoft.com/Forums/en/windowsserver2008r2general/thread/062cc52c-899b-45f3-8d0c-798b92363f41"

Thanks!

 

Technical Support

Symantec

ANevatia's picture

Hello Mike,

Generally when the VSS writers are failing we ask customers to perform a reboot of the server. But It is not necessary that it is only a Microsoft related issue. It could be something to do with BAckup Exec.

The mechanism goes like this. When we backup some data we act as requesters requesting the VSS writer to take snapshot of the particular data and then we backup the snapshot.

If the VSS writer is timing out / failing then the snapshot is not created and hence the backup fails.

- Things you could check.

-What options have you selected under the job settings > Advanced open file option

-You should ideally be using Microsoft Shadow copy provider

-What kind of data are you backing up ?

-You could probably check the Windows event viewer > Application and System events for errors/

-Also re-registering the dlls might fix the issue but it should be done in consultation with MS.

-You could probably run vss trace to run some debugs for further analysis to find out the root cause of the issue. We would need to work in co-ordination with MS .

marcusolini's picture

Hi.  If you are still experiencing the VSS Provider failure, when able, please collect the following diagnostic information using the native Windows command line tools and post the information for review.  This diagnostic information is executed on the server that experiencing the VSS Provider failure.  Thank you.

(1)    C:\>VSSADMIN LIST VOLUMES
(2)    C:\>VSSADMIN LIST WRITERS
(3)    C:\>VSSADMIN LIST PROVIDERS
(4)    C:\>VSSADMIN LIST SHADOWS
(5)    C:\>VSSADMIN LIST SHADOWSTORAGE
(6)    C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\VSS"
(7)    C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\VSS\Providers" /s
(8)    C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\VSS\VssAccessControl" /s
(9)    C:\>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SPP" /s
(10)  C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\MountMgr" /s
(11)  C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\TrueCrypt" /s
(12)  C:\>REG QUERY "HKLM\SYSTEM\CurrentControlSet\control\hivelist" /s
(13)  C:\>VER
(14)  C:\>BCDEDIT /ENUM
(15)  C:\>MOUNTVOL
(16)(a)   C:\>DISKPART
(16)(b)   DISKPART> LIST DISK
(16)(c)   DISKPART> LIST VOLUME
(16)(d)   DISKPART> LIST VDISK
(16)(e)   DISKPART> EXIT
(17)  Backup Exec Job Log.  Text excerpts of the exact reported failures or exceptions.
(18)  Question: Physical Machine or Virtual Machine?

mli7777's picture

Yea we are still having the issue.

And I appreciate you looking to help.

I can run all those commands no problem I assume I am going to have to give you screen shots of all that stuff ??

Will look again and I don't think is has Diskpart on it I saw articles about that and was looking around some for that.

Thanks

Mike

marcusolini's picture

Hi.  You can copy and paste the text.  Either directly to the post or attached as a text file.  By the way, is your other post "Job Failed . Final error 0x8004230f(2147754767)" the same server or a different server?  Thank you.

mli7777's picture

I am attaching the requested information. 

And the last couple questions answers are this.   It is a VM running on VMWare 4.1.

The server I can't get backed up was working maybe 3 months ago according to the logs I caught a climse of it a few weeks ago but they are keeping this one for 16 weeks so they are gone now.

I just started working here and on this client just recently.

The server that has not backed up for many moons is the server with BE 2012 SP2 loaded on it.

It is backing up many other servers with no issues on them.

Thanks for the help.

Mike

AttachmentSize
datacollected.docx 242.57 KB
marcusolini's picture

Hi.  Thank you for collecting the requested diagnostic data so quickly!  Some additional diagnostic data is needed from the Backup Exec installation location.  When able, please collect and attached the below files for review.  Thank you. 

(19) C:\Program Files\Symantec\Backup Exec\Logs\{BE000CBE-11FE-4426-9C58-531AA6355FC4} - ASR Writer.xml
(20) C:\Program Files\Symantec\Backup Exec\Logs\{E8132975-6F93-4464-A53E-1050253AE220} - System Writer.xml
Note, This is an example location based on the default Backup Exec installation path.  Please substitute with the actual Backup Exec installation path.

 

marcusolini's picture

Hi.  Thanks again for the data!  There appears to be an issue with the System volume (\\?\Volume{54e0d5e2-e244-11e1-ac16-806e6f6e6963}).  The System volume appears to be offline.  The System volume contains the BCD Store, which is a part of the System State ASR component.  Resolving the System State backup failure can be as easy as running a command, however, since I do not know why the system volume is offline the command can ultimately fail.  If the command does succeeds, then the System State backup may succeed.  If the command fails, then the reason for the System volume being offline will require more involved diagnostics that cannot be conducted within the forum.  With that said, when able, please execute the below commands.  If successful, then re-try the previously failing System State backup job.  Please let me know the outcome either way.  Good luck and thank you.

(21)(a)  C:\>DISKPART
(21)(b)  DISKPART> LIST VOLUME

(21)(c)   DISKPART> SELECT VOLUME 1
Note, the 100MB Offline volume should now be selected.  Info:”Offline”.

(21)(d)  DISKPART> LIST VOLUME
Note, ensure that the 100MB Offline volume is selected.  An “*” will appear on the left of the volume.

(21)(e)  DISKPART> ONLINE VOLUME
Note, a success or failure message should be reported. 

(21)(f)   DISKPART> LIST VOLUME
Note, confirm that the 100MB Offline volume is now online.  Label:“System Rese”.  Info:”System”.

(21)(g)  DISKPART> EXIT

(22)  C:\>BCDEDIT /ENUM
Note, if the online command is successful, then the BCD Store should now be successfully enumerated.

SOLUTION
mli7777's picture

Awesome.

Won't be today but will take a shot at the info you gave me probably tomorrow.

Will let you know for sure.

Mike

 

mli7777's picture

Well the volume mounted not problem.

Have the backup running right now.

Will see how it goes.

Thanks

Mike

mli7777's picture

You ROCK dude.    :)

Hadn't backed up for months till today. 

Had to add a screen shot.   lol

Any idea why that volume was not mounted ??

Just curious.

Thanks again.

Had a ticket open on this with your partners in crime and they had pointed me to Microsoft.

Had not get that far yet and glad I didn't.

Have a great weekend.

Mike

 

success.PNG
marcusolini's picture

Great news!   I have no idea why the System volume wasn’t mounted and that is why I wasn’t confident that the manual online command would work.  Please consider marking this post as solved so others with this issue can perform similar self-help diagnostics.  Glad I was able to help.  Thank you for all of your prompt assistance with the diagnostics and resolution!  Have a great weekend as well!

James Ho's picture

I struggled with this problem.

Finally found this article which has fixed it so far (but I have only run one backup job since fixing it, will know more after this weekend).

 

http://www.symantec.com/business/support/index?pag...

 

marcusolini's picture

Hi. Although that technote you have referenced reports the same failure message, the root cause is different than what is occurring in this post.  That technote specifically pertains to Provider selection (not just limited to virtual machine snapshot) for which there may be a couple less intrusive resolutions.  Regardless, it’s good to know that that technote was helpful.

mli7777's picture

??

Hello James

Not sure if you read all the above.

The directions Marcusolini gave me concerning the volume not being mounted fixed my issue.

I did the diskpart commands to remount that drive and like you I have only done one successful backup but having high hopes it is fixed.

But thanks for the info.

Mike