Video Screencast Help

Zapping a mailbox returns error [0x8004011D]

Created: 21 Nov 2012 | 1 comment

Hi All,

Just thought I'd share this information as it drove me crazy for days.

We had about 20 or so users who could archive but restores would fail or hang, but after further investigation other symptons may vary. Basically when they tried to restore an email from the vault it would hang in the R1 queue and cause backlogs that simply wouldn't clear. I'm suspecting this could also affect the 'A' queues as well.

When we tried to ZAP the mailbox it would fail with the below error, and I couldn't work out why!

Error - Whilst processing mailbox with dn: (LegecyExchangeDN of user) [0x8004011D]

I dtraced the EVPM with no success, or no valid errors that explained why (not sure if that was the right one to trace). In the end I remembered a similar issue with our BlackBerry's and checked the users LegecyExchangeDN in ADSIEDIT.

Surprise! There was a space at the end of it! This is not something you can see in PowerShell...

After removing the space from the end and trying again... SUCCESS! Not only did zapping now work but recalls worked as well.

Be warned though, you cannot simply remove the space from the LegecyExchangeDN as you will break email for replies and cached entries in Outlook. You'll have to add the damaged LegecyExchangeDN as an X500 address to the users mailbox and then remove the space from the account either through PowerShell or ADSIEDIT (adsiedit is probably eaiser as you see what you are doing)

Hopefully this will be helpful to someone...

Comments 1 CommentJump to latest comment

AndrewB's picture

*thumbs up* to you. thanks for sharing this.

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner |