Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

zoning the data stores with full read write privilege

Created: 05 Jan 2013 | 6 comments
Rami Nasser's picture

Hi All,

The appliance 5220 v2.5 was configured as VMware backup host and the datastore of all esx osts are visible to this appliance.when i'm trying to discover the vm machine inside the esx servers it is failed to finf the client.my question is : is it possible that the data strores were zoned without privilage to read and write? or through zoneing no settings for privileges ?

Regards,

Comments 6 CommentsJump to latest comment

Marianne's picture

VM discovery is not done via the SAN. At this point the network is used with the user name and password that you added in Media and Device Management -> Credentials.
So, verify network connectivity and user name and password.

Also double-check that you have selected Backup Media Server in Backup options on the VMware tab in the policy to ensure Appliance is used as backup host and that Appliance is specified as STU.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Rami Nasser's picture

As the network admin said to me : user name and password for the vcenter has full previlage . and when i added the vcenter the validation was succeded using 443 port.
inside the policy i verified that the appliance is backup host and it specified as STU.

the main concern here about the previlage when zoning the data store !!!
what do you thing
Regards,

Marianne's picture

Zoning of datastores has nothing to do with discovery of VM's... It only plays a role in data transfer during actual backup.
I can use our demo 5220 to browse our in-house lab ESX server without data stores being zoned. 
Test backups are done using LAN.

Have you tried to select virtual machines manually, instead of the 'automatic through query' option?
Use 'Select manually' in Clients tab, then 'Browse and select...'

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Rami Nasser's picture

yes , "browse and select" taking too much time then hang,it is not finding any VM.the only way is to enter the full name,but when run this client it taking too much time discovering then failed.

Mark_Solutions's picture

This sounds very much like an earlier thread I dealt with here:

https://www-secure.symantec.com/connect/forums/using-query-builder-vmware-policy

It is helped / resolved by the disableIPResolution setting on the appliance:

On the appliance create the following file:
/usr/openv/netbackup/virtualization.conf
 
and then add the following section to it - this is all case sensitive:
[BACKUP]
"disableIPResolution"=dword:00000000

 

Probably best to re-start NetBackup on the appliance or reboot it after doing this

Then see if things work for you

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Rami Nasser's picture

I dont know why it become same as the link you mentioned.really agree with you.
But the main concern here is about the previlage when zoning the data store !!!
Because as I know that some storage has it own privileges to read and write,and other storage just creatin direct path to the luns no privileges needed.
storage are HP and 3PAR
thanks