Vidéos d'aide de Screencast

NBDB Database not alive

Created: 27 Janv. 2013 • Updated: 17 Mars 2013 | 6 comments
Ce problème a été résolu. Voir la solution.

Hi friends.

We are using Symantec Netbackup 7.0.1 on our Redhat Linux 5.0 Master server.

After restarting the server few days ago, we have observed that  Database[NBDB] is not available. Same error I have faced few months before and I followed the following steps to solve that error.

/usr/openv/netbackup/bin/goodies/netbackup stop

/usr/openv/db/bin/nbdb_admin -auto_start NONE

. /usr/openv/db/vxdbms_env.sh

bash: /usr/openv/db/vxdbms_env.sh : Permission denied

cd /usr/openv/db/data

mv NBDB.log NBDB.log.bad

/usr/openv/db/bin/dbeng11 -f NBDB

/usr/openv/db/bin/dbeng11 : error while loading shared libraries :libdbservll_r.so: cannot open shared object file : No such file or directory

/usr/openv/db/bin/nbdb_admin -auto_start NBDB

( /usr/openv/db/bin/nbdb_admin -auto_start BMRDB  -  If you use BMR)

/usr/openv/db/bin/nbdbms_start_server

Start ASA Server failed! error code :1

/usr/openv/db//bin/dbspawn -f "usr/openv/db//bin/NB_dbsrv"@" /usr/openv/var/global/server.conf"@"/usr/openv/var/global/databases.conf"

DBSPAWN ERROR :-935

Unable to start specified database ::Log file error

SQL Anywhere Start Server in Background Utility Version 11.0.1.2250

/usr/openv/db/bin/nbdb_ping

Database[NBDB] is not available

but now I am getting some errors while performing the above mentioned steps

Output of nbservice.conf

[CONTAINER]
[CONTAINER\nbrmms]
"ADMIN_REQUIRED"=dword:00000001
"ORB_THREADS"=dword:0000000a
[CONTAINER\nbars]
"ADMIN_REQUIRED"=dword:00000001
"ORB_THREADS"=dword:0000000a
[CONTAINER\nbkms]
"ADMIN_REQUIRED"=dword:00000001
"ORB_THREADS"=dword:0000000a
[CONTAINER\nbevtmgr]
"ADMIN_REQUIRED"=dword:00000001
"ORB_THREADS"=dword:0000000a
"SOURCE_THREADS"=dword:00000005
"DISPATCHING_THREADS"=dword:00000005
[CONTAINER\nbstserv]
"ADMIN_REQUIRED"=dword:00000001
"ORB_THREADS"=dword:0000000a

Output of  server.conf

 -n NB_his1
   -x tcpip(LocalOnly=YES;ServerPort=13785)  -gp 4096 -gd DBA -gk DBA -gl DBA -ti 0 -c 25M -ch 500M -cl 25M -zl -os 1M  -o /usr/openv/db//log/server.log
 -ud

Output of databases.conf

"/usr/openv/db/data/NBDB.db" -n NBDB
"/usr/openv/db/data/BMRDB.db" -n BMRDB

 

Kindly advice, how to solve the above mentioned error.

Thank You

Girish
 

Commentaires CommentairesAccéder au dernier commentaire

l'image des revarooo

Are you running this as root, you should not be getting permission denied

. /usr/openv/db/vxdbms_env.sh

Make sure that runs correctly before continuing with the rest.

l'image des girish_nair1984

Hi

. /usr/openv/db/vxdbms_env.sh  issue is sorted out, but after running this command

/usr/openv/db/bin/dbeng11 -f NBDB

following error is occuring

/usr/openv/db/bin/dbeng11 : error while loading shared libraries :libdbservll_r.so: cannot open shared object file : No such file or directory

Thank You

l'image des girish_nair1984

Now Database[NBDB] is alive,

but after running this command

/usr/openv/db/bin/nbdb_admin -auto_start BMRDB

usr/openv/db/bin/nbdbms_start_server

Start ASA Server failed! error code :1

/usr/openv/db//bin/dbspawn -f "usr/openv/db//bin

/NB_dbsrv"@" /usr/openv/var/global/server.conf"@"

/usr/openv/var/global/databases.conf"

DBSPAWN ERROR :-935

Unable to start specified database ::Log file error

SQL Anywhere Start Server in Background Utility Version 11.0.1.2250

It works fine, when I don't add BMR database.

Kindly advice.

l'image des revarooo

Raise a support call.

l'image des mph999

If I understand, it works when you do not specify BMR.
If you are not using BMR then you should not specify it, just miss out any lines mentioning BMR in the procedure you have, then as you mention, it works.
If this is the case (you are not using BMR) then I don't think you have an issue - as the issue is casued by trying to run a BMR line when BMR is not used.

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
l'image des Guduru

do you have the free space in the file system where the netbackup installed?