Video Screencast Help

BEremote.exe service crashes right after it is started. Faulting module name: KERNELBASE.dll in Backup Exec 2012

Created: 29 Jun 2012 • Updated: 05 Jul 2012 | 2 comments
Justin2.0's picture
2
Votes
Login to vote
Me Too!I have the same issue
Product(s): Backup Exec - 2012, Backup Exec
Severity: Non-data threatening / major functionality
Status: Investigating/gathering information
Tech Note: More Information

On a remote server that has the Backup Exec remote agent installed the BEremote.exe service crashes faulting module name: KERNELBASE.dll
VSS errors will also be seen in the application event logs.

Application event logs:

Event ID 12290 before beremote.exe crashes:

Log Name:      Application
Source:        VSS
Date:          6/26/2012 9:54:03 AM
Event ID:      12290
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Remote_server.Domain.com
Description:
Volume Shadow Copy Service warning: GetDiskFreeSpaceEx() for \\?\Volume{237c2165-8b55-11e1-83d9-005056b649a2}\ failed with 0x00000005.  hr = 0x00000000, The operation completed successfully.

 

Log Name:      Application
Source:        Application Error
Date:          6/25/2012 9:56:57 AM
Event ID:      1000
Task Category: Application Crashing Events
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Remote_server.Domain.com
Description:
Faulting application name: beremote.exe, version: 14.0.1798.0, time stamp: 0x4f1e02d7
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e21213c
Exception code: 0xe06d7363
Fault offset: 0x000000000000cacd
Faulting process id: 0x8d0
Faulting application start time: 0x01cd52da5d9447c7
Faulting application path: C:\Program Files\Symantec\Backup Exec\RAWS\beremote.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned in this article. Symantec Corporation is committed to product quality and satisfied customers.

This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns.  For information on how to contact Symantec Sales, please see http://www.symantec.com Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

NOTE:
Customers experiencing this issue are encouraged to contact Symantec Technical Support as data is still being collected to assist in resolving this issue.

 

Workaround:
1. Login as a local administrator to the server with the service crash and VSS errors.
2. Goto the Shadow copy tab for each volume.
3. Set the reserve space to minimum. (320mb)
4. Create a few shadow copies manually.(This should force the old snapshots to be deleted)
6. Then Delete the snapshots that were just created.
7. Start the BEremote service.

Comments 2 CommentsJump to latest comment

MattRCD's picture

Justin, Thank you so much for this post. I was going crazy, everything I read and phone support said to upgrade to the latest service pack. I am old school and updating to the latest service pack I felt wasn't the answer as that could introduce more issues. I like to find out what happened first.

I ran your procedure above but 320mb wasn't enough for the snapshots. Mine were over 3gb and deleting these shapshots I just created didn't do the trick.

I had to increase to NOLIMIT, run the snapshots, then decrease the size again to 300mb to force it to delete the new ones. Once I got these shadow copies down to 0mb size, I was able to start the remote agent and it was then stable. I left the size of these shadow copies to NOLIMIT till I get through a night of backups. I will then decrease the size if everything is back to normal tomorrow.

 

Thanks Again!!!! This saved my butt!

Matt

0
Login to vote
daniel086's picture

I have same issue but without the VSS errors. There are no other errors on my log files.

I tried the work around and the agent started succesfully without stopping. I configured a small one time backup job and ran it twice. The backup did not fail. I reconfigrued back my backups and they should be running at night. I will keep testing and will wait until Symantec gets back at us.

-4
Login to vote