ビデオヘルプ

Installing client 7.5 error unpacking java

作成: 26 Nov 2012 • 更新: 06 Dec 2012 | コメント数: 10
Andre_Torres の写真
この問題は解決されました。 ソリューションを参照してください。

Hi Folks,

I'm trying to install a client 7.5 on a SuSe 2.6, I've already installed other clients with the same installer files, but, in this particular server, it gives error unpacking Java:

Unpacking SYMCnbclt package.
Checking for pre-existing SYMCnbclt package.

Removing pre-existing SYMCnbclt package.

Installing SYMCnbclt package.

Installation of SYMCnbclt was successful.

More details regarding SYMCnbclt can be found in file

/tmp/install_cltpkg_trace.10932 on <client name>.



Terminating NetBackup and/or Media Manager processes.



Installing NB-Java.



gzip: /usr/openv/java/NB-Java.tar.gz: not in gzip format

/bin/tar: This does not look like a tar archive

/bin/tar: Exiting with failure status due to previous errors



gzip: /usr/openv/java/NB-Java.tar.gz: not in gzip format

/bin/tar: This does not look like a tar archive

/bin/tar: Exiting with failure status due to previous errors



tar failed unpacking /usr/openv/java/NB-Java.tar.gz on <client name>.

Cannot complete the install.

Aborting...

Failure extracting java files.



A failure was detected

running /netbackup/NetBackup_7.5_CLIENTS/NBClients/anb/Clients/usr/openv/netbackup/client/Linux/SuSE2.6.16/cp_to_client

 <Master Server Name> <client name> /tmp/install_trace.10679





File /usr/openv/tmp/install_trace.10679 contains a trace of this install.

That file can be deleted after you are sure the install was successful.

コメント コメント数: 10最新のコメントを表示

Andre_Torres の写真

In this thread it looks for a NB-Java.Z, and in my case, it's not a wrong name, it looks for the right file.

Curiously I've tried to install a 7.1 version, only for it keeps backuping last night until I solve the problem, and it gives the exactly same error.

revarooo の写真

run this command: file /usr/openv/java/NB-Java.tar.gz

what is the output?

Andre_Torres の写真

/usr/openv/java/NB-Java.tar.gz: empty

but, if I'm trying to install, should the problem be in the installation? Not in /usr/openv ?

revarooo の写真

Look at the error:

gzip: /usr/openv/java/NB-Java.tar.gz: not in gzip format

/bin/tar: This does not look like a tar archive

/bin/tar: Exiting with failure status due to previous errors

So are you saying this file is empty? ls -l gzip: /usr/openv/java/NB-Java.tar.gz

Do you have space in /usr/openv? 

Andre_Torres の写真

space is no problem, 16GB available.

Andre_Torres の写真

editting the script, putting to ignore the Java file, and copying the folder, made the install work. But now I need to update to 7.5.0.4 and the error keeps going, and edit 7.5.0.4 script shows to be more difficult than 7.5.

Anyone can help what I can do?

RamNagalla の写真

/usr/openv/java/NB-Java.tar.gz: empty

what is the size of the /usr/openv/java/NB-Java.tar.gz file. 

did you compare the file size with the other client file that run successfully?

are you sure this file is not good ?

please try to have the new files copied and try installing it... 

Andre_Torres の写真

Tried to copy the files a lot of times.

So, Ive figured a workaround. Picked the openv folder from another Server, one that is working, and copied via SCP. It worked ok.

ソリューション