ビデオヘルプ

Problem installing OWA for Exchange 2010 SP2 CAS Server

作成: 14 Feb 2013 • 更新: 01 Mar 2013 | コメント数: 7
この問題は解決されました。 ソリューションを参照してください。

Hi,

We trying to install EV 10.0.1 OWA on to Exchange 2010 SP2 CAS Server. But getting the following error

 

 

However Exchange 2010 SP2 is installed on that CAS server Version 14.2 Build 247.5

CAS Server doesn't have internet connection. Do we need to manually install verisign certificate as well?

Many Thanks.

タグでディスカッションを検索:

コメント コメント数: 最新のコメントを表示

Rob.Wilcox の写真

I would suggest running regmon and seeing which registry key the installer is checking to discover the version of Exchange installed.

You can install it without any problem on a CAS that doesn't have internet connection - I've done that many times.

From the message you're getting a suggest things like:

* Registry key for Exchange version not present

* Permissions not allowing the installer to check the registry key

ia01 の写真

Thanks Rob,

These are the two Registry Localtion that OWA Extension MSI Checks for Exchange / CAS Version

 

HKLM\SOFTWARE\Microsoft\ExchangeServer\v14\Setup
HKLM\SOFTWARE\Microsoft\ExchangeServer\v14\ClientAccessRole
 
ia01 の写真

Can confirm this on Monday, did that on a test system where These Keys either doesn't exist or Access modified or Versions modified then we get exactly the same error. Can only test this on Prodution system on Monday.

Rob.Wilcox の写真

Okay.

So IMHO it's this particular key the setup is looking for:

HKLM\SOFTWARE\Microsoft\ExchangeServer\v14\ClientAccessRole

 

In there on my server is the version number.  Version can be looked up on:

http://technet.microsoft.com/en-us/library/hh135098(v=exchg.141).aspx

ソリューション