ビデオヘルプ

Virtualize Fonts installation

作成: 25 Jan 2012 • 更新: 06 Mar 2012 | コメント数: 3
gsalerno の写真
この問題は解決されました。 ソリューションを参照してください。

hi all,

I'm back again for a font problem.

I've done a xpf package with fonts when I use it with SWV administration tool it work fine.

But when I stream it on my domain who is a lot restricted the changes appears after a logoff/logon.

Does someone have any idea why does it work like this?

P.S. this is on a win7 x64 environement

コメント コメント数: 3最新のコメントを表示

ryanmc の写真

When streamed the layer is activated in the system context, so the fonts are not registered for the current user.  In Windows 7 this means that the font won't be visible to the user until they log out and log back in.  A workaround would be to deactivate and activate the layer as the user using SVSAdmin or SVSCmd.  There is a fix for this issue slated for the next major release.

Often you are better off having the fonts installed on the base rather than attempting to stream them.  When you register a font on the endpoint, the system will read the entire font file causing a large download for the streamed layer.  When you activate a layer every font in the layer gets registered.

gsalerno の写真

Thanks for you reply,

Could you please let me know when the next major release would be able to do it?

Because I'm really waiting for it.

You could just let me know writting on this post.

Salerno Giuseppe
System Engineer
Bechtle Suisse Romande

gsalerno の写真

For anyone who are following this discussion, this will be able on the next release.

Salerno Giuseppe
System Engineer
Bechtle Suisse Romande

ソリューション