Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Archiving and eDiscovery Community Blog
Showing posts in English
EC at TW | 27 Nov 2014 | 0 comments

A very specific issue but sharing in case it ever helps someone out.

Following on from my forum query

I was testing an EV9 to EV10 upgrade and roll back, everything went OK apart from the web-sites (no search or archiveexplorer). After some investigation I realised I did not have the EnterpriseVault virtual directory. Lots of re-installs of EV9, uninstall/reinstalls of EV9, removal of IIS etc.. all without success.

JesusWept3 passed across the below helpful tip:

Cd to your EV directory and type
cscript webapp.vbs

Looked very promising but kept throwing a "Failed to create Virtual Directory" error. Going through the VBS and realising where it was failing I manually created the IIS virtual directory in IIS Manager and re-ran the VBS, much more promising and he script created the Directory and AppPool.

Rob.Wilcox | 23 Nov 2014 | 0 comments

Perhaps a lesser known feature of Enterprise Vault is an option that can be added to the WEBAPP.INI file to allow users to do 'basket restores' to a PST file. If you've never tried it then it is something that can be given a quick run through in a lab.

There is, however, a little gotcha that I came across the other day.

The issue is that the items when they land in the PST file appear as unread, losing the status of how they were when they were archived. This appears to affect EV 10 and EV 11. It might not be something that is a problem for many of users, after all you might not have this feature enabled.  But if you do, then well, there is a technote about the issue now (interesting spellings in...

Rob.Wilcox | 15 Nov 2014 | 0 comments

One of the questions which is frequently asked on the forums after a new Exchange Server update is whether or not Enterprise Vault will work with it, and whether it will be supported. For the most part in the past, roll-ups or cumulative updates weren't specifically tested and called out individually. Customers could contact Support, and if an issue was found, it would be worked on and (hopefully) fixed.

Microsoft, in their wisdom, changed things a bit with Exchange 2013. The Cumulative Updates there are more like service packs than every before. Take a look at the table below for an example of what I mean:

Exchange 2010:

Screenshot 2014-11-15 11.37.07.png

With Exchange 2010 come service packs, and then update rollups after that.. then another service pack, and more update rollups.

Exchange 2013:


Rob.Wilcox | 09 Nov 2014 | 0 comments

Many times when I've used Outlook I have used the follow-up flag to remind me about the item that I'm looking at.  Sometimes I use it just so that I can see it in a pile of things within my mailbox, other times I use the Outlook search folder and look at the things that I've marked for follow-up and then I process them.

But what happens when the item gets archived?

Well, the best way to consider this situation is that archiving effectively creates a freeze-frame of the item.  If the item was archived with a flag set then the archived item will always have a flag set. If the item was archived without the flag set, then yes, it can be set later, but if you restore the original item, it won't have a flag.

It's fairly logical, but it does sometimes lead to confusion when a user clears the flag on an archived item, then at some point later then double click on the archived mail to view, and they see the reminder again (even though they've cleared it)

EC at TW | 04 Nov 2014 | 1 comment

Just a write-up of my EV9 Indexing Service move to a new dedicated Indexing server.

My situation was Server1 was getting overwhelmed with both Storage and Indexing Services running. The Indexes folder was getting large (1.2 TB) too. (Separating the Services will help with our EV10 upgrade as we are hardware constrained.)

Proposed solution was to build a new dedicated Indexing server, Server2. Create new Open Indexes on Server2, Closing Indexes on Server1, then move all of the existing Server1 Indexes to Server2.

All EV9.0.5 on VM servers with virtual RDM storage.

  • Server 2 was built and joined to the existing Site, following Virtual RDM added for new Indexes as F:.
  • Added the “Enterprise Vault Indexing Service” to Server 2 from the VAC, Servers, Server Name, right-click Services and open the Properties.
  • Created new Open Indexes on...
Rob.Wilcox | 27 Oct 2014 | 0 comments

Did you know that there are two types of Vault Cache 'Reset'?  As a reminder you can access these from the Enterprise Vault Outlook Add-in Diagnostics window (Control + Shift + click on an EV button in Outlook):


As you can see there are two types of reset:

Partial Reset -> Resets only the header. The next synchronisation will be a full header synch.

Reset -> Resets the header and the content. The next synchronisation will be both header and content; just like when a user was first configured to use Vault Cache.

Hope that helps!

Rob.Wilcox | 22 Oct 2014 | 0 comments

The other day I had a need to find out how many archived items were in a particular archive. Normally I'd leap straight over to the Vault Store Usage Report, but for some reason (maybe the number of archives) that just seemed to take 5+ minutes to display. Needless to say, I gave up on the report, for now.

But I still needed to know how many items were in the archive I was interested in.

I used this query in the end:

SELECT A.ArchiveName, AP.ArchivedItems, AP.ArchivedItemsSize

FROM EnterpriseVaultDirectory.dbo.Archive A, EnterpriseVaultDirectory.dbo.Root R, VSDB.dbo.ArchivePoint AP

WHERE AP.ArchivePointId = R.VaultEntryId AND R.RootIdentity = A.RootIdentity

AND A.ArchiveName = 'User'

All you have to do is change the VSDB to the name of the Vault Store database you're interested in (or, remove it and the .dbo. and launch the query from the Vault Store database), and on the last line put in the User you're interested in.

Problem solved, and...

Rob.Wilcox | 07 Oct 2014 | 2 comments

Over the last few years there has been a steady increase in the amount of 'stuff' you can do with Enterprise Vault from the command line. Specifically from Powershell.

Just published is this excellent guide from Symantec with all of the Powershell information referenced. Take a look, it's pretty good.

Rob.Wilcox | 03 Oct 2014 | 0 comments

Hot off the presses is Enterprise Vault 11 Cumulative Hotfix 2. Weighing at 185 Mb for the download it consists of a series of changes that have been made to Enterprise Vault 11 following from it's original release.

As with the first cumulative update it's essential to read through both the read me document, and, the installation instructions.  If you don't then, like me, you might forget to run the database upgrade script that is required after the installation.

Have you installed the update yet?

Rob.Wilcox | 28 Sep 2014 | 1 comment

Many people realise after using Enterprise Vault for some time that there are an awful lot of relatively small files on the Vault Store partition disks. These sort of things often cause problems for traditional backup software.  So what can you do?

One option is to add the files to CAB files, a process in Enterprise Vault known as 'Collection'.  The CAB files use the regular Microsoft CAB format, the files added to them are already compressed and so are not compressed again.

Using CAB files like this, particularly on 'old' data, can definitely help with things like backups. I've written about that before. There is a neat clean up process, which has been written about too.

One of the problems I happened to see...