Video Screencast Help
Endpoint Management Community Blog
Showing posts tagged with Workflow Solution
Showing posts in English
BRING | 04 Feb 2010 | 0 comments

While running applications from our workflow server, the end users were reporting that emails were not being sent as designed.  We furhter  noticed the following error messages:

EventType clr20r3, P1 w3wp.exe, P2 6.0.3790.3959, P3 45d6968e, P4 mscorlib, P5 2.0.0.0, P6 4a7cd8f7, P7 11eb, P8 18, P9 system.outofmemoryexception, P10 NIL.

An unhandled exception occurred and the process was terminated.
Application ID: /LM/W3SVC/1/Root/HardwareEquipmentRequestV4
Process ID: 1052
Exception: System.OutOfMemoryException
Message: Exception of type 'System.OutOfMemoryException' was thrown.
StackTrace:    at System.Threading.ExecutionContext.CreateCopy()
   at System.Threading._TimerCallback.PerformTimerCallback(Object state

We further noticed additional error messages from the specific project logs:

System.Data.SqlClient.SqlException: Could not allocate space for object 'dbo....

WEVO Group Developers | 03 Feb 2010 | 0 comments

Now with Workflow 7's ticketing and reporting functionality you can add status and reporting to your processes quickly and easily.

I recently had to build a "Proof of Concept" (POC) for a client proposal that we are working on. The client wanted to generate reports using Workflow to track a process for auditing purposes.

Now as many of you know, in past versions of Workflow we would've had to create a report like this in a couple of different ways: we could have developed a Web Forms Reporting Dashboard or a SQL Reporting Services report. Both of these options would have required some significant development time and additional cost to the project.

Ticketing Functionality

Some of the new ticketing functionality that was created for ServiceDesk 7 in Workflow allows us to develop these reports quickly and easily.

I think it is important to note the ticketing functionality wasn’t developed...

Don Rowland | 20 Jan 2010 | 4 comments

I am trying to solidify a group of 10 who can commit to a 2 day training class on Workflow 7.  It will be a complete hands on class covering topics from install to complex design.

We have a commitment from the Symantec Workflow trainer that if we can get at least 10 people to commit, they will bring the class to us.

Each student would need to bring a laptop with at least 3GB of memory and enough space to store the virtual machine for the class material.

I'd like to have this class in February.  Please post and/or e-mail me if you are interested and can commit to attending. 

BRING | 16 Dec 2009 | 1 comment

After successfully installing ServiceDesk 7.0, and passing thru the evaluation time frame, or after applying a production-type license, the following error has been observed.

Error 1:

"License does not allow use of web part [SearchTextPortalWebPart] 

What are some suggested ideas to troubleshoot  this problem, since it makes using ServiceDesk impossible?

1. On the ServiceDesk Server, open up the Notification Server Credentials tool on the ServiceDesk server, and verify that the connectivity test for the Notification Server is successful.
       a.  If not, add the correct credentials and retry.  Suggested credential to use the the Altiris Application Identity (APPID) account.  This account should be a member of the local administrators group on the Symantec Management Platform Server (NS).
2. On the Servicedesk Server, open up the...

BRING | 14 Oct 2009 | 0 comments

While running a Workflow application recently developed, a problem manifested itself in a couple of different ways. There was first an error:

"Server was unable to process request.--->Object Reference not set to an instance of an Object"

Also, no matter how I varied the input information into the application, the result set always matched the result set that I had obtained the first time I ran the program.  It would change if I closed and restarted the Workflow session, or republished the application to the server, and ran it again.  But once running, it did not matter how many different iterations of input data I provided, the result set was the same, and that was frustrating.

Upon further review of my project, and specifically a linked workflow model inside of my project, it was discovered that there were two potential culprits for this behavior.

The first culprit was found within the properties of...

AndyN | 14 Oct 2009 | 2 comments

The Super User Group in Cleveland on October 2, 2009 was a SUPER success!

We had approximately 100 customers in attendance from at least 5 User Groups: Cleveland, Columbus, Michigan, Pittsburgh, and Rochester. Surprisingly, there wasn't anyone there from Hawaii or Australia. Maybe next time.

Slides from the following Product Managers are attached to this blog:

  • Michael Grueber and Rene Kolga: Client Management Suite and Server Management Suite SP1
  • Hugo Parra: Deployment Solution
  • Jeremy Carter: Workflow
  • Vinny Buscarnera: ServiceDesk

If you attended the Super User Group, please...

BRING | 12 Oct 2009 | 0 comments

When attempting to open a workflow .package file from an external source, (which is the best way to transfer Workflow projects), the following Unexpected Exception, Size Mismatch error occurred, as shown in the screen shot. This error caused frustration, as no matter what I tried to get the .package file to open, it would not. Why? 

sisemismatch.jpg

Well, lets first understand that the .package file is essentially just a zip file, and the file can be renamed to have a .zip extension and then extracted using standard ZIP utilities. Most of the time that will work.   In this case however,  the .package file was more than likely scanned with a virus scanner during transfer, and certain files contained in the package file probably were flagged by the virus scanner, and were removed from the .package file.  When the check sum process of...

BRING | 09 Oct 2009 | 0 comments

While workig within a multipath dialogue workflow component, the embedded decision model begins its evaluation and process of data, but for some reason does not complete successfully and return program control back to the source dialogue component.  This can really wreak havoc when troubleshooting, as no model validation errors are present.  You are just left wondering why it won't finish.

Found wthin the emebedded decision model for the process, specifically in the options of the END component, under the Data Handling tab, there are specific data definitions that can be required to pass thru the process (embedded model) and be returned to the original workflow, or made optional.  You should know the schema of the data you are trying to import when you declare your variables, or data types.  This will allow you to control what you need, since, when using queried data  from SQL or...

BRING | 09 Oct 2009 | 3 comments

Of the occasional Servicedesk installation issues, this one can be frustrating.  You will proceed through the first phase of the process, and while watching the details of the install, observe the following error:

An error has occurred at: GetAllPermissions
Error Message: Empty SessionID.

Stack Trace: System.Web.Services.Protocols.SoapException: Empty SessionID. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at LogicBase.Core.Ensemble.UserMan.Userman.GetAllPermissions(String sessionID) at Ensemble.Userman.GetAllPermissions.Run(IData modelData) at LogicBase.Core.ExecutionEngine.SinglePathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine,...

BRING | 09 Oct 2009 | 0 comments

In familiarizing myself with Workflow and its features, I began by building a simple webforms project in Workflow 6.5, and testing the project in debug mode, it worked fine.  However, wanting to try out all of the fun new features, and to make this test application  accessible by others, It was published to the server.  After publishing it, and attempting to use the URL of the published package, the page that should have appeared was not to be found.  THe browser attempted to load the page, but it simply came up blank.  Arrgghh!.

After some troubleshooting and a support call, it was discovered that the web root folders (and sub-folders) of the Workflow program installation folder did not have proper NTFS permissions granted.  It is possible that the installation of workflow was performed with an account that had less than local admin privileges.

In this case, the permissions were changed at the root of the...