Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Endpoint Management Community Blog
Showing posts tagged with Workflow Solution
Showing posts in English
AndyN | 14 Oct 2009 | 2 comments

The Super User Group in Cleveland on October 2, 2009 was a SUPER success!

We had approximately 100 customers in attendance from at least 5 User Groups: Cleveland, Columbus, Michigan, Pittsburgh, and Rochester. Surprisingly, there wasn't anyone there from Hawaii or Australia. Maybe next time.

Slides from the following Product Managers are attached to this blog:

  • Michael Grueber and Rene Kolga: Client Management Suite and Server Management Suite SP1
  • Hugo Parra: Deployment Solution
  • Jeremy Carter: Workflow
  • Vinny Buscarnera: ServiceDesk

If you attended the Super User Group, please...

BRING | 12 Oct 2009 | 0 comments

When attempting to open a workflow .package file from an external source, (which is the best way to transfer Workflow projects), the following Unexpected Exception, Size Mismatch error occurred, as shown in the screen shot. This error caused frustration, as no matter what I tried to get the .package file to open, it would not. Why? 

sisemismatch.jpg

Well, lets first understand that the .package file is essentially just a zip file, and the file can be renamed to have a .zip extension and then extracted using standard ZIP utilities. Most of the time that will work.   In this case however,  the .package file was more than likely scanned with a virus scanner during transfer, and certain files contained in the package file probably were flagged by the virus scanner, and were removed from the .package file.  When the check sum process of...

BRING | 09 Oct 2009 | 0 comments

While workig within a multipath dialogue workflow component, the embedded decision model begins its evaluation and process of data, but for some reason does not complete successfully and return program control back to the source dialogue component.  This can really wreak havoc when troubleshooting, as no model validation errors are present.  You are just left wondering why it won't finish.

Found wthin the emebedded decision model for the process, specifically in the options of the END component, under the Data Handling tab, there are specific data definitions that can be required to pass thru the process (embedded model) and be returned to the original workflow, or made optional.  You should know the schema of the data you are trying to import when you declare your variables, or data types.  This will allow you to control what you need, since, when using queried data  from SQL or...

BRING | 09 Oct 2009 | 3 comments

Of the occasional Servicedesk installation issues, this one can be frustrating.  You will proceed through the first phase of the process, and while watching the details of the install, observe the following error:

An error has occurred at: GetAllPermissions
Error Message: Empty SessionID.

Stack Trace: System.Web.Services.Protocols.SoapException: Empty SessionID. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at LogicBase.Core.Ensemble.UserMan.Userman.GetAllPermissions(String sessionID) at Ensemble.Userman.GetAllPermissions.Run(IData modelData) at LogicBase.Core.ExecutionEngine.SinglePathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine,...

BRING | 09 Oct 2009 | 0 comments

In familiarizing myself with Workflow and its features, I began by building a simple webforms project in Workflow 6.5, and testing the project in debug mode, it worked fine.  However, wanting to try out all of the fun new features, and to make this test application  accessible by others, It was published to the server.  After publishing it, and attempting to use the URL of the published package, the page that should have appeared was not to be found.  THe browser attempted to load the page, but it simply came up blank.  Arrgghh!.

After some troubleshooting and a support call, it was discovered that the web root folders (and sub-folders) of the Workflow program installation folder did not have proper NTFS permissions granted.  It is possible that the installation of workflow was performed with an account that had less than local admin privileges.

In this case, the permissions were changed at the root of the...

jjesse | 18 Aug 2009 | 0 comments

I don't know if anyone else has posted this here but one of things our clients are asking about, especially as their AUP's come up for renewal, is "I've heard Workflow Licensing has changed now what do I need to renew????"

Hopefully I can try and explain this a bit here.  We had some Symantec people in town meeting with customers and received the following answer

In Notification Server 6.X world there were several ways one could purchase a license for workflow

  • Workflow Soluton (license for the server)
  • Workflow Designer (program to modify and customize workflows) -- Licensed per user
  • Workflow Process Manager -- Licensed per user
  • Workflow Advanced (included portal, repository and a couple of other extras

Now in the Workflow 7 World (yes Workflow 7 connects to a Notification Server 6 world, but you do need a NS7 box for licensing, could be same box)
Within the Symantec...

BRING | 06 Aug 2009 | 0 comments

Most of the time, after installing and properly configuring Workflow, the ability to publish developed applications is intact and works well.  Recently, while attempting to publish a workflow project to the webserver, the publishing process appears to complete correctly, and the files were copied to the correct location.  But when opening the browser and attempting to run the application, it would not run.  And further research proved that the workflow virtual directories were not appearing in IIS.  

After some troubleshooting efforts, it was determined that the Web Site ID was not set correctly in WorkFlow.  This probably occurred as a result of the default web-site being removed.  To fix this, the Web Site ID must be configured in Workflow to match the Workflow Web Site ID in IIS, and the steps to resolve this are outlined below:

1.  Determine what the Web Site ID in IIS is, on the workflow server...

Spencer Parkinson | 05 Aug 2009 | 4 comments
Every job has repetition. This may start out as a minor annoyance, but it can quickly grow into a huge frustration. It reminds me of the movie Groundhog Day when the main character, Phil, finally snaps and kidnaps the groundhog to try to get the day to stop repeating.
 
However, there is a better way to handle this than what he did (i.e. drive off a cliff in a pickup truck). This morning, Symantec announced Workflow 7.0 and ServiceDesk 7.0, and both of these products have one underlying theme - they help businesses maximize efficiencies and minimize costs by automating repetitive tasks. This frees IT and other employees from monotony and allows them to spend their time in other areas, increasing their productivity.
  
Workflow 7.0 focuses on automation for businesses as a...
ChrisBern | 28 Apr 2009 | 2 comments

Recently, a website has been launched with the goal of making Workflow Solution resources easier to find. It is not a replacement for any existing sites, but rather an aggregator of available resources in an organized way that will help both new and existing users of Workflow Solution. The site won't host content, but will link to content that is on Symantec Connect, the official Symantec website, the Altiris KnowledgeBase, forums, etc.

Please review the site and let us know what you think, either by responding to this blog, or on the Submit Feedback tab on the site itself. The more feedback we get on ways to improve or organize the site, the better we can make it. Here is the URL:  www.workflowswat.com