Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Endpoint Management Community Blog
Showing posts tagged with Tip/How to
Showing posts in English
ziggy | 24 Mar 2009 | 0 comments

While tirelessly looking for a method to automatically uninstall Workflow Designer instances found on clients machines, I  stumbled upon this little gem:
 
C:\Program Files\Altiris\Workflow Designer\Uninstall.exe
 
Just add an /S at the end for a silent uninstall
 
I have it setup in a software delivery job to run on a collection that is built using 'All computers' - 'Authorized Designers'.  The latter is a manually updated collection for now since it a small and static (for the most part).  I could also wait for the Operating System Inventory to populate (tablename: Inv_AeX_OS_Add_Remove_Programs), since that contains the contents of Add/Remove Programs and just build a sql query based collection for that.  Which I will probably do in the near future.
 
Hope this article was helpful.  Short, sweet and to the point.
 
Thank you.

BRING | 20 Mar 2009 | 0 comments

Recently, it was discovered on a large number of server class machines that the Altiris Agent was displaying the following error:

HTTP Request Failed: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full. (-2147014841).

Sufficient buffer space?  Well, after checking the memory statistics on a client machine exhibiting the behavior, the handle counts for the Altiris Agent Service were very high, in some cases exceeding 10k or more.  However, the counts were ascending and descending as expected, just at a very high level. 

After some research, this error is a common error and warning occurs when the Altiris Agent cannot contact a domain controller/DNS server to resolve the name of the Notification Server.  This has been shown in some cases to point to a inconsistently behaving or non-functional domain controller/DNS server. The high ...

rbrucelee1978 | 19 Mar 2009 | 0 comments

I have noticed that most of the links to sites "designed to help beginners" generally talk about how to create msi's, how to modify these packages or even how to fix some ICE errors. However, these sites do not give beginners any information on very important basic concepts such as Self Healing, Installation Sequences, how to read the logs generated on installation of the msi. These "basic" concepts can help beginners understand things like how these ICE errors occur or say in the even of a failed msi installation where to look in the package based on the information given by the verbose log file.

This site (written by John McFadyen) will provide detailed information on these concepts Windows Installer Blog.

Happy reading!! :-)

Randall Newnham | 19 Mar 2009 | 2 comments

This error can occur when you are trying to automate a Ghostcast session with the -sure switch. What is going on is that the the disk is not specified. In a non-automated Ghostcast session, the user specifies the source (for image cration) or destination (for image restore). When adding the -sure switch, the -clone switch either needs to be included in the boot media, or the disk number needs to be specified in the Ghostcast Server session in the "Client command line options" area. this particularly useful in a PXE deployment environment when the switches -ja=<sessionname> -sure are typically added.

Randall Newnham | 19 Mar 2009 | 0 comments

Due to limited memory, installing a Ghost client on these devices will fail. 1-click virtual partition boot media tends to fail, as well. Here is a method to backup and restore to an iGel Thin Client:

1. Create a Standard Ghost Boot Package using PC-DOS on a USB flash drive.

2. Boot to that device; the boot order will need to be changed to allow booting to that device.

3. Choose Local > Disk > To Image to backup, or choose Local > Disk > From Image to restore.

Note: The USB flash drive used will need to be large enough to accomodate the Ghost boot package and the image.

 

riva11 | 17 Mar 2009 | 1 comment

Maybe in the last year, for different reasons you decided to stop in your organization the deployment of Service Pack updates through Windows Update.
An official Microsoft tool for this task is the Windows Service Pack Blocker Tool Kit,  or a different way is described in my previous post  Block Installation of Windows XP SP3 and Vista SP1.

The Windows Service Pack Blocker Tool Kit allows to temporarly disable this automatic update, but remember only for a limited time.

Now the time could be expires soon, in fact in the Microsoft note release there is the Service Pack update list disabled and the date:

- Windows XP Service Pack 3 (valid until May 19th, 2009)
- Windows Vista...

jjesse | 13 Mar 2009 | 1 comment

Channel Insider has posted several articles in regards to items coming out of Manage Fusion 09 in Vegas last week.  This article talkes about utilizing Symantec's Workflow product.

Symantec is betting huge on the integration between workflow and other products.  The CEO of Symantec stated in the article: “It’s all about integration,” says Enrique Salem, Symantec’s chief operating officer and future CEO, who mentioned the game-changing potential of workflow technology in the opening of his keynote address at Managed Fusion."

The Workflow Solution is indeed a game changing product for Symantec because it can integrate into other products than those made by Symantec.  Need to integrate with Sharepoint, Active Directory, Exchange or other...

DParent | 11 Mar 2009 | 3 comments

I updated my golden image with XP sp3 and all the windows updates. Created a new sysprep.inf file. Ran sysprep on the master computer. Shut it down and captured the image.

When I deploy the HII image to the test computers, sysprep starts to run then give me the error "autochk program not found -skipping..." then goes into a continuous loop rebooting.

I tried rebuilding the image from scratch, using the sysprep from sp2 that works good on my current image. Any ideas or advice would be appreciated.

adtlink | 10 Mar 2009 | 0 comments

As always, the keynote kicked off with a joke or two from Steve Morton.  We love Steve here at Symantec, and are always ready to enjoy his jokes.  Now to the elephant in the room not named Steve Morton. 

ALTIRIS 7 launches!!!

As beta program manager for the Endpoint Management group, I am happy to say that Altiris 7 has shipped.  And more importantly - it is ready to be shipped.  As you heard in the announcement today from Enrique Salem our next CEO, we have worked long and hard to ensure a successful release.  Today is the culmination of all our efforts, from development, QA, partners, and our customers we all combined to help launch Altiris 7. 

Who was that, Joaquin Phoenix? 

Yeah, that was me.  I think I threw Morton off-script.  Not sure if it was the hair, or the beard, but I am proud to say that I left Steve Morton speechless (rare occurrence) and in fits of laughter during a MF keynote....

Antonp | 05 Mar 2009 | 0 comments

Important:

Never ever delete the Altiris database before doing a repair on the Notification server. The server hangs and never actually repairs the system but corrupts something, so it is not advised. Had to reload the entire Windows 2003 server as a result of registry being full of old Notification server entries not deleted.