Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.
Endpoint Management Community Blog
Showing posts in English
ianatkin | 31 Jul 2014 | 0 comments

After upgrading from SMP7.5 to 7.5P1 on our production setup (which has SQL server offbox) one niggle was that IT Analytics stopped working. All console users were presented with this error,

An error has occurred during report processing. (rsProcessingAborted)
Cannot impersonate user for data source 'ITAnalytics'. (rsErrorImpersonatingUser)
Log on failed. Ensure the user name and password are correct. (rsLogonFailed)

After rechecking our settings in the console, we couldn't understand the root cause. Logging in directly to the SQL server and trying to access the reports through the report url, http://localhost/reports, resulted in the same error.

After playing a bit with permissions and getting nowhere, I found this tech article, "TECH213502: Error accessing...

riva11 | 29 Jul 2014 | 0 comments

InstalledDriversList by NirSoft is a portable tool that lists all device drivers that are currently installed on your system.
As shown in the image below, for every device driver is shown : Driver Name, Display Name, Description, Startup Type, Driver type, Driver Group, Filename, File Size, Modified/Created Time of the driver file, and version information of the driver file.


Available 32-bit and 64-bit versions. InstalledDriversList is also available in several other languages
Supported OS: Windows Xp , Windows Vista , Windows 7 , Windows 8 , Windows 8.1 – (x86 and x64 bit)

License: Freeware

Link : InstalledDriversList  

ianatkin | 25 Jul 2014 | 1 comment

Last week saw us having a few festivities to mark the end of a major project here; our XP to Windows 7 migration. We're all pretty chuffed with what we've achieved here; a very smooth user upgrade with remarkably few hitches considering from start to finish the project of migrating nearly 2900 machines took 7 months. 


This really was a remarkable success. The target time to migrate a user's desktop from XP to Windows 7 was set at 1hr, and this average time was to hold no matter what the site link speed was, and despite the fact that machines would be competing with up to 15 machines being deployed concurrenty.

Most of the migrations were also complicated by the fact that they were at user's desks which were distributed across 50 sites. To enable the deskside techs to focus on confirming machine configuration, specialist software requirements, and...

ianatkin | 25 Jul 2014 | 5 comments

When we upgraded our production SMP server from 7.5HF2 to 7.5SP1 we noticed a lot of errors sloshing around our event logs in the days that followed,

  1. Access Denied: No Permission to view task history
  2. Unhandled Exception: An entry with the same key already exists
  3. Unable to create menu item as there due to an XML schema error. An entry with the same key already exists


The first error initially dominated the logs (occuring every few seconds) and then it eased, becoming less frequent (perhaps hourly) and sporadic.

The second and third errors always occured together and only started appearing once the techs started using the console following the upgrade. It turned out that these two errors conincided with a broken resource manager. When console users double-clicked a computer object in the console this...

Kevin Haysmer | 24 Jul 2014 | 0 comments

I started to hunt as many have before for a custom inventory for Altiris 7.1 that would get the Autodesk information like in Altiris 6.5. Every time I thought I had the script working I would find a different product it was not getting the information on correctly. Or in some case it just would not read a registry field like it would all the others. As I started to look I found the reason was not all the registry fields patterns where the same in about 2012 they changed the format of the registry configuration. There are also other products in Autodesk that the path in the registry was different or the field I wanted had a different name from one product to the next. So I started to compile a list of all the software I may need and looked for the registry keys I would need to make a functional custom inventory script for Autodesk. Just so we can all get it out yes I know I could have broken parts of this down into functions and had the script shorter but at the time I was not...

kedar_k | 21 Jul 2014 | 8 comments

ITMS 7.5 SP1 HF1 is available through SIM. It has the fix for the following issue:


You can access the ITMS 7.5 SP1 HF1 release notes from the following location:

Symantec™ IT Management Suite 7.5 SP1 HF1 powered by Altiris™ technology Release Notes


You can access the ITMS 7.5 SP1 HF2 release notes from the following location:

Symantec™ IT Management Suite 7.5 SP1 HF2 powered by Altiris™ technology Release Notes

ryanschoenherr | 09 Jul 2014 | 0 comments

Join our webinar on July 29th @ 11AM EST to learn about our Universal Imaging Solution.

                                            REGISTER HERE NOW!

            Screen Shot 2014-07-09 at 2.53.51 PM.png

Screen Shot 2014-07-09 at 2.48.48 PM.png

ianatkin | 07 Jul 2014 | 2 comments

One of the things about writing DS jobs in a rush is that the end result is often really difficult to repurpose and port to other servers. This is because my DS jobs contain many tasks; so rushing inevitably means that many aspects are hard-coded. 

As a programmer having hardcoded elements distributed throughout a complex job goes against the grain; when programming I try to place all those nice user-editble variables at the start to make it clear that only one area needs attention when changing simple items like file locations.

However this is tricky to do with DS... sharing user variables between the client production, automation and the server is just plain awkward. In the past I've tried various routes to get around this,

  1. Creating on the fly and environment variable batch script (named %ID%_env.bat) on the deployment share. This hosts all the user-editable variables and can be called at the start of each script task to ensure they are...
ianatkin | 07 Jul 2014 | 0 comments

I came across this news last month and was a bit dissapointed. I was aiming to move to Zone just before this accouncement came as I very much liked the idea of holding my own encryption keys. Unlike with some other cloud storage providers, my stuff would remain always remain my stuff in the zone.

If you are a Norton Zone customer, today (7th July) sadly marks the beginning of the end. According to the Zone placeholder page, from today you'll no longer be able to share files or create public links. The end itself comes in one month on the 6th of August at which point Symantec will terminate the service and delete any remaining Zone files.

My heart goes out to all those who shed sweat developing this product.

Full details on

Kind Regards,

ianatkin | 02 Jul 2014 | 15 comments

Just imported some job binary for normally well behaved jobs on a new DS6.9 SP6 server (on Windows 2008 R2 with SQL Server 2012) and started getting this error on tasks running embedded scripts.

Never seen this before which is odd as I've been using these job sets for years (since SP4). It's an access denied problem...  and sometimes it happens... sometimes it doesn't.

Feels like a support ticket is looming... :-(