Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Enterprise Vault Server Settings Migration Wizard

Created: 21 Jul 2011 • Updated: 22 Jul 2011 | 15 comments
Evan Barrett's picture
+6 6 Votes
Login to vote
Symantec single video player.

New with Enterprise Vault 10, the Enterprise Vault Server Settings Migration Wizard is perfect for those administrators looking to migrate their Enterprise Vault 9.0.1 or later servers running a 32-bit Windows to Windows 2008 R2.  This video provides an overview and walk-through on how to use the wizard.

Video Upload: 

Comments 15 CommentsJump to latest comment

Andy Nash's picture

During the video Evan mentions that the drive letters need to stay the same for the import of settings, while this would be our best practice and definitely advisable the wizards will allow you to change the locations if needed.

Regards,
--Andy

0
Login to vote
wg231063's picture

A nice Tool. But when we try to import the migration files on an EV 9.0.2 Server on Windows 2008 R2, source is EV 9.0.2 on WIndows 2003,  we get an error that the password of the VSA is not valid, but it is.

One information. The OS is german on both sides

Walter

0
Login to vote
Ben Shorehill's picture

Excellent walkthrough Evan!

Ben Shorehill

0
Login to vote
ManishN's picture

Hello Wg231063,

I was having a recent case where customer is also having the same issue and what we do is performed the dtrace on the servermigration wizard and found the following trace

69 10:15:11.249  [3528] (ServerMigration) <1860> EV:M [EVSM] VSAAccount.AddVsaAccountToAdminGroup Exception occurred: Der Gruppenname konnte nicht gefunden werden.|
70 10:15:11.249  [3528] (ServerMigration) <1860> EV:H [EVSM] EVServerMigrate.ConfigureVsaAccount throwing Exception: Das System konnte die eingegebene Umgebungsoption nicht finden

It means that the Administrators group were not able to recognize, so we have renamed the default Administratoren group to Administrators and started the migration wizard again and it works.

I hope this will help you.

Regards,

MN

0
Login to vote
Altimate1's picture

I started archiving with EV10 and wonder about upgrading to future versions. I feel now better confident about how this would be possible when next major release will be available.Thanks

Bernard

0
Login to vote
Markus Klußmann's picture

Since the new version release a few days ago (ServerMigration 1.0.0.1227) I receive an error "VSA account not valid" when trying to import settings on a german server. The workaround with renamig "Administratoren" to "Administrators" did not work any longer for me.

DTRACE shows these messages:

189  14:10:19.660 [2.776] (ServerMigration) <2768> EV:M [EVSM] DTraceHelper.LogDTrace CLuster Mode is STANDALONE

190  14:10:19.660 [2.776] (ServerMigration) <2376> EV:L [EVSM] EVServerImport.CheckVSACredentials Check VSA credentials starts...

191  14:10:19.848 [2.776] (ServerMigration) <2376> EV:M [EVSM] VSAAccount.AddVsaAccountToAdminGroupAdministrators group name is VORDEFINIERT\Administrators

192  14:10:19.848 [2.776] (ServerMigration) <2376> EV:H [EVSM] VSAAccount.AddVsaAccountToAdminGroupException occurred: Der Gruppenname konnte nicht gefunden werden.

193  14:10:19.848 [2.776] (ServerMigration) <2376> EV:H [EVSM] EVServerMigrate.ConfigureVsaAccount throwing Exception: Unbekannter Fehler

194  14:10:19.848 [2.776] (ServerMigration) <2376> EV:M [EVSM] VSAAccount.RunningAsVSA current logon user: <DOMAIN\SERVICEACCOUNT>

195  14:10:19.848 [2.776] (ServerMigration) <2376> EV:L [EVSM] EVServerImport.CheckVSACredentials Check VSA credentials failed

196  14:10:19.848 [2.776] (ServerMigration) <2768> EV:M [EVSM] DTraceHelper.LogDTrace CLuster Mode is STANDALONE

With a previous version of ServerMigration (version 1.0.0.1217) the export and import of server settings works fine (after renaming group to "Administrators").

I hope the tech-guys will work on it and fix this issue soon.

0
Login to vote
voytech's picture

I have also an issue with this tool.

Check if Vault Service Account is configured. Failed.

Dtrace shows this:

118    15:15:00.701     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check if Enterprise Vault core services are installed." Started
119    15:15:00.701     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check if Enterprise Vault core services are installed." Completed
120    15:15:00.701     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check Enterprise Vault version." Started
121    15:15:00.716     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoVersionCheck Enterprise Vault Version is 9.0.1.1073
122    15:15:00.716     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoVersionCheck Enterprise Vault Version check passed
123    15:15:00.716     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check Enterprise Vault version." Completed
124    15:15:00.716     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoEVConfiguredCheck Enterprise Vault core services configured
125    15:15:00.716     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check if Vault Service Account is configured" Started
126    15:15:00.826     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoVSAAccountCheck exception:
127    15:15:00.826     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoVSAAccountCheck Cannot get VSA account from EV services
128    15:15:00.826     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] TaskExecution.LogTaskStatus Task "Check if Vault Service Account is configured" Failed
129    15:15:00.826     [2512]    (ServerMigration)    <3704>    EV:L    [EVSM] EVPreReqChecks.DoChecks returning mode NONE

0
Login to vote
andreas krupp's picture

Is there any progress on the Error? Version 1227 and 1235 are both not working. With or without the workaround to change the Groupname from Administratoren to Administrators.

Please Help!

521  11:53:57.800 [2.440] (ServerMigration1227) <300> EV:L [EVSM] EVServerImport.CheckVSACredentials Check VSA credentials starts...
522  11:53:57.925 [2.440] (ServerMigration1227) <300> EV:M [EVSM] VSAAccount.AddVsaAccountToAdminGroup Administrators group name is VORDEFINIERT\Administratoren

523  11:53:57.925 [2.440] (ServerMigration1227) <300> EV:H [EVSM] VSAAccount.AddVsaAccountToAdminGroup Exception occurred: Der Gruppenname konnte nicht gefunden werden.

524  11:53:57.925 [2.440] (ServerMigration1227) <300> EV:H [EVSM] EVServerMigrate.ConfigureVsaAccount throwing Exception: Unbekannter Fehler
525  11:53:57.925 [2.440] (ServerMigration1227) <300> EV:M [EVSM] VSAAccount.RunningAsVSA current logon user: MANUFACTUM\Service_Vault
526  11:53:57.925 [2.440] (ServerMigration1227) <300> EV:L [EVSM] EVServerImport.CheckVSACredentials Check VSA credentials failed
527  11:53:57.972 [2.440] (ServerMigration1227) <2196> EV:M [EVSM] DTraceHelper.LogDTrace CLuster Mode is STANDALONE

0
Login to vote
piyushnasa's picture

Hi,

Very nicely described.

We want to upgrade our Office 2010 to Office 2010 SP1. For that we need to update the EV from 9.2 to 10 on our client machines. do we follow the same procedure or is there something else we need to do.

Do not know much on EV stuff so your help would be appreciated.

Thanks,

Piyush

Piyush Nasa Altiris Certified Professional (ACP)

http://msiworld.blogspot.com/

+1
Login to vote
Rob.Wilcox's picture

For a client, you can either ...

A.. Just install the latest over the top of what is there already
Or

A...uninstall the current version,
B... Restart the machine
C... Install the latest.

It largely depends what they have now.. EV and Outlook version... And when or how office 2010 is coming into the mix.

By the way, it might be better as a new forum thread, rather than joining on to this.

+1
Login to vote
phaul's picture

Hi Guys,

I having trouble while creating a enterprise vault package package. I noticed that EV admin service is not stopping.

This is the log that had been created and also screenshot of the error.

Hope it helps.

1/19/2013 7:41:06 PM Task "Check if Enterprise Vault core services are installed." Started
1/19/2013 7:41:06 PM Task "Check if Enterprise Vault core services are installed." Completed
1/19/2013 7:41:06 PM Task "Check Enterprise Vault version." Started
1/19/2013 7:41:06 PM Enterprise Vault Version is 9.0.4.1097
1/19/2013 7:41:06 PM Enterprise Vault Version check passed
1/19/2013 7:41:06 PM Task "Check Enterprise Vault version." Completed
1/19/2013 7:41:06 PM Enterprise Vault core services configured
1/19/2013 7:41:06 PM Task "Check if Vault Service Account is configured" Started
1/19/2013 7:41:07 PM Can get VSA account from EV services
1/19/2013 7:41:07 PM Task "Check if Vault Service Account is configured" Completed
1/19/2013 7:41:07 PM returning mode Export
1/19/2013 7:41:11 PM Check DNS address starts...
1/19/2013 7:41:11 PM Server alias evserver.exchange.com resolved to 192.168.3.21, returning True
1/19/2013 7:41:11 PM Check DNS address ends.
1/19/2013 7:41:14 PM Built package name EVServerMigration_Settings_evserver_20130119T1941.evsmp
1/19/2013 7:41:31 PM Created settings package named E:\packge\EVServerMigration_Settings_evserver_20130119T1941.evsmp
1/19/2013 7:41:32 PM Check available disk space ends.
1/19/2013 7:41:35 PM Created settings package named E:\packge\EVServerMigration_Settings_evserver_20130119T1941.evsmp
1/19/2013 7:41:35 PM Check available disk space ends.
1/19/2013 7:41:39 PM Export EV server settings started
1/19/2013 7:41:39 PM Task "Create migration package" Started
1/19/2013 7:41:39 PM Created settings package named E:\packge\EVServerMigration_Settings_evserver_20130119T1941.evsmp
1/19/2013 7:41:39 PM Task "Create migration package" Completed
1/19/2013 7:41:39 PM Task "Stop Enterprise Vault Services" Started
1/19/2013 7:41:39 PM Stopping Enterprise Vault Services
1/19/2013 7:42:53 PM StopServices failed: The requested control is not valid for this service
1/19/2013 7:42:53 PM Task "Stop Enterprise Vault Services" Failed

1/19/2013 7:42:53 PM Task "Export Server Settings" Started
1/19/2013 7:42:54 PM Task "Export Server Settings" Completed
1/19/2013 7:42:54 PM Task "Export Enterprise Vault Registry" Started
1/19/2013 7:42:54 PM Task "Export Enterprise Vault Registry" Completed
1/19/2013 7:42:54 PM Task "Export Enterprise Vault Components" Started
1/19/2013 7:42:54 PM Starting DSN export
1/19/2013 7:42:54 PM adding DSN EnterpriseVaultDirectory
1/19/2013 7:42:54 PM adding DSN EVVaultStoreJournal
1/19/2013 7:42:54 PM adding DSN EVITSMEVaultStore
1/19/2013 7:42:54 PM Wrote 3 DSNs to EVDSN document
1/19/2013 7:42:54 PM Task "Export Enterprise Vault Components" Completed
1/19/2013 7:42:54 PM Task "Export Server Files" Started
1/19/2013 7:42:54 PM Starting file export
1/19/2013 7:42:54 PM License files export started
1/19/2013 7:42:54 PM License files export completed
1/19/2013 7:42:54 PM Filters files export started
1/19/2013 7:42:55 PM Filters files export completed
1/19/2013 7:42:55 PM Shortcut files export started
1/19/2013 7:42:55 PM Shortcut files export completed
1/19/2013 7:42:55 PM Messages files export started
1/19/2013 7:42:55 PM Messages files export completed
1/19/2013 7:42:55 PM WebConfig files export started
1/19/2013 7:42:55 PM WebConfig files export completed
1/19/2013 7:42:55 PM NetConfig files export started
1/19/2013 7:42:55 PM NetConfig files export completed
1/19/2013 7:43:32 PM Operation files export started
1/19/2013 7:43:32 PM Operation files export completed
1/19/2013 7:43:32 PM OWAServers files export started
1/19/2013 7:43:32 PM OWAServers files export completed
1/19/2013 7:43:32 PM Dtrace files export started
1/19/2013 7:43:33 PM Dtrace files export completed
1/19/2013 7:43:33 PM Export pea files starting
1/19/2013 7:43:33 PM exported 0 pea files
1/19/2013 7:43:33 PM File export ended
1/19/2013 7:43:33 PM Task "Export Server Files" Completed
1/19/2013 7:43:33 PM Task "Export Report Files" Started
1/19/2013 7:43:33 PM Export reports starting
1/19/2013 7:43:33 PM exporting report file evomdb_updates.log
1/19/2013 7:43:33 PM Created report package E:\packge\EVServerMigration_Reports1_evserver_20130119T1941.evsmr
1/19/2013 7:43:33 PM exporting report file FSAReportingWebServiceConfigUtility.log
1/19/2013 7:43:33 PM exporting report file MonitoringConfigUtility 2012-10-16 23-33-32.log
1/19/2013 7:43:33 PM exporting report file UpgradeEVServerToV8.0 2012-12-05 21-20-35.log
1/19/2013 7:43:33 PM exporting report file Upgrade_DesktopSettings 2012-10-16 23-40-05.log
1/19/2013 7:43:33 PM exporting report file EvAzUtil_20121205212311.txt
1/19/2013 7:43:33 PM exporting report file EvAzUtil_20121213001534.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange 20121203000009.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange 20121203001210.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange 20121204000004.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange 20121204005349.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange 20121205000008.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report Only for exchange 20121024000133.txt
1/19/2013 7:43:33 PM exporting report file PstColTask_EVSERVER_20121204202246.txt
1/19/2013 7:43:33 PM exporting report file PstColTask_EVSERVER_20121204210125.txt
1/19/2013 7:43:33 PM exporting report file PstLocTask_EVSERVER_20121204010738.txt
1/19/2013 7:43:33 PM exporting report file PstLocTask_EVSERVER_20121204201942.txt
1/19/2013 7:43:33 PM exporting report file PstLocTask_EVSERVER_20121204210044.txt
1/19/2013 7:43:33 PM exporting report file PstLocTask_EVSERVER_20121204210117.txt
1/19/2013 7:43:33 PM exporting report file PSTMig_20121204211149.txt
1/19/2013 7:43:33 PM exporting report file PSTMig_20121204212902.txt
1/19/2013 7:43:33 PM exporting report file PSTMig_20121204213620.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange_20121207000142.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange_20121207001352.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange_20121207001446.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange_20121213001530.txt
1/19/2013 7:43:33 PM exporting report file Exchange Provisioning Task Report for exchange_20121219005756.txt
1/19/2013 7:43:33 PM Export reports ended
1/19/2013 7:43:33 PM Task "Export Report Files" Completed
1/19/2013 7:43:34 PM Writing report documents to export package started
1/19/2013 7:43:34 PM Server Details report creation started
1/19/2013 7:43:34 PM Server details report creation succeeded
1/19/2013 7:43:36 PM Report image file failed_sm.gif written to package
1/19/2013 7:43:36 PM Report image file info_sm.gif written to package
1/19/2013 7:43:36 PM Report image file passed_sm.gif written to package
1/19/2013 7:43:36 PM Report image file Logo_150x61.png written to package
1/19/2013 7:43:36 PM Report image file warning_sm.gif written to package
1/19/2013 7:43:36 PM Documents for report ExportReport_20130119T1941.html written to package
1/19/2013 7:43:36 PM Write Server Settings Migration Wizard log file to export package
1/19/2013 7:43:36 PM Export server failed
 

export_failed.JPG
0
Login to vote
Rob.Wilcox's picture

Why not just stop the services manually?

+1
Login to vote
phaul's picture

Hi Rob,

Thanks for your suggestion it works I thought EV admin services needs to be running before creating package.

Thanks.

0
Login to vote
Rob.Wilcox's picture

Ah okay, no it doesn't need to be running.

Glad you got it sorted out.

0
Login to vote
John Santana's picture

Is this tool still applicable for EV 9.0 upgrade to EV 10.0.4 ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

0
Login to vote