截屏视频帮助

Execute a command under Windows 7

创建时间: 06 8 月 2012 | 3 条评论

I have read this:

http://www.symantec.com/business/support/index?pag...

and guess that this is my problem, but has anyone had any luck fixing this? I am using AutoIT exes to start a VMWare image, but I have disabled the Interacive Services Detection service and the task still does nothing. I can't even find out why. The logs show Ghost ran everything successfully, but the exe is still not run at all. I don't even get the Windows popup for it anymore.

评论 条评论跳转至最新评论

EdT 的图片

This is a standard feature of Windows 7 as Microsoft no longer support the interaction of services with the desktop. This is a security measure.

I refer you to :

http://msdn.microsoft.com/en-us/windows7trainingcourse_sessionisolation_unit.aspx

and

http://msdn.microsoft.com/en-us/library/windows/hardware/gg463353.aspx

For a service to interact with the desktop it is now necessary to provide a coded solution - for example, you have a separate process running in the user context that communicates with the service using one of the available communications options, eg Named Pipes.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

msassoon 的图片

Wow! I will have to read up on this to figure out how to do all that. Thanks.

msassoon 的图片

Ok, I managed to hack my way around this.

I created a batch file that runs PSExec and used the -i to start the command in Session 1:

PSExec -h -i 1 C:\VMWare\vmware.exe

This ensures I can see it. The only odd thing is that VMWare starts as SYSTEM but with a session id of 1. I may try the -u -p commands to run as Administrator.