截屏视频帮助

How does it work: Deployment Scanner

创建时间: 19 3 月 2013 • Updated: 02 4 月 2013 | 8 条评论
STHN 的图片
此问题已解决。 请查看解决方案。

Hi folks!

Does anyone have a clue, how exactly deployment scanner findy out what has been installed on a system?

I'm asking because according to DS results neither IIS nor EV are installed on a EV server that has been runnung for some time now. EV and IIS are installed.

Another issue is that a newly created archive task fails because - according to EV-logs - there is an unsupported Outlook version installed.

I've double-checkd it. The outlook version is correct.

EV-Version is 10.0.1

Outlook version is 2007 SP3 with AttachmentMax and RecipientMax are configured.

I wonder if there is anything that determines installed software. It that thing is broke it would explain our issues.

Thanks in advance!

评论 条评论跳转至最新评论

TonySterling 的图片

Where are you running the Deployment Scanner from and are you running the Deployment Scanner logged in as the Vault Service account?   You should be running it on the EV server logged in as VSA.

What version of the Deployment Scanner are you running?  I haven't had any issues with DS so I would tend to think it isn't an issue with the scanner but rather something environmental to your system.

Chris Warren 的图片

Also, I believe DS is no longer publicly distributed so updates, especially for recent versions of EV (10) may be... quirky :)

TonySterling 的图片

Hi Chris,

Could you clarify what you mean?  Deployment Scanner is part of the installation media as recent as EV 10 SP3.

Regards,

Chris Warren 的图片

Ack...  I was thinking the Deployment Scanner Support tool (DSS) that was pulled.  Sorry for the confusion - need more caffeine!

Thanks for the sanity check Tony.

Rob.Wilcox 的图片

Deployment Scanner uses a variety of techniques to get information about the system, and components.. for example checking file properties, and looking for values in the registry.

With regards to the Outlook check .. what version of Outlook.exe are actually running?

STHN 的图片

Thanks for all the feedback. Someone else is now working on it. So I cannot provide information.

Seems it is an issue with the installation. Currently Outlook and EV binaries are beeing reinstalled.

PMCS GmbH & Co. KG - Consulting und Support für Altiris/SEP/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!

JesusWept3 的图片

Typically outlook versions and stuff like that are pulled from registry
SQL stuff tends to be direct queries on SQL Server itself
there are also some WMI calls as well, but its typically registry for the most part, so if you have this issue again, look at running a procmon.

It could also be that UAC is blocking the account, and you might want to run the DS with elevated permissions (i.e Run As Administrator), especially if it starts looking at the \SOFTWARE\ registry key as UAC will start to use Virtualized registry paths which really can mess things up

解决方案