截屏视频帮助

Important services started and set to Manual without the option to change

创建时间: 22 1 月 2013 • Updated: 22 1 月 2013 | 20 条评论
此问题已解决。 请查看解决方案。

In the most recent version of SEP, I have come across this a couple of times, the services are there, but they are started and set to manual, you can not stop or restart the service and you can not change the order from manual to automatic. This is really annoying if I have to make some changes to a remote PC or server. Why is this like this now and can it be changed? I think we should have the option to select the service(s) and how it works.

The one I really dislike is the fact that the management client is set up like this.

评论 条评论跳转至最新评论

Brɨan 的图片

What happens when you right click it and select Properties?

From here, you can set it to Automatic, Manual or Disabled

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Brɨan 的图片

Turn off tamper protection and give it another try.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Brɨan 的图片

Seems that the ability to change (or not change) is hard-coded within SEP. You can look at the SmcService folder in the registry located under HKLM\System\CurrentControlSet\Services

You would probably need to edit the Start or Type REG_DWORD value but I'm not exactly sure which

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

The Conquistador 的图片

DO NOT like this change!!!!

With the ability to stop the SMC service from a remote location, I could at least get out the correct Sylink.xml to client PC's and servers, now with this change, I will have INTERUPT a user or go on a server via a remote connection. I am NOT happy with this at all.

Brɨan 的图片

I just confirmed you can do it in the registry. Change the value to one of the below:

2 = Automatic

3 = Manual

4 = Disabled

But it looks to be hard coded

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

The Conquistador 的图片

Change, what exactly? Where? I am at the services folder in the registry then that is where I trail off and have no clue.

Brɨan 的图片

Under Services, you should see another folder called SmcService

When you click on it, you should see a key called Start

Change that to 2 and click OK

Check the service again, should now be showing automatic

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Brɨan 的图片

And tamper protection is off? I got the same message but once I turned off tamper protection I could make the change.

Are you admin of the box?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

The Conquistador 的图片

Changing it to 2 only made the service automatic, I want the ability to stop and restart that service WITHOUT accessing a users PC.

Even on MY PC the option is greyed out.

I do not like this change at all!!!

Brɨan 的图片

The only thing I can think of is using the SEPM to replace it remotely.

I have a script which restarts SMC but not stop than start

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Brɨan 的图片

You can replace the sylink file automatically with 12.1.2. There is now an option to do this

On the Client page, click Add Client

Select the last option at the bottom "Communication Update Package Deployment"

This will do it for you now.

Check this article:

Restoring client-server communications by using a client installation package

padding: 1px;padding-bottom: 3px ;font: 12px Arial; text-align: left;color: #666666; background-color:#f2f2f2">Article:HOWTO81455 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2;"> |  padding: 0px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2;">Created: 2012-10-25 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2"> |  padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2">Updated: 2012-12-20 padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2"> |  padding: 1px;font: 12px Arial; text-align: left;color: #666666;background-color:#f2f2f2">Article URL http://www.symantec.com/docs/HOWTO81455

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

解决方案
Brɨan 的图片

Nevermind just found it...

Go to the key I mentioned above.

Click on the Start REG_DWORD and change the value to 2

Open services.msc and SMC should now be set to automatic

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

SebastianZ 的图片

Its is hard coded - and it hasn't changed much since the first release of 12.1 - you cannot turn of or on the SMC from services console - this can only be done with admin right from command prompt:

* smc -stop

* smc -start

..or in case it is not working on some systems:

http://www.symantec.com/docs/TECH177584

The Conquistador 的图片

I used to be able to do so, and by doing smc -stop and smc -start, that requires actually BEING on the PC or server that needs to have the update, which is intrusive to their work.