截屏视频帮助

tpconfig not working on Media Server

创建时间: 07 4 月 2013 • Updated: 07 4 月 2013 | 4 条评论
此问题已解决。 请查看解决方案。

Hi All,

I am having some weried issue on one of the media server.

Output of vmoprcmd is displaying the Output, tpautoconf is also giving the output but when i try to run tpconfig it does not come up with any result.

I have tried tpconfig, tpconfig -d , tpconfig -delete -drive etc..

This media server have several drives configured on it...Backups are also going through fine from this media server.

But No Luck..Please assist

Media Server : sun os. NBU-7.1

操作系统:

评论 条评论跳转至最新评论

Marianne 的图片

Check size of tpconfig binary. Compare with another media server on same OS and NBU version.
I have seen this where binary got corrupted and file size was 0.

Copy binary from another same version media server.

If binary size is correct, we will need to dig a bit deeper....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

解决方案
nbu123 的图片

Thanks Marianne..

You were correct size of tpconfig is 0.

i have copied it and now we are getting output of tpconfig

Ankit Maheshwari 的图片

very first you need to check the size of tpconfig file this could be corrupted.

Ankit Maheshwari 

Ankit Maheshwari

Marianne 的图片

Please ensure that all NBU paths are added to your PATH variable so that it is never necessary to cd to binary paths.

The following actions WILL result in tpconfig filesize of 0:
cd /usr/openv/volmgr/bin
tpconfig -d > tpconfig

The above command will create a blank file called tpconfig, and then look to the left for what to put in the file. Any output should always be saved in /tmp and always have and extension, like .txt or .out.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links