1. /
  2. Products & Solutions/
  3. Products/
  4. Mobile Security and Management Product Family/
  5. Managed PKI Service

Symantec Managed PKI Service

Lower Cost and Complexity with a Managed, Cloud-Based Solution

Symantec, the leading provider of cloud-based PKI solutions, delivers a proven and trusted solution to secure mission-critical interactions. Built on Symantec’s proven, globally managed, highly reliable infrastructure, Symantec Managed PKI Service reduces the cost and complexity associated with in-house PKI and focuses enterprises on delivering solutions, instead of infrastructure.

PKI Manager

Supported web browsers

  • On Windows 7 (32-bit and 64-bit)
    Microsoft Internet Explorer 8 or 9
    Mozilla Firefox 10.0.3 or 14
  • Windows XP SP3 (32-bit)
    Internet Explorer 8
    Mozilla Firefox 10.0.3 or 14

PKI Certificate Service

Supported web browsers

  • On Windows 7 (32-bit and 64-bit)
    Microsoft Internet Explorer 8 or 9
    Mozilla Firefox 10.0.3 or 14
  • Windows XP SP3 (32-bit)
    Internet Explorer 8
    Mozilla Firefox 10.0.3 or 14
  • Mac OS X v10.7
    Safari 5.1
    Mozilla Firefox 10.0.3 or 14
  • Mac OS X v10.8
    Safari 6
    Mozilla Firefox 10.0.3 or 14

PKI Enterprise Gateway

Supported Operating Systems

  • Microsoft Windows Server 2008 R2 (64 bit)
  • Microsoft Windows Server 2008 R2 SP1 (64 bit)

Supplementary Required Components

  • IIS 7.5 or above roles added with the following roles services:
    IIS 6 management compatibility
    Windows Authentication
  • .NET Framework 4.0
  • Server must be part of a domain with Active Directory installed or Novell eDirectory 8.8.5

Supported Hardware Security Modules

  • Luna SA/Luna SA Hybrid (PED Auth), Client version 4.4.3-1, Firmware version 4.8.1
  • Luna PCI Key Export Mode/Signing with Backup, Client version 3.0, Firmware version 4.7.1
  • Luna PCI and PCI Express (3000 signing) Client version N/A, Firmware 4.7.1

PKI Client

Supported web browsers

  • On Windows 7 SP1 (32-bit and 64-bit)
    Microsoft Internet Explorer 8 or 9
    Mozilla Firefox 10.0.3 or 14
  • Windows XP SP3 (32-bit)
    Internet Explorer 8 or 9
    Mozilla Firefox 10.0.3 or 14
  • Mac OS X v10.7
    Safari 5.1
    Mozilla Firefox 10.0.3 or 14
  • Mac OS X v10.8
    Safari 6
    Mozilla Firefox 10.0.3 or 14

iOS devices

  • iOS 4 and iOS 5
    iPhones (3rd and 4th generation)
    iPads (1st and 2nd generation)

Android devices

  • Android OS ICS 4.0
    Samsung Galaxy S II and S II Skyrocket
    Samsung Galaxy Tab 2 7.0
    Samsung Galaxy Tab 7.0 Plus, 7.0 Plus Si-Fi, or 7.7
    Samsung Galaxy Tab 10.1
    Samsung Galaxy S III
    Samsung Galaxy Note
    Nexus 7
    Nexus S 4G
    Galaxy nexus
    Motorola Xoom
    Motorola Droid RAZR
    Motorola XYBOARD 10.1
  • VPN Client (required)
    AnyConnect ICS+ (all supported devices)
    Samsung AnyConnect (Samsung devices)