1. /
  2. Security Response/
  3. FastTrack P2P Supernode Packet Handler Buffer Overflow Vulnerability

FastTrack P2P Supernode Packet Handler Buffer Overflow Vulnerability

Risk

High

Date Discovered

May 26, 2003

Description

FastTrack P2P Supernode Packet Handler has been reported prone to a buffer overflow vulnerability. The issue presents itself in the FastTrack Supernode packet handler. The handler does not perform sufficient bounds checking on supernode entries received before they are copied into a reserved buffer in internal memory. An attacker may exploit this vulnerability to trigger a denial of service condition or ultimately have arbitrary attacker supplied code executed. Code execution would occur in the context of the user running an application that incorporates the vulnerable FastTrack P2P Packet Handler. It should be noted that this vulnerability has been tested on KaZaA version 2.0.2. Other versions of KaZaA and similar file-sharing clients based on FastTrack P2P technology may also be affected.

Technologies Affected

  • Grokster Grokster 1.3.0
  • Grokster Grokster 1.3.3
  • KaZaA KaZaA Media Desktop 1.3.0
  • KaZaA KaZaA Media Desktop 1.3.1
  • KaZaA KaZaA Media Desktop 1.3.2
  • KaZaA KaZaA Media Desktop 1.6.1
  • KaZaA KaZaA Media Desktop 2.0.0
  • KaZaA KaZaA Media Desktop 2.0.2
  • Music City Networks Morpheus 1.3.0
  • Music City Networks Morpheus 1.3.3
  • Music City Networks Morpheus 1.9.0
  • iMesh.Com iMesh 1.0.0 2
  • iMesh.Com iMesh 3.1.0

Recommendations

Block external access at the network boundary, unless external parties require service.

If applicable, block all incoming FastTrack P2P based traffic at the network boundary.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.

Deploy network intrusion detection systems and audit logs regularly.

Run all software as a nonprivileged user with minimal access rights.

If possible, reduce the privilege level of this and other server processes. This will limit the immediate consequences of a successful attack.

Implement multiple redundant layers of security.

An attackers ability to exploit this vulnerability, to execute arbitrary code, may be hindered through the use of various memory protection schemes. Where possible, implement the use of non-executable and randomly mapped memory segments.
The pending release of a patch to address this issue in KaZaA has been reported. Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

Credits

Discovery of this vulnerability has been credited to random nut .
Copyright © Symantec Corporation.
Permission to redistribute this alert electronically is granted as long as it is not edited in any way unless authorized by Symantec Security Response. Reprinting the whole or part of this alert in any medium other than electronically requires permission from secure@symantec.com.

Disclaimer
The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.
Symantec, Symantec products, Symantec Security Response, and secure@symantec.com are registered trademarks of Symantec Corp. and/or affiliated companies in the United States and other countries. All other registered and unregistered trademarks represented in this document are the sole property of their respective companies/owners.

Threat Intelligence

Subscribe
Follow the Threat Intelligence Twitter feed
STAR Antimalware Protection Technologies
Internet Security Threat Report
Symantec DeepSight Screensaver