Storage Foundation for Windows High Availabitlity 5.1 SP 2 EMC MirrorView agent fails to online

Article:TECH154448  |  Created: 2011-02-28  |  Updated: 2011-06-17  |  Article URL http://www.symantec.com/docs/TECH154448
Article Type
Technical Solution


Environment

Issue



EMC Veritas Cluster Server (VCS) MirrorView agent checks if naviseccli.exe is installed. If it does not find naviseccli.exe, the agent checks the presence of navicli which in turn needs Java Runtime Environment (JRE). If JRE is not installed on the node, the agent fails to bring the resource online.

 


Error



V-16-20048-91 (nodename) MirrorView:<resourcename>-MirroView:clean:Can't open keys SOFTWARE\Wow6432Node\Veritas\VRTSjre

V-16-20048-92 (nodename) MirrorView:<resourcename>-MirroView:clean:Can't open keys SOFTWARE\Veritas\VRTSjre

VCS ERROR V-16-20048-94 (nodename) MirrorView:MIRRORVIEW:online:Java home is not found hence exiting


Environment



Storage Foundation for Windows High Availability (SFW-HA) 5.1 Service Pack (SP) 2

VCS 5.1 SP2

Microsoft Windows Server 2003

Microsoft Windows Server 2008

 


Cause



VCS MirrorView agent checks if naviseccli.exe is installed. If it does not find naviseccli.exe, the agent checks the presence of navicli which in turn needs Java Runtime Environment (JRE). If JRE is not installed on the node, the agent fails to bring the resource online.
 


Solution



This issue is fixed in the updated VCS MirrorView agent fix related to this article
With the secure naviseccli, JRE is no longer required. The agent does not check for JRE on the cluster node.

This issue has been identified and a private fix is available from Symantec Enterprise Technical Support. To obtain the private fix, contact Symantec Support and reference this TechNote during the call. A support representative will be available to assist in troubleshooting this issue. If it is determined that the private fix addresses the problem, the support representative will further assist in obtaining the private fix. For a complete list of Symantec Enterprise Technical Support contact numbers, go to http://www.symantec.com/enterprise/support/index.jsp


Supplemental Materials

SourceETrack
Value2271435
Description

MirrorView Agent does not work with SFW-HA 5.1 SP2



Article URL http://www.symantec.com/docs/TECH154448


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