Storage agent service terminates unexpectedly with Storage Foundation for Windows 5.1 SP2

Article:TECH159931  |  Created: 2011-05-12  |  Updated: 2012-02-07  |  Article URL http://www.symantec.com/docs/TECH159931
Article Type
Technical Solution

Environment

Issue



After the SFW 5.1 SP2 installation, the Storage Agent fails to start. The Storage Agent uses a SCSI inquiry to get information from the disks, and in some cases, it is observed that Storage Agent crashes while releasing memory for the buffer passed to collect this information.
 


Error



Storage agent service fails to start

Error 1067 Service terminated unexpectedly.

From the Vxisis log for SFW it is observed that the ddlprov.dll fails to load during startup of the service.

4/24/2011 3:48:44 AM:5856:CDdlprov: Exiting Initialize(). er=0
4/24/2011 3:48:44 AM:5856:ddlprov:Version - DDL Provider version WINNT.5.1.20000.87
4/24/2011 3:48:44 AM:5856:LoadProvider: provider ddlprov loaded
4/24/2011 3:48:44 AM:5856:LoadProvider: load failed for provider vxvm. error = 0xc1000004
4/24/2011 3:48:44 AM:5856:LoadProvider: load failed for provider cluster. error = 0xc1000004

Error 0xc1000004 = dll/image file is missing, but the files do exist and are located in their proper location.
 

 


Environment



Storage Foundation for Windows 5.1 Sp2

Storage Foundation for Windows with MSCS/ WFC 5.1 SP2

Storage Foundation for Windows HA 5.1 Sp2


Cause




Aligned the buffer records on 16 byte boundaries. This ensures that the data structures passed down between native drivers and providers are in sync. Additionally, it also saves the effort of relying on data translation done by WOW64 when code is running on 32-bit emulation mode.


Solution



This issue has been identified and a private fix is available from Symantec Enterprise Technical Support. To obtain the private fix, contact Symantec Support and reference this TechNote during the call. A support representative will be available to assist in troubleshooting this issue. If it is determined that the private fix addresses the problem, the support representative will further assist in obtaining the private fix. For a complete list of Symantec Enterprise Technical Support contact numbers, go to http://www.symantec.com/business/support/index?page=home


Supplemental Materials

SourceETrack
Value2364591


Article URL http://www.symantec.com/docs/TECH159931


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