"Unable to connect to the Database" error while upgrading SCSP Server from 5.2.8 to 5.2.9

Article:TECH196978  |  Created: 2012-09-20  |  Updated: 2013-05-28  |  Article URL http://www.symantec.com/docs/TECH196978
Article Type
Technical Solution

Product(s)

Environment

Issue



You have downloaded SCSP 5.2.9 source, and you ran server.exe file on your SCSP Server in order to upgrade it, but upgrade fails at database credentials stage. You confirmed credentials are correct by using osql command and connecting to SCSP database via SQL Server Management Studio.

SQL Server error log do not show login failure event. SQL Browser service is started on database server. If you cancel upgrade wizard, you can log in to 5.2.8 console and manage your agents without any issue.

 


Error



"Unable to connect to the Database with the specified username and password. Please verify the Database settings"

 

 


Environment



SCSP 5.2.8 with remote SQL Server database, using a custom port.
Default SQL Server instance is used (MSSQLSERVER).

 


Cause



SCSP upgrade wizard is unable to reach database server.

 


Solution



1. Open SQL Server Configuration Manager on SCSP Server side.

 

2. Go to Aliases

 

3. Configure an alias as follow:

     - Alias name: [SQLSERVERNAME]\MSSQLSERVER

     - Server: [SQLSERVERNAME]

     - Protocol: TCP

     - Parameters: custom SQL Server port

 

 4. Run the upgrade

 




Article URL http://www.symantec.com/docs/TECH196978


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