DA customer database upgrade from 8.0 SP5 to 9.0 fails with 'Error converting data type from bigint to int'

Article:TECH203384  |  Created: 2013-02-28  |  Updated: 2014-05-19  |  Article URL http://www.symantec.com/docs/TECH203384
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Article Type
Technical Solution

Product(s)

Issue



Enterprise Vault (EV) Discovery Accelerator (DA) customer database upgrade from 8.05 to 9.04 fails with 'Error converting data type from bigint to int'.


Error



Error converting data type from bigint to int


Environment



- Enterprise Vault 8.0 SP5 on Windows Server 2008R2.

- Discovery Accelerator 8.0 SP5 on Windows Server 2008R2 with Enterprise Vault 8.0 SP5 binaries only installed.

- Microsoft SQL Server 2005 hosting the EV and DA databases.

 


Cause



During the upgrade process, line 77 if the file AcceleratorConfigurationScripts.sql executes to upgrade part of the DA Customer database.  This is seen in the status update field on the DA Customer properties when viewed through the EVBAAdmin site.  The status field contains the information similar to the following:

Script: C:\Program Files (x86)\Enterprise Vault Business Accelerator\AcceleratorConfigurationScripts.sql executing line 77

Line 77 of the AcceleratorConfigurationScripts.sql file is the execution initiator for a stored procedure that processes updates to table statistics.  This stored procedure calls another stored procedure that performs the table statistics update processing using a set of variable arguments that include:

@LastRowCount = @Rowcnt

The '@Rowcnt' variable is cast as data type 'BIGINT'.  The '@LastRowCount' variable is cast as data type 'INT'.  When data in the '@Rowcnt' variable is in the 'INT' data range, there is no issue passing this data from the calling stored procedure to the called stored procedure; however, when the data in the '@Rowcnt' variable is in the 'BIGINT' data range - which can happen with Analytics enabled cases - the process of passing this data to the called stored procedure attempts to convert that data to the 'INT' data range and fails as the data are too big.

This error could occur when upgrading from any version of DA with Analytics enabled cases.

 


Solution



This issue has been addressed in the following release:

Symantec Enterprise Vault 11.0 0 Release Details
http://www.symantec.com/docs/DOC7401


Supplemental Materials

SourceETrack
Value3106860
Description

Discovery Accelerator upgrade fails with "Error converting data type from bigint to int".




Article URL http://www.symantec.com/docs/TECH203384


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