BUG REPORT: Unable to boot Apple MacBook Air 5,2 Model after v1.2 Thunderbolt Firmware Update with Symantec Drive Encryption (formerly PGP Whole Disk Encryption) installed

Article:TECH206300  |  Created: 2013-05-16  |  Updated: 2013-08-13  |  Article URL http://www.symantec.com/docs/TECH206300
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Article Type
Technical Solution


Environment

Issue



After running v1.2 Thunderbolt Firmware update on an Apple MacBook Air 5,2 (Mid 2012) running Mac OS X 10.8.3 and Symantec Drive Encryption or PGP Whole Disk Encryption, the system is unable to boot. If you boot in verbose mode you will see an error on the screen (listed below).

Error



 Prohibitory sign in regular boot mode:

When booting into a more verbose boot you will see it stop at "still waiting for root device". The error keeps repeating:


Environment



  • Apple Mac OS X 10.8.3 with v1.2 Thunderbolt Firmware Update
  • Symantec Drive Encryption 10.3.0, 10.3.0 MP1; PGP Whole Disk Encryption 10.2.1 MP5

This issue appears to be confined to the 2012 5,2 Model 13" MacBook Air model only.

Following is a table containing the results of testing at this time:

 

Model tested

Model Identifier Products Tested State
MacBook Air (13-inch, Mid 2012) MacBookAir5,2 Drive Encryption 10.3.0 MP1, 10.3.0; PGP WDE 10.2.1 MP5 Varied success (1 failure)
MacBook Air (13-inch, Mid 2011) MacBookAir4,2 Drive Encryption 10.3.0 MP1 Working
MacBook Pro (Retina,15-inch, Mid 2012) MacBookPro10,1 Drive Encryption 10.3.0 MP1, 10.3.0; PGP WDE 10.2.1 MP5 Working
MacBook Pro (15-Inch,Mid 2011) MacBookPro8,2 Drive Encryption 10.3.0 MP1 Working
MacBook Air (11-inch, Mid 2011) MacBookAir 4,1 Drive Encryption 10.3.0 MP1 Working
MacMini (Core i5, 2011) MacMini5,1 Drive Encryption 10.3.0 MP1, 10.3.0 Working
iMac iMac (21.5-inch, Mid 2011) iMac12,1 Drive Encryption 10.3.0 MP1, 10.3.0 Working

 


Cause



Thunderbolt Firmware Update not working correctly with the Symantec Drive Encryption Driver (pgpwde.kext)


Solution



Symantec Corporation is committed to product quality and satisfied customers. This issue is currently being considered by Symantec Corporation to be addressed in a forthcoming version or Maintenance Pack of the product.  Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

The following is a known temporary workaround for the issue until the version/maintenance pack is released:

Scenario 1 The drive is encrypted and won't boot

Scenario 1 - Option A: Using the Recovery CD with an External USB drive

Note: To recover from this method you need access to a USB CD/DVD-ROM drive

Warning: Using the Recovery CD method can take several days to recover, depending on the size of the drive.

  1. Download Symantec Drive Encryption Recovery Images found in this article
  2. Boot the recovery CD.
  3. To decrypt the drive, press "D" to begin the decryption.
  4. Once you are decrypted, follow steps in Scenario 2.

Scenario 1 - Option B: Using Target Disk Mode via FireWire with a Thunderbolt to FireWire adapter

Note: Using this recovery method requires physical access to another Mac OS X system that you can use to control the affected MacBook Air which has a FireWire port and also access to a Thunderbolt to FireWire adapter.

  1. Attach a Thunderbolt to FireWire adapter/cable to the Mac you are controlling the affected MacBook Air with.
  2. Recover the system using Target Disk Mode. For this option please see this article on recovery via Target Disk Mode.
  3. Once you are decrypted, follow the steps in Scenario 2.

Scenario 2  The drive is not encrypted and will not boot

Since the drive is not encrypted in this scenario, it is possible to boot into the recovery partition or use the Mac OS X installation disc and then open up a terminal utility and move the PGPwde.kext from /System/Library/Extensions to another location. You can then reboot the system. Symantec Drive Encryption (or PGP Whole Disk Encryption) is still installed at this point, but you will not be able to encrypt your disk.


Supplemental Materials

SourceETrack
Value3198755



Article URL http://www.symantec.com/docs/TECH206300


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